Add patch from Yoichi Yuasa to fix IDE on Cobalt.

svn path=/dists/trunk/linux-2.6/; revision=9124
This commit is contained in:
Martin Michlmayr 2007-07-12 10:03:25 +00:00
parent df3048f2a7
commit 697cfb83de
3 changed files with 35 additions and 0 deletions

3
debian/changelog vendored
View File

@ -16,6 +16,9 @@ linux-2.6 (2.6.22-1~experimental.1) UNRELEASED; urgency=low
[ Christian T. Steigies ]
* add module.lds to kernel headers
[ Martin Michlmayr ]
* [mips] Add patch from Yoichi Yuasa to fix IDE on Cobalt.
-- Bastian Blank <waldi@debian.org> Wed, 11 Jul 2007 14:12:35 +0200
linux-2.6 (2.6.22~rc5-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,31 @@
# Upstream status: needs to be reworked
# http://www.linux-mips.org/archives/linux-mips/2007-01/msg00049.html
From: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
Hi Ralf,
This patch has fixed IDE resources problem about Cobalt.
pcibios_fixup_device_resources() changes non-movable resources.
It cannot be changed if there is IORESOURCE_PCI_FIXED in the resource flags.
Yoichi
Signed-off-by: Yoichi Yuasa <yoichi_yuasa@tripeaks.co.jp>
diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/pci/pci.c mips/arch/mips/pci/pci.c
--- mips-orig/arch/mips/pci/pci.c 2006-12-18 15:53:10.735222250 +0900
+++ mips/arch/mips/pci/pci.c 2006-12-18 15:56:59.805538250 +0900
@@ -232,7 +232,8 @@ static void __init pcibios_fixup_device_
int i;
for (i = 0; i < PCI_NUM_RESOURCES; i++) {
- if (!dev->resource[i].start)
+ if (!dev->resource[i].start ||
+ dev->resource[i].flags & IORESOURCE_PCI_FIXED)
continue;
if (dev->resource[i].flags & IORESOURCE_IO)
offset = hose->io_offset;

View File

@ -17,6 +17,7 @@
+ bugfix/mips/sgi-ioc3.patch
+ bugfix/mips/64bit-tulip.patch
+ bugfix/mips/tulip_dc21143.patch
+ bugfix/mips/cobalt-ide-resources.patch
+ features/mips/qemu-vga.patch
+ features/mips/sb1-duart.patch
+ features/arm/ixp4xx-npe-driver-0.3.1.patch