[alpha] add isa_page_to_bus and isa_bus_to_virt defines to complement the

existing isa_virt_to_bus define; untested, but these should all be
straightforward on alpha and defining them is certainly a better option for
getting user feedback than disabling the affected drivers.


svn path=/dists/trunk/linux-2.6/; revision=8599
This commit is contained in:
Steve Langasek 2007-05-17 22:54:25 +00:00
parent 20e6ea9467
commit 6802c6e234
3 changed files with 28 additions and 2 deletions

11
debian/changelog vendored
View File

@ -1,10 +1,17 @@
linux-2.6 (2.6.21-2) unstable; urgency=low
linux-2.6 (2.6.21-2) UNRELEASED; urgency=low
[ Christian T. Steigies ]
* m68k: fix atari scc patch
* m68k: install compressed vmlinuz images so the post-inst script can find it
-- Christian T. Steigies <cts@debian.org> Thu, 17 May 2007 18:06:26 +0200
[ Steve Langasek ]
* [alpha] isa-mapping-support.patch: add isa_page_to_bus and
isa_bus_to_virt defines to complement the existing isa_virt_to_bus
define; untested, but these should all be straightforward on alpha and
defining them is certainly a better option for getting user feedback
than disabling the affected drivers.
-- Steve Langasek <vorlon@debian.org> Thu, 17 May 2007 15:53:31 -0700
linux-2.6 (2.6.21-1) unstable; urgency=low

View File

@ -0,0 +1,18 @@
--- a/include/asm-alpha/io.h 2007-04-25 20:08:32.000000000 -0700
+++ b/include/asm-alpha/io.h 2007-05-16 19:01:44.000000000 -0700
@@ -89,6 +89,7 @@
#endif
#define page_to_phys(page) page_to_pa(page)
+#define isa_page_to_bus page_to_phys
/* This depends on working iommu. */
#define BIO_VMERGE_BOUNDARY (alpha_mv.mv_pci_tbi ? PAGE_SIZE : 0)
@@ -126,6 +127,7 @@
virt = phys_to_virt(address);
return (long)address <= 0 ? NULL : virt;
}
+#define isa_bus_to_virt bus_to_virt
/*
* There are different chipsets to interface the Alpha CPUs to the world.

1
debian/patches/series/2 vendored Normal file
View File

@ -0,0 +1 @@
+ features/alpha/isa-mapping-support.patch