Update to 4.4.6

This commit is contained in:
Ben Hutchings 2016-03-16 13:22:40 +00:00
parent 65a9f754ff
commit 67517892da
5 changed files with 50 additions and 99 deletions

53
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.4.5-1) UNRELEASED; urgency=medium
linux (4.4.6-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* New upstream stable update:
@ -78,10 +78,57 @@ linux (4.4.5-1) UNRELEASED; urgency=medium
- efi: Fix boot crash by always mapping boot service regions into new EFI
page tables (Closes: #815125)
- mm/pat: Fix boot crash when 1GB pages are not supported by cpu
* Revert "drm/radeon/pm: adjust display configuration after powerstate",
which caused a regression on some older hardware
* [armhf] gpio: Enable GPIO_PCF857X as module, needed by TI DRA7xx EVMs
(Closes: #818386)
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.6
- [arm64] account for sparsemem section alignment when choosing vmemmap
offset
- [armel,armhf] mvebu: fix overlap of Crypto SRAM with PCIe memory window
- [armhf] dts: dra7: do not gate cpsw clock due to errata i877
- [armhf] OMAP2+: hwmod: Introduce ti,no-idle dt property
- PCI: Allow a NULL "parent" pointer in pci_bus_assign_domain_nr()
- kvm: cap halt polling at exactly halt_poll_ns
- [x86] KVM: VMX: disable PEBS before a guest entry
- [s390x] KVM: correct fprs on SIGP (STOP AND) STORE STATUS
- [powerpc*] KVM: Book3S HV: Sanitize special-purpose register values on
guest exit
- [x86] KVM: MMU: fix ept=0/pte.u=1/pte.w=0/CR0.WP=0/CR4.SMEP=1/EFER.NX=0
combo
- [x86] KVM: MMU: fix reserved bit check for
ept=0/CR0.WP=0/CR4.SMEP=1/EFER.NX=0
- [s390x] mm: four page table levels vs. fork (CVE-2016-XXXX)
- [s390x] dasd: fix diag 0x250 inline assembly
- tracing: Fix check for cpu online when event is disabled
- jffs2: reduce the breakage on recovery from halfway failed rename()
- ncpfs: fix a braino in OOM handling in ncp_fill_cache()
- ASoC: dapm: Fix ctl value accesses in a wrong type
- ovl: ignore lower entries when checking purity of non-directory entries
- ovl: fix working on distributed fs as lower layer
- wext: fix message delay/ordering
- cfg80211/wext: fix message ordering
- can: gs_usb: fixed disconnect bug by removing erroneous use of kfree()
- iwlwifi: mvm: inc pending frames counter also when txing non-sta
- mac80211: minstrel: Change expected throughput unit back to Kbps
- mac80211: fix use of uninitialised values in RX aggregation
- mac80211: minstrel_ht: set default tx aggregation timeout to 0
- mac80211: minstrel_ht: fix a logic error in RTS/CTS handling
- mac80211: check PN correctly for GCMP-encrypted fragmented MPDUs
- mac80211: Fix Public Action frame RX in AP mode
- [armhf] gpu: ipu-v3: Do not bail out on missing optional port nodes
- [i386/686-pae] mm: Fix slow_virt_to_phys() for X86_PAE again
- Revert "drm/radeon: call hpd_irq_event on resume"
- drm/amdgpu: Fix error handling in amdgpu_flip_work_func.
- drm/radeon: Fix error handling in radeon_flip_work_func.
- Revert "drm/radeon/pm: adjust display configuration after powerstate"
- [powerpc*] powernv: Add a kmsg_dumper that flushes console output on panic
- [powerpc*] powernv: Fix OPAL_CONSOLE_FLUSH prototype and usages
- userfaultfd: don't block on the last VM updates at exit time
- ovl: copy new uid/gid into overlayfs runtime inode
- ovl: fix getcwd() failure after unsuccessful rmdir
- [mips*] smp.c: Fix uninitialised temp_foreign_map
- block: don't optimize for non-cloned bio in bio_get_last_bvec()
- target: Drop incorrect ABORT_TASK put for completed commands
[ Ian Campbell ]
* [arm64] Enable ARCH_HISI (Hisilicon) and the set of currently available

View File

@ -1,22 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 7 Mar 2016 07:55:44 +0000
Subject: Revert "drm/radeon: call hpd_irq_event on resume"
This reverts commit dbb17a21c131eca94eb31136eee9a7fe5aff00d9,
reported to cause regressions (crash/hang) on some systems.
---
drivers/gpu/drm/radeon/radeon_device.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/gpu/drm/radeon/radeon_device.c b/drivers/gpu/drm/radeon/radeon_device.c
index 902b59cebac5..4197ca1bb1e4 100644
--- a/drivers/gpu/drm/radeon/radeon_device.c
+++ b/drivers/gpu/drm/radeon/radeon_device.c
@@ -1744,7 +1744,6 @@ int radeon_resume_kms(struct drm_device *dev, bool resume, bool fbcon)
}
drm_kms_helper_poll_enable(dev);
- drm_helper_hpd_irq_event(dev);
/* set the power state here in case we are a PX system or headless */
if ((rdev->pm.pm_method == PM_METHOD_DPM) && rdev->pm.dpm_enabled)

View File

@ -1,39 +0,0 @@
From: Alex Deucher <alexander.deucher@amd.com>
Date: Tue, 8 Mar 2016 11:31:00 -0500
Subject: Revert "drm/radeon/pm: adjust display configuration after powerstate"
Origin: https://git.kernel.org/linus/d74e766e1916d0e09b86e4b5b9d0f819628fd546
This reverts commit 39d4275058baf53e89203407bf3841ff2c74fa32.
This caused a regression on some older hardware.
bug:
https://bugzilla.kernel.org/show_bug.cgi?id=113891
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
Cc: stable@vger.kernel.org
---
drivers/gpu/drm/radeon/radeon_pm.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
--- a/drivers/gpu/drm/radeon/radeon_pm.c
+++ b/drivers/gpu/drm/radeon/radeon_pm.c
@@ -1075,6 +1075,8 @@ force:
/* update display watermarks based on new power state */
radeon_bandwidth_update(rdev);
+ /* update displays */
+ radeon_dpm_display_configuration_changed(rdev);
/* wait for the rings to drain */
for (i = 0; i < RADEON_NUM_RINGS; i++) {
@@ -1091,9 +1093,6 @@ force:
radeon_dpm_post_set_power_state(rdev);
- /* update displays */
- radeon_dpm_display_configuration_changed(rdev);
-
rdev->pm.dpm.current_active_crtcs = rdev->pm.dpm.new_active_crtcs;
rdev->pm.dpm.current_active_crtc_count = rdev->pm.dpm.new_active_crtc_count;
rdev->pm.dpm.single_display = single_display;

View File

@ -1,32 +0,0 @@
From: Andreas Schwab <schwab@linux-m68k.org>
Date: Fri, 5 Feb 2016 19:50:03 +0100
Subject: powerpc: Fix dedotify for binutils >= 2.26
Origin: https://git.kernel.org/linus/f15838e9cac8f78f0cc506529bb9d3b9fa589c1f
Since binutils 2.26 BFD is doing suffix merging on STRTAB sections. But
dedotify modifies the symbol names in place, which can also modify
unrelated symbols with a name that matches a suffix of a dotted name. To
remove the leading dot of a symbol name we can just increment the pointer
into the STRTAB section instead.
Backport to all stables to avoid breakage when people update their
binutils - mpe.
Cc: stable@vger.kernel.org
Signed-off-by: Andreas Schwab <schwab@linux-m68k.org>
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
---
arch/powerpc/kernel/module_64.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/arch/powerpc/kernel/module_64.c
+++ b/arch/powerpc/kernel/module_64.c
@@ -335,7 +335,7 @@ static void dedotify(Elf64_Sym *syms, un
if (syms[i].st_shndx == SHN_UNDEF) {
char *name = strtab + syms[i].st_name;
if (name[0] == '.')
- memmove(name, name+1, strlen(name));
+ syms[i].st_name++;
}
}
}

View File

@ -132,11 +132,8 @@ debian/revert-cgroup-make-sure-a-parent-css-isn-t-offlined.patch
debian/thermal-fix-abi-change-in-4.4.4.patch
debian/ipv4-fix-abi-change-in-4.4.4.patch
debian/ipv6-fix-abi-change-in-4.4.4.patch
bugfix/all/revert-drm-radeon-call-hpd_irq_event-on-resume.patch
bugfix/powerpc/powerpc-fix-dedotify-for-binutils-2.26.patch
bugfix/x86/drm-i915-Fix-oops-caused-by-fbdev-initialization-fai.patch
debian/revert-libata-align-ata_device-s-id-on-a-cacheline.patch
debian/module-fix-abi-change-in-4.4.5.patch
bugfix/x86/x86-efi-fix-boot-crash-by-always-mapping-boot-servic.patch
bugfix/x86/x86-mm-pat-fix-boot-crash-when-1gb-pages-are-not-supported.patch
bugfix/all/revert-drm-radeon-pm-adjust-display-configuration-af.patch