Add stable release 2.6.32.7

Remove a whole load of patches accepted into this release.

Replace the ALPS 4-directional button patch with a minimal version
that applies on top of 2.6.32.7.

Fix conflict between 2.6.32.7 and vserver in kernel/sched.c by moving
a declaration.


svn path=/dists/trunk/linux-2.6/; revision=15061
This commit is contained in:
Ben Hutchings 2010-01-29 00:31:47 +00:00
parent c929bfe667
commit 673ec2b5f1
5 changed files with 4495 additions and 27 deletions

16
debian/changelog vendored
View File

@ -1,17 +1,6 @@
linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
[ Ben Hutchings ]
* be2net: Add device ids for ServerEngines BladeEngine3
* mpt2sas: Add device ids for LSI SAS2208
* ar9170: Add device id for D-Link DWA 160 A2
* powerpc/fsl: Add device ids for new QoirQ chips
* arm/dm646x: Add hardware id for DM6467 rev 3.x
* hda: Add device ids for Nvidia G2xx series
* smsusb: Add device ids for new Hauppauge devices
* mos7850: Add device ids for new B&B Electronics devices
* ftdi_sio: Add device ids for new B&B Electronics devices
* saa7134: Add device id and description for Asus Europa DVB-T card
* x86/iTCO-wdt: Add device ids for Intel 'Ibex Peak' PCH
* Documentation/3c509: document ethtool support (Closes: #564743)
* Add MODULE_FIRMWARE declarations to several drivers that lacked them
* [x86] Update rt2860sta/rt2870sta firmware loader patch
@ -46,13 +35,14 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
* Force distribution=UNRELEASED in debian/bin/test-patches so that it
works in released source packages
* Add stable release 2.6.32.6
* clockevent: Don't remove broadcast device on halt or CPU hotplug
(Closes: #566547)
* postinst: Enable escape sequences in debconf notes (Closes: #566539)
* Add 3w-sas driver for LSI 3ware 9750 SAS controllers
* aufs2: Update to snapshot from 2010-01-25 (Closes: #567391)
* cdc_ether: Do not set link down initially; not all devices send link
change interrupts
* Add stable release 2.6.32.7:
- clockevent: Don't remove broadcast device on halt or CPU hotplug
(Closes: #566547)
[ Ian Campbell ]
* xen: Enable up to 32G of guest memory on i386.

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,19 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] sched: Fix conflict between 2.6.32.7 and vserver
Make some cosmetic changes to sched.c on top of 2.6.32.7 so that
the vserver patch will still apply.
--- a/kernel/sched.c
+++ b/kernel/sched.c
@@ -1812,8 +1813,9 @@
}
#endif
+static void update_sysctl(void);
+
static void calc_load_account_active(struct rq *this_rq);
-static void update_sysctl(void);
#include "sched_stats.h"
#include "sched_idletask.c"

View File

@ -0,0 +1,59 @@
Based on:
commit 71bb21b677e89a2b438b804231f92b779beda5d7
Author: Maxim Levitsky <maximlevitsky@gmail.com>
Date: Mon Nov 16 22:12:22 2009 -0800
Input: ALPS - add support for touchpads with 4-directional button
The touchpad on Acer Aspire 5720, 5520 and some other Aspire models
(signature 0x73, 0x02, 0x50) has a button that can be rocked in 4
different directions. Make the driver to generate BTN_0..BTN_3 events
in response. The Synaptics driver by default maps BTN_0 and BTN_1 to
up and down, so there should be no visible changes with the old setup
that generated BTN_FORWARD and BTN_BACK (also mapped to up and down).
Signed-off-by: Maxim Levitsky <maximlevitsky@gmail.com>
Signed-off-by: Dmitry Torokhov <dtor@mail.ru>
diff --git a/drivers/input/mouse/alps.c b/drivers/input/mouse/alps.c
index f361106..a3f492a 100644
--- a/drivers/input/mouse/alps.c
+++ b/drivers/input/mouse/alps.c
@@ -61,7 +61,7 @@ static const struct alps_model_info alps_model_data[] = {
/* Dell Latitude E5500, E6400, E6500, Precision M4400 */
{ { 0x62, 0x02, 0x14 }, 0xcf, 0xcf,
ALPS_PASS | ALPS_DUALPOINT | ALPS_PS2_INTERLEAVED },
- { { 0x73, 0x02, 0x50 }, 0xcf, 0xcf, ALPS_FW_BK_1 }, /* Dell Vostro 1400 */
+ { { 0x73, 0x02, 0x50 }, 0xcf, 0xcf, ALPS_4BTN }, /* Dell Vostro 1400 */
};
/*
@@ -241,6 +241,13 @@ static void alps_process_packet(struct psmouse *psmouse)
input_report_key(dev, BTN_BACK, back);
}
+ if (priv->i->flags & ALPS_4BTN) {
+ input_report_key(dev, BTN_0, packet[2] & 4);
+ input_report_key(dev, BTN_1, packet[0] & 0x10);
+ input_report_key(dev, BTN_2, packet[3] & 4);
+ input_report_key(dev, BTN_3, packet[0] & 0x20);
+ }
+
input_sync(dev);
}
@@ -689,6 +696,13 @@ int alps_init(struct psmouse *psmouse)
dev1->keybit[BIT_WORD(BTN_BACK)] |= BIT_MASK(BTN_BACK);
}
+ if (priv->i->flags & ALPS_4BTN) {
+ dev1->keybit[BIT_WORD(BTN_0)] |= BIT_MASK(BTN_0);
+ dev1->keybit[BIT_WORD(BTN_1)] |= BIT_MASK(BTN_1);
+ dev1->keybit[BIT_WORD(BTN_2)] |= BIT_MASK(BTN_2);
+ dev1->keybit[BIT_WORD(BTN_3)] |= BIT_MASK(BTN_3);
+ }
+
snprintf(priv->phys, sizeof(priv->phys), "%s/input1", psmouse->ps2dev.serio->phys);
dev2->phys = priv->phys;
dev2->name = (priv->i->flags & ALPS_DUALPOINT) ? "DualPoint Stick" : "PS/2 Mouse";

View File

@ -1,15 +1,3 @@
+ features/all/be2net-Add-support-for-next-generation-of-BladeEngine.patch
+ features/all/be2net-Add-the-new-PCI-IDs-to-PCI_DEVICE_TABLE.patch
+ features/all/SCSI-mpt2sas-New-device-SAS2208-support-is-added.patch
+ features/all/ar9170-Add-support-for-D-Link-DWA-160-A2.patch
+ features/powerpc/fsl-Add-PCI-device-ids-for-new-QoirQ-chips.patch
+ features/arm/davinci-dm646x-Add-support-for-3.x-silicon-revision.patch
+ features/all/hda-Add-PCI-IDs-for-Nvidia-G2xx-series.patch
+ features/all/smsusb-add-5-Hauppauge-USB-IDs.patch
+ features/all/mos7840-add-device-IDs-for-B-B-electronics-devices.patch
+ features/all/ftdi_sio-add-USB-device-ID-s-for-B-B-Electronics.patch
+ features/all/saa7134-Add-support-for-Asus-Europa-Hybrid-DVB.patch
+ features/x86/iTCO_wdt-Add-support-for-Intel-Ibex-Peak.patch
+ bugfix/all/Documentation-3c509-document-ethtool-support.patch
+ bugfix/all/drm-i915-disable-powersave.patch
+ features/all/module-firmware/0025-tty-declare-MODULE_FIRMWARE-in-various-drivers.patch
@ -30,8 +18,17 @@
+ bugfix/all/e1000e-enhance-fragment-detection.patch
+ bugfix/all/stable/2.6.32.5.patch
+ bugfix/all/stable/2.6.32.6.patch
+ bugfix/all/clockevents-Dont-remove-broadcast-device.patch
+ bugfix/all/clockevents-Add-missing-include.patch
+ features/all/SCSI-3w-sas-Add-new-driver-for-LSI-3ware-9750.patch
+ features/all/aufs2/aufs2-20100125.patch
+ bugfix/all/cdc_ether-Partially-revert-usbnet-Set-link-down-init.patch
- bugfix/all/DocBook-media-create-links-for-included-sources.patch
- bugfix/all/DocBook-media-copy-images-after-building-HTML.patch
- bugfix/all/atl1c-use-common_task-instead-of-reset_task-and-link.patch
- bugfix/all/atl1e-remove-broken-tsov6.patch
- bugfix/all/netfilter-xtables-fix-conntrack-match-v1-ipt-save-output.patch
- features/all/input-alps-add-interleaved-protocol-support.patch
- bugfix/all/sfc-Fix-DMA-mapping-cleanup-on-error-in-TSO.patch
- features/all/input-alps-add-support-for-touchpads-with-4-directional-button.patch
+ bugfix/all/stable/2.6.32.7.patch
+ features/all/input-alps-add-support-for-touchpads-with-4-directional-button-2.patch
+ debian/sched-fix-conflict-between-2.6.32.7-and-vserver.patch