rtlwifi: rtl8723ae: Fix typo in firmware names

svn path=/dists/sid/linux/; revision=20381
This commit is contained in:
Ben Hutchings 2013-07-18 05:04:28 +00:00
parent b8aaca8ceb
commit 6598fbc0fb
3 changed files with 45 additions and 0 deletions

1
debian/changelog vendored
View File

@ -8,6 +8,7 @@ linux (3.10.1-2) UNRELEASED; urgency=low
Samuel Thibault (Closes: #717183)
* be2net: Fix to avoid hardware workaround when not needed
* iwlwifi: Update 3160 and 7260 support to work with production firmware
* rtlwifi: rtl8723ae: Fix typo in firmware names
-- Arnaud Patard <arnaud.patard@rtp-net.org> Tue, 16 Jul 2013 08:19:29 +0200

View File

@ -0,0 +1,43 @@
From: Larry Finger <Larry.Finger@lwfinger.net>
Date: Sun, 23 Jun 2013 18:14:43 -0500
Subject: rtlwifi: rtl8723ae: Fix typo in firmware names
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Origin: https://git.kernel.org/linus/73e088ed17c2880a963cc760a78af8a06d4a4d9d
The driver loads its firmware from files rtlwifi/rtl8723fw*.bin, but the
MODULE_FIRMWARE macros refer to rtlwifi/RTL8723aefw*.bin.
Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>
Cc: Stable <stable@vger.kernel.org> [3.8+]
Reported-by: Axel Köllhofer <AxelKoellhofer@web.de>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/rtlwifi/rtl8723ae/sw.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c b/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
index e4c4cdc..d9ee2ef 100644
--- a/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
+++ b/drivers/net/wireless/rtlwifi/rtl8723ae/sw.c
@@ -251,7 +251,7 @@ static struct rtl_hal_cfg rtl8723ae_hal_cfg = {
.bar_id = 2,
.write_readback = true,
.name = "rtl8723ae_pci",
- .fw_name = "rtlwifi/rtl8723aefw.bin",
+ .fw_name = "rtlwifi/rtl8723fw.bin",
.ops = &rtl8723ae_hal_ops,
.mod_params = &rtl8723ae_mod_params,
.maps[SYS_ISO_CTRL] = REG_SYS_ISO_CTRL,
@@ -353,8 +353,8 @@ MODULE_AUTHOR("Realtek WlanFAE <wlanfae@realtek.com>");
MODULE_AUTHOR("Larry Finger <Larry.Finger@lwfinger.net>");
MODULE_LICENSE("GPL");
MODULE_DESCRIPTION("Realtek 8723E 802.11n PCI wireless");
-MODULE_FIRMWARE("rtlwifi/rtl8723aefw.bin");
-MODULE_FIRMWARE("rtlwifi/rtl8723aefw_B.bin");
+MODULE_FIRMWARE("rtlwifi/rtl8723fw.bin");
+MODULE_FIRMWARE("rtlwifi/rtl8723fw_B.bin");
module_param_named(swenc, rtl8723ae_mod_params.sw_crypto, bool, 0444);
module_param_named(debug, rtl8723ae_mod_params.debug, int, 0444);

View File

@ -107,5 +107,6 @@ bugfix/all/alx-fix-lockdep-annotation.patch
bugfix/all/xen-blkback-Check-device-permissions-before-allowing.patch
bugfix/all/be2net-Fix-to-avoid-hardware-workaround-when-not-nee.patch
features/all/iwlwifi-mvm-support-BSS-only.patch
bugfix/all/rtlwifi-rtl8723ae-Fix-typo-in-firmware-names.patch
features/all/iwlwifi-mvm-adjust-firmware-D3-configuration-API.patch
features/all/iwlwifi-bump-required-firmware-API-version-for-3160-.patch