writeback: Fix ABI change in 3.14.10 (Closes: #754902)

svn path=/dists/sid/linux/; revision=21557
This commit is contained in:
Ben Hutchings 2014-07-16 23:52:34 +00:00
parent 1da3edccd8
commit 65088b4b55
4 changed files with 33 additions and 2 deletions

3
debian/changelog vendored
View File

@ -9,6 +9,9 @@ linux (3.14.12-2) UNRELEASED; urgency=medium
* [mips,mipsel] Add a debconf note to warn users that they have to
configure the system bootloader to load initramfs.
[ Ben Hutchings ]
* writeback: Fix ABI change in 3.14.10 (Closes: #754902)
-- Ian Campbell <ijc@hellion.org.uk> Sat, 12 Jul 2014 21:12:17 +0100
linux (3.14.12-1) unstable; urgency=medium

View File

@ -24,8 +24,6 @@ ignore-changes:
sock_diag_put_filterinfo
# Can't build target modules OOT
module:drivers/target/iscsi/iscsi_target_mod
# Apparently not used OOT
test_set_page_writeback
[base]
arches:

View File

@ -0,0 +1,29 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 16 Jul 2014 20:50:04 +0100
Subject: writeback: Fix ABI change in 3.14.10
Bug-Debian: https://bugs.debian.org/754902
Forwarded: not-needed
Commit 1c8349a17137 ("ext4: fix data integrity sync in ordered mode")
renamed test_set_page_writeback() to __test_set_page_writeback() and
added a function-macro under the old name as a wrapper.
test_set_page_writeback() was an exported function that is used by
some OOT modules including openafs. To keep old modules working, we
need to provide a real function as well.
--- a/mm/page-writeback.c
+++ b/mm/page-writeback.c
@@ -2439,6 +2439,13 @@ int __test_set_page_writeback(struct pag
}
EXPORT_SYMBOL(__test_set_page_writeback);
+#undef test_set_page_writeback
+int test_set_page_writeback(struct page *page)
+{
+ return __test_set_page_writeback(page, false);
+}
+EXPORT_SYMBOL(test_set_page_writeback);
+
/*
* Return true if any of the pages in the mapping are marked with the
* passed tag.

View File

@ -96,3 +96,4 @@ debian/irq-avoid-abi-change-in-3.14.10.patch
debian/ptrace-avoid-abi-change-in-3.14.10.patch
debian/trace-syscall-avoid-abi-change-in-3.14.11.patch
debian/blkcg-avoid-abi-change-in-3.14.12.patch
debian/writeback-fix-abi-change-in-3.14.10.patch