ext4: Fix duplicate softdep fields in module info

We no longer need to add the crypto-aes or crypto-ecb dependencies
because ext4 uses the common encryption code in fscrypto (and has a
regular symbol dependency on it).

Since upstream added a softdep on "crc32c", we don't actually need to
change ext4 at all now.  But let's replace it with "crypto-crc32c",
since that's the module alias the crypto subsystem will actually
request and is consistent with the softdep we add to other
filesystems.
This commit is contained in:
Ben Hutchings 2018-06-07 16:18:34 +01:00
parent c1ecc67a90
commit 64f4d67d9e
2 changed files with 6 additions and 10 deletions

3
debian/changelog vendored
View File

@ -288,6 +288,9 @@ linux (4.16.13-1) UNRELEASED; urgency=medium
* hardening: enable FORTIFY_SOURCE, disable HARDENED_USERCOPY_FALLBACK
* [x86] hardening: enable REFCOUNT_FULL
[ Ben Hutchings ]
* ext4: Fix duplicate softdep fields in module info
-- Salvatore Bonaccorso <carnil@debian.org> Wed, 30 May 2018 08:41:30 +0200
linux (4.16.12-1) unstable; urgency=medium

View File

@ -26,19 +26,12 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+MODULE_SOFTDEP("pre: crypto-aes crypto-ecb");
--- a/fs/ext4/super.c
+++ b/fs/ext4/super.c
@@ -5868,6 +5868,14 @@ static void __exit ext4_exit_fs(void)
@@ -5880,6 +5880,6 @@ static void __exit ext4_exit_fs(void)
MODULE_AUTHOR("Remy Card, Stephen Tweedie, Andrew Morton, Andreas Dilger, Theodore Ts'o and others");
MODULE_DESCRIPTION("Fourth Extended Filesystem");
MODULE_LICENSE("GPL");
+
+#ifdef CONFIG_EXT4_FS_ENCRYPTION
+#define EXT4_ENC_EXTRA_SOFTDEPS " crypto-aes crypto-ecb"
+#else
+#define EXT4_ENC_EXTRA_SOFTDEPS ""
+#endif
+MODULE_SOFTDEP("pre: crypto-crc32c" EXT4_ENC_EXTRA_SOFTDEPS);
+
MODULE_SOFTDEP("pre: crc32c");
-MODULE_SOFTDEP("pre: crc32c");
+MODULE_SOFTDEP("pre: crypto-crc32c");
module_init(ext4_init_fs)
module_exit(ext4_exit_fs)
--- a/fs/f2fs/super.c