libcpupower: Hide private function and drop it from .symbols file

This avoids an FTBFS after this function was renamed in 4.19.6.
This commit is contained in:
Ben Hutchings 2018-12-01 19:27:12 +00:00
parent 5a00e93df2
commit 64dab5b29a
4 changed files with 22 additions and 1 deletions

1
debian/changelog vendored
View File

@ -27,6 +27,7 @@ linux (4.19.6-1~exp1) UNRELEASED; urgency=medium
[ Ben Hutchings ] [ Ben Hutchings ]
* debian/rules.real: Mark most targets as phony * debian/rules.real: Mark most targets as phony
* debian/rules: Mark more targets as phony * debian/rules: Mark more targets as phony
* libcpupower: Hide private function and drop it from .symbols file
-- Uwe Kleine-König <ukleinek@debian.org> Wed, 28 Nov 2018 12:20:46 +0100 -- Uwe Kleine-König <ukleinek@debian.org> Wed, 28 Nov 2018 12:20:46 +0100

View File

@ -36,4 +36,3 @@ libcpupower.so.1 libcpupower1 #MINVER#
cpuidle_state_usage@Base 4.7~rc2-1~exp1 cpuidle_state_usage@Base 4.7~rc2-1~exp1
cpupower_is_cpu_online@Base 4.7~rc2-1~exp1 cpupower_is_cpu_online@Base 4.7~rc2-1~exp1
get_cpu_topology@Base 4.7~rc2-1~exp1 get_cpu_topology@Base 4.7~rc2-1~exp1
sysfs_read_file@Base 4.7~rc2-1~exp1

View File

@ -0,0 +1,20 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 01 Dec 2018 19:22:50 +0000
Subject: libcpupower: Hide private function
cpupower_read_sysfs() (previously known as sysfs_read_file()) is an
internal function in libcpupower and should not be exported when
libcpupower is a shared library. Change its visibility to "hidden".
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/power/cpupower/lib/cpupower.c
+++ b/tools/power/cpupower/lib/cpupower.c
@@ -15,6 +15,7 @@
#include "cpupower.h"
#include "cpupower_intern.h"
+__attribute__((visibility("hidden")))
unsigned int cpupower_read_sysfs(const char *path, char *buf, size_t buflen)
{
int fd;

View File

@ -143,6 +143,7 @@ bugfix/all/tools-lib-traceevent-use-ldflags.patch
bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch bugfix/x86/revert-perf-build-fix-libunwind-feature-detection-on.patch
bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch bugfix/all/tools-build-remove-bpf-run-time-check-at-build-time.patch
bugfix/all/cpupower-bump-soname-version.patch bugfix/all/cpupower-bump-soname-version.patch
bugfix/all/libcpupower-hide-private-function.patch
bugfix/all/cpupower-fix-checks-for-cpu-existence.patch bugfix/all/cpupower-fix-checks-for-cpu-existence.patch
bugfix/all/tools-lib-api-fs-fs.c-fix-misuse-of-strncpy.patch bugfix/all/tools-lib-api-fs-fs.c-fix-misuse-of-strncpy.patch
bugfix/all/usbip-fix-misuse-of-strncpy.patch bugfix/all/usbip-fix-misuse-of-strncpy.patch