[rt] latency_hist: Update sched_switch probe

This commit is contained in:
Ben Hutchings 2016-01-04 17:23:09 +00:00
parent 5ad5fe2d6f
commit 64474e57fd
3 changed files with 32 additions and 0 deletions

1
debian/changelog vendored
View File

@ -5,6 +5,7 @@ linux (4.4~rc8-1~exp1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* [rt] Update to 4.4-rc6-rt1 and re-enable
* [rt] Fix build error in kernel/time/hrtimer.c
* [rt] latency_hist: Update sched_switch probe
* [armhf] Add support for BCM2836 and Raspberry Pi 2:
- pwm: bcm2835: Calculate scaler in ->config()
- pwm: bcm2835: Prevent division by zero

View File

@ -0,0 +1,30 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 04 Jan 2016 17:19:33 +0000
Subject: latency_hist: Update sched_switch probe
Commit c73464b1c843 ("sched/core: Fix trace_sched_switch()") adds a
'bool preempt' parameter to probe functions, so change
probe_wakeup_latency_hist_stop() accordingly..
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/kernel/trace/latency_hist.c
+++ b/kernel/trace/latency_hist.c
@@ -116,7 +116,7 @@ static char *wakeup_latency_hist_dir = "
static char *wakeup_latency_hist_dir_sharedprio = "sharedprio";
static notrace void probe_wakeup_latency_hist_start(void *v,
struct task_struct *p);
-static notrace void probe_wakeup_latency_hist_stop(void *v,
+static notrace void probe_wakeup_latency_hist_stop(void *v, bool preempt,
struct task_struct *prev, struct task_struct *next);
static notrace void probe_sched_migrate_task(void *,
struct task_struct *task, int cpu);
@@ -906,7 +906,7 @@ out:
raw_spin_unlock_irqrestore(&wakeup_lock, flags);
}
-static notrace void probe_wakeup_latency_hist_stop(void *v,
+static notrace void probe_wakeup_latency_hist_stop(void *v, bool preempt,
struct task_struct *prev, struct task_struct *next)
{
unsigned long flags;

View File

@ -556,6 +556,7 @@ features/all/rt/workqueue-prevent-deadlock-stall.patch
# TRACING
features/all/rt/latency_hist-update-sched_wakeup-probe.patch
features/all/rt/latency_hist-update-sched_switch-probe.patch
# Add RT to version
features/all/rt/localversion.patch