cciss: Add IRQF_SHARED back in for the non-MSI(X) interrupt handler (Closes: #650119)

svn path=/dists/sid/linux-2.6/; revision=18390
This commit is contained in:
Ben Hutchings 2011-12-16 03:22:27 +00:00
parent 00a06bd668
commit 64378c34a9
3 changed files with 47 additions and 0 deletions

2
debian/changelog vendored
View File

@ -4,6 +4,8 @@ linux-2.6 (3.1.5-2) UNRELEASED; urgency=low
* staging: r8712u: Add new USB ID (Closes: #651622)
* [x86] Enable HYPERV, HYPERV_STORAGE, HYPERV_BLOCK, HYPERV_NET,
HYPERV_UTILS, HYPERV_MOUSE as modules (Closes: #652014)
* cciss: Add IRQF_SHARED back in for the non-MSI(X) interrupt handler
(Closes: #650119)
[ Arnaud Patard ]
* [arm] setup: initialize arm_dma_zone_size earlier (Closes: #651215)

View File

@ -0,0 +1,44 @@
From: "Stephen M. Cameron" <scameron@beardog.cce.hp.com>
Date: Mon, 28 Nov 2011 20:12:05 +0100
Subject: [PATCH] cciss: Add IRQF_SHARED back in for the non-MSI(X) interrupt
handler
commit 6225da481597ebff09454c785fe0afc7f5fdbb77 upstream.
IRQF_SHARED is required for older controllers that don't support MSI(X)
and which may end up sharing an interrupt.
Also remove deprecated IRQF_DISABLED.
Signed-off-by: Stephen M. Cameron <scameron@beardog.cce.hp.com>
Signed-off-by: Jens Axboe <axboe@kernel.dk>
[bwh: Adjust context for 3.1]
---
drivers/block/cciss.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/block/cciss.c b/drivers/block/cciss.c
index 8004ac3..6f22ed0 100644
--- a/drivers/block/cciss.c
+++ b/drivers/block/cciss.c
@@ -4880,7 +4880,7 @@ static int cciss_request_irq(ctlr_info_t *h,
{
if (h->msix_vector || h->msi_vector) {
if (!request_irq(h->intr[PERF_MODE_INT], msixhandler,
- IRQF_DISABLED, h->devname, h))
+ 0, h->devname, h))
return 0;
dev_err(&h->pdev->dev, "Unable to get msi irq %d"
" for %s\n", h->intr[PERF_MODE_INT],
@@ -4889,7 +4889,7 @@ static int cciss_request_irq(ctlr_info_t *h,
}
if (!request_irq(h->intr[PERF_MODE_INT], intxhandler,
- IRQF_DISABLED, h->devname, h))
+ IRQF_SHARED, h->devname, h))
return 0;
dev_err(&h->pdev->dev, "Unable to get irq %d for %s\n",
h->intr[PERF_MODE_INT], h->devname);
--
1.7.7.3

View File

@ -88,3 +88,4 @@
+ debian/inetpeer-hide-ABI-change-in-3.1.5.patch
+ features/all/staging-r8712u-Add-new-USB-ID.patch
+ bugfix/arm/nslu2-dma-size.patch
+ bugfix/all/cciss-Add-IRQF_SHARED-back-in-for-the-non-MSI-X-inte.patch