[x86] Enable MEMTEST (Closes: #613321, #646361)

If bad RAM is detected, WARN and recommend a more thorough test

svn path=/dists/sid/linux-2.6/; revision=18354
This commit is contained in:
Ben Hutchings 2011-12-05 06:04:56 +00:00
parent 8971affbe1
commit 619c99e343
4 changed files with 33 additions and 1 deletions

2
debian/changelog vendored
View File

@ -8,6 +8,8 @@ linux-2.6 (3.1.4-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* USB: EHCI: fix HUB TT scheduling issue with iso transfer (Closes: #651015)
* [x86] Enable MEMTEST (Closes: #613321, #646361)
- If bad RAM is detected, WARN and recommend a more thorough test
-- Bastian Blank <waldi@debian.org> Thu, 01 Dec 2011 13:17:34 +0100

View File

@ -18,7 +18,7 @@ CONFIG_KVM_GUEST=y
CONFIG_PARAVIRT=y
# CONFIG_PARAVIRT_SPINLOCKS is not set
# CONFIG_PARAVIRT_DEBUG is not set
# CONFIG_MEMTEST is not set
CONFIG_MEMTEST=y
CONFIG_HPET_TIMER=y
CONFIG_SCHED_SMT=y
CONFIG_SCHED_MC=y

View File

@ -0,0 +1,29 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 5 Dec 2011 04:00:58 +0000
Subject: [PATCH] x86: memtest: WARN if bad RAM found
Since this is not a particularly thorough test, if we find any bad
bits of RAM then there is a fair chance that there are other bad bits
we fail to detect.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/x86/mm/memtest.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/arch/x86/mm/memtest.c b/arch/x86/mm/memtest.c
index 92faf3a..ac6bdaa 100644
--- a/arch/x86/mm/memtest.c
+++ b/arch/x86/mm/memtest.c
@@ -30,6 +30,8 @@ static u64 patterns[] __initdata = {
static void __init reserve_bad_mem(u64 pattern, u64 start_bad, u64 end_bad)
{
+ WARN_ONCE(1, "Bad RAM detected. Use memtest86+ to perform a thorough test\n"
+ "and the memmap= parameter to reserve the bad areas.");
printk(KERN_INFO " %016llx bad mem addr %010llx - %010llx reserved\n",
(unsigned long long) pattern,
(unsigned long long) start_bad,
--
1.7.7.3

View File

@ -82,3 +82,4 @@
+ features/all/topology-Provide-CPU-topology-in-sysfs-in-SMP-configura.patch
+ bugfix/all/USB-EHCI-fix-HUB-TT-scheduling-issue-with-iso-transf.patch
+ bugfix/all/EHCI-Fix-a-regression-in-the-ISO-scheduler.patch
+ debian/x86-memtest-WARN-if-bad-RAM-found.patch