[arm] add io{read,write}{16,32}be functions (fixes FTBFS)

svn path=/dists/trunk/linux-2.6/; revision=18243
This commit is contained in:
Ben Hutchings 2011-11-11 02:10:11 +00:00
parent 3e1e1a6980
commit 609a1e3502
3 changed files with 40 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux-2.6 (3.1.0-1~experimental.2) UNRELEASED; urgency=low
* [alpha] wire up accept4 syscall, thanks to Michael Cree
* iwlagn: fix modinfo display for 135 ucode (Closes: #647958)
* [powerpc] ptrace: Fix build with gcc 4.6
* [arm] add io{read,write}{16,32}be functions (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 04 Nov 2011 15:05:47 +0000

View File

@ -0,0 +1,38 @@
From: Arnd Bergmann <arnd@arndb.de>
Date: Sat, 3 Sep 2011 17:54:44 +0200
Subject: [PATCH] ARM: add io{read,write}{16,32}be functions
commit 06901bd83412db5a31de7526e637101ed0c2c472 upstream.
These functions are used in some PCI drivers with big-endian
MMIO space, and they are trivial to add here.
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
---
arch/arm/include/asm/io.h | 6 ++++++
1 files changed, 6 insertions(+), 0 deletions(-)
diff --git a/arch/arm/include/asm/io.h b/arch/arm/include/asm/io.h
index d66605d..bad7bfb 100644
--- a/arch/arm/include/asm/io.h
+++ b/arch/arm/include/asm/io.h
@@ -260,10 +260,16 @@ extern void _memset_io(volatile void __iomem *, int, size_t);
#define ioread16(p) ({ unsigned int __v = le16_to_cpu((__force __le16)__raw_readw(p)); __iormb(); __v; })
#define ioread32(p) ({ unsigned int __v = le32_to_cpu((__force __le32)__raw_readl(p)); __iormb(); __v; })
+#define ioread16be(p) ({ unsigned int __v = be16_to_cpu((__force __be16)__raw_readw(p)); __iormb(); __v; })
+#define ioread32be(p) ({ unsigned int __v = be32_to_cpu((__force __be32)__raw_readl(p)); __iormb(); __v; })
+
#define iowrite8(v,p) ({ __iowmb(); (void)__raw_writeb(v, p); })
#define iowrite16(v,p) ({ __iowmb(); (void)__raw_writew((__force __u16)cpu_to_le16(v), p); })
#define iowrite32(v,p) ({ __iowmb(); (void)__raw_writel((__force __u32)cpu_to_le32(v), p); })
+#define iowrite16be(v,p) ({ __iowmb(); (void)__raw_writew((__force __u16)cpu_to_be16(v), p); })
+#define iowrite32be(v,p) ({ __iowmb(); (void)__raw_writel((__force __u32)cpu_to_be32(v), p); })
+
#define ioread8_rep(p,d,c) __raw_readsb(p,d,c)
#define ioread16_rep(p,d,c) __raw_readsw(p,d,c)
#define ioread32_rep(p,d,c) __raw_readsl(p,d,c)
--
1.7.7.2

View File

@ -1,3 +1,4 @@
+ bugfix/alpha/alpha-wire-up-accept4-syscall.patch
+ bugfix/all/iwlagn-fix-modinfo-display-for-135-ucode.patch
+ bugfix/powerpc/powerpc-ptrace-Fix-build-with-gcc-4.6.patch
+ bugfix/arm/ARM-add-io-read-write-16-32-be-functions.patch