Update Artop PATA patch for NAS 100d and set CONFIG_PATA_ARTOP for

ixp4xx.

svn path=/dists/trunk/linux-2.6/; revision=8964
This commit is contained in:
Gordon Farquharson 2007-06-11 05:08:05 +00:00
parent c27aecf51a
commit 606b00649f
5 changed files with 28 additions and 51 deletions

View File

@ -671,6 +671,7 @@ CONFIG_SCSI_QLA_FC=m
# CONFIG_SCSI_DC390T is not set
# CONFIG_SCSI_NSP32 is not set
# CONFIG_SCSI_DEBUG is not set
CONFIG_PATA_ARTOP=m
#
# Serial ATA (prod) and Parallel ATA (experimental) drivers

3
debian/changelog vendored
View File

@ -45,8 +45,9 @@ linux-2.6 (2.6.22~rc4-1~experimental.1) UNRELEASED; urgency=low
DVB_B2C2_FLEXCOP, and DVB_BUDGET as broken on ARM.
* arm/ixp4xx: Add support for the new generic I2C GPIO driver on the
NSLU2 and the NAS100D. Thanks to Michael-Luke Jones and Rod Whitby.
* arm/ixp4xx: Update Artop PATA support patch for the NAS 100d.
-- Gordon Farquharson <gordonfarquharson@gmail.com> Sat, 9 Jun 2007 19:33:59 -0600
-- Gordon Farquharson <gordonfarquharson@gmail.com> Sun, 10 Jun 2007 22:52:02 -0600
linux-2.6 (2.6.21-3) UNRELEASED; urgency=low

View File

@ -1,49 +0,0 @@
From: Alan Cox <alan@redhat.com>
To: Alessandro Zummo <alessandro.zummo@towertech.it>
Cc: Jeff Garzik <jgarzik@redhat.com>, Alan Cox <alan@redhat.com>
Subject: Re: drivers/ata/pata_artop.c
Date: Sun, 15 Oct 2006 14:25:16 -0400
User-Agent: Mutt/1.4.1i
On Sun, Oct 15, 2006 at 07:18:31PM +0200, Alessandro Zummo wrote:
> In the discovery phase there's a lot of time spent in the detection
> of the second port.
The error recovery is a bit determined right now - Tejun's been doing some
work on SRST behaviour and also for the worst cases polled detect so it
should come out ok
> What's the correct way to inform the driver
> to avoid checking the second port?
Set the number of ports to 1 in your own tree for now. The real fix is
not to go poking at pata ports if the ret is 0xFF
---
drivers/ata/pata_artop.c | 6 ++++++
1 file changed, 6 insertions(+)
Index: linux-2.6.19/drivers/ata/pata_artop.c
===================================================================
--- linux-2.6.19.orig/drivers/ata/pata_artop.c
+++ linux-2.6.19/drivers/ata/pata_artop.c
@@ -26,6 +26,7 @@
#include <scsi/scsi_host.h>
#include <linux/libata.h>
#include <linux/ata.h>
+#include <asm/mach-types.h>
#define DRV_NAME "pata_artop"
#define DRV_VERSION "0.4.2"
@@ -469,6 +470,11 @@ static int artop_init_one (struct pci_de
pci_read_config_byte(pdev, 0x4a, &reg);
pci_write_config_byte(pdev, 0x4a, (reg & ~0x01) | 0x80);
+ /* NAS100D workaround */
+#ifdef CONFIG_MACH_NAS100D
+ if (machine_is_nas100d())
+ ports = 1;
+#endif
}
BUG_ON(info == NULL);

View File

@ -0,0 +1,24 @@
Index: linux-2.6.22-rc4-armeb/drivers/ata/pata_artop.c
===================================================================
--- linux-2.6.22-rc4-armeb.orig/drivers/ata/pata_artop.c
+++ linux-2.6.22-rc4-armeb/drivers/ata/pata_artop.c
@@ -26,6 +26,7 @@
#include <scsi/scsi_host.h>
#include <linux/libata.h>
#include <linux/ata.h>
+#include <asm/mach-types.h>
#define DRV_NAME "pata_artop"
#define DRV_VERSION "0.4.3"
@@ -480,6 +481,11 @@ static int artop_init_one (struct pci_de
pci_read_config_byte(pdev, 0x4a, &reg);
pci_write_config_byte(pdev, 0x4a, (reg & ~0x01) | 0x80);
+ /* NAS100D workaround - probing second port kills uhci_hcd */
+#ifdef CONFIG_MACH_NAS100D
+ if (machine_is_nas100d())
+ ppi[1] = &ata_dummy_port_info;
+#endif
}
BUG_ON(ppi[0] == NULL);

View File

@ -4,7 +4,7 @@
+ features/all/xen/fedora-2.6.20-48670.patch *_xen *_xen-vserver
+ features/all/xen/update.patch *_xen *_xen-vserver
+ features/all/xen/vserver-update.patch *_xen-vserver
+ bugfix/arm/nas100d-artop-temp-fix.patch arm
+ bugfix/arm/nas100d-pata-artop-single-port.patch arm
# Submitted
+ bugfix/m68k/falconide_intr_lock-reentrant.diff m68k