[powerpc*] vdso: Make vdso32 installation conditional in vdso_install

Closes: #785065

This finally removes the need for the ppc64el compiler to support
32-bit code generation, and removes a useless file from debug
packages on ppc64el.
This commit is contained in:
Ben Hutchings 2019-03-22 04:28:33 +00:00
parent a8e51bb570
commit 6039118f59
3 changed files with 32 additions and 0 deletions

2
debian/changelog vendored
View File

@ -3,6 +3,8 @@ linux (4.19.28-3) UNRELEASED; urgency=medium
* debian/bin/abiupdate.py: Automatically select the correct archive to fetch
from
* debian/bin/abiupdate.py: Change default URLs to use https: scheme
* [powerpc*] vdso: Make vdso32 installation conditional in vdso_install
(Closes: #785065)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 18 Mar 2019 22:50:08 +0000

View File

@ -0,0 +1,29 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 22 Mar 2019 03:30:10 +0000
Subject: powerpc: vdso: Make vdso32 installation conditional in vdso_install
Bug-Debian: https://bugs.debian.org/785065
Forwarded: https://lore.kernel.org/linuxppc-dev/20190322042436.nttfgsdpdshco27y@decadent.org.uk/
The 32-bit vDSO is not needed and not normally built for 64-bit
little-endian configurations. However, the vdso_install target still
builds and installs it. Add the same config condition as is normally
used for the build.
Fixes: e0d005916994 ("powerpc/vdso: Disable building the 32-bit VDSO ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/powerpc/Makefile | 2 ++
1 file changed, 2 insertions(+)
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -403,7 +403,9 @@ vdso_install:
ifdef CONFIG_PPC64
$(Q)$(MAKE) $(build)=arch/$(ARCH)/kernel/vdso64 $@
endif
+ifdef CONFIG_VDSO32
$(Q)$(MAKE) $(build)=arch/$(ARCH)/kernel/vdso32 $@
+endif
archclean:
$(Q)$(MAKE) $(clean)=$(boot)

View File

@ -81,6 +81,7 @@ bugfix/x86/x86-kvmclock-set-offset-for-kvm-unstable-clock.patch
bugfix/arm/ARM-dts-sun8i-h3-add-sy8106a-to-orange-pi-plus.patch
bugfix/arm64/arm64-dts-allwinner-a64-Enable-A64-timer-workaround.patch
bugfix/mips/MIPS-Loongson-Introduce-and-use-loongson_llsc_mb.patch
bugfix/powerpc/powerpc-vdso-make-vdso32-installation-conditional-in.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch