radeon: Fix MacBook Pro connector quirk (Closes: #585943)

svn path=/dists/sid/linux-2.6/; revision=15879
This commit is contained in:
Ben Hutchings 2010-06-16 01:06:19 +00:00
parent e7ead72712
commit 5db6cefd82
3 changed files with 30 additions and 0 deletions

1
debian/changelog vendored
View File

@ -29,6 +29,7 @@ linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
(Closes: #585661)
- option, qcserial: Use generic USB WWAN code
- qcserial: Add support for Qualcomm Gobi 2000 devices
* radeon: Fix MacBook Pro connector quirk (Closes: #585943)
[ Aurelien Jarno ]
* [sh4] fix sh_tmu clocksource following recent nohz changes.

View File

@ -0,0 +1,28 @@
From: Alex Deucher <alexdeucher@gmail.com>
Date: Fri, 26 Mar 2010 17:14:37 -0400
Subject: [PATCH] drm/radeon/kms: fix macbookpro connector quirk
commit e1e8a5dd4faf356b5d31c620c5787eaa83ee831d upstream.
Signed-off-by: Alex Deucher <alexdeucher@gmail.com>
Signed-off-by: Dave Airlie <airlied@redhat.com>
---
drivers/gpu/drm/radeon/radeon_atombios.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/drivers/gpu/drm/radeon/radeon_atombios.c b/drivers/gpu/drm/radeon/radeon_atombios.c
index f0ea7f8..1fff955 100644
--- a/drivers/gpu/drm/radeon/radeon_atombios.c
+++ b/drivers/gpu/drm/radeon/radeon_atombios.c
@@ -264,6 +264,8 @@ static bool radeon_atom_apply_quirks(struct drm_device *dev,
if ((supported_device == ATOM_DEVICE_CRT1_SUPPORT) ||
(supported_device == ATOM_DEVICE_DFP2_SUPPORT))
return false;
+ if (supported_device == ATOM_DEVICE_CRT2_SUPPORT)
+ *line_mux = 0x90;
}
/* ASUS HD 3600 XT board lists the DVI port as HDMI */
--
1.7.1

View File

@ -142,3 +142,4 @@
+ features/all/USB-option-Use-generic-USB-wwan-code.patch
+ features/all/USB-qcserial-Use-generic-USB-wwan-code.patch
+ features/all/USB-qcserial-Add-support-for-Qualcomm-Gobi-2000.patch
+ bugfix/x86/drm-radeon-kms-fix-macbookpro-connector-quirk.patch