PCI: ASPM: Fix pcie devices with non-pcie children (Closes: #665420)

svn path=/dists/sid/linux-2.6/; revision=18898
This commit is contained in:
Ben Hutchings 2012-04-01 22:43:12 +00:00
parent eaaf213afd
commit 5da05a3637
3 changed files with 75 additions and 0 deletions

3
debian/changelog vendored
View File

@ -3,6 +3,9 @@ linux-2.6 (3.2.13-2) UNRELEASED; urgency=low
[ Jonathan Nieder ]
* ata: Enable PATA_IT8213 as module (Closes: #666506)
[ Ben Hutchings ]
* PCI: ASPM: Fix pcie devices with non-pcie children (Closes: #665420)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 01 Apr 2012 06:33:00 +0100
linux-2.6 (3.2.13-1) unstable; urgency=low

View File

@ -0,0 +1,71 @@
From: Matthew Garrett <mjg@redhat.com>
Date: Tue, 27 Mar 2012 10:17:41 -0400
Subject: [PATCH] ASPM: Fix pcie devices with non-pcie children
commit c9651e70ad0aa499814817cbf3cc1d0b806ed3a1 upstream.
Since 3.2.12 and 3.3, some systems are failing to boot with a BUG_ON.
Some other systems using the pata_jmicron driver fail to boot because no
disks are detected. Passing pcie_aspm=force on the kernel command line
works around it.
The cause: commit 4949be16822e ("PCI: ignore pre-1.1 ASPM quirking when
ASPM is disabled") changed the behaviour of pcie_aspm_sanity_check() to
always return 0 if aspm is disabled, in order to avoid cases where we
changed ASPM state on pre-PCIe 1.1 devices.
This skipped the secondary function of pcie_aspm_sanity_check which was
to avoid us enabling ASPM on devices that had non-PCIe children, causing
trouble later on. Move the aspm_disabled check so we continue to honour
that scenario.
Addresses https://bugzilla.kernel.org/show_bug.cgi?id=42979 and
http://bugs.debian.org/665420
Reported-by: Romain Francoise <romain@orebokech.com> # kernel panic
Reported-by: Chris Holland <bandidoirlandes@gmail.com> # disk detection trouble
Signed-off-by: Matthew Garrett <mjg@redhat.com>
Cc: stable@vger.kernel.org
Tested-by: Hatem Masmoudi <hatem.masmoudi@gmail.com> # Dell Latitude E5520
Tested-by: janek <jan0x6c@gmail.com> # pata_jmicron with JMB362/JMB363
[jn: with more symptoms in log message]
Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
drivers/pci/pcie/aspm.c | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/drivers/pci/pcie/aspm.c b/drivers/pci/pcie/aspm.c
index 4bdef24..b500840 100644
--- a/drivers/pci/pcie/aspm.c
+++ b/drivers/pci/pcie/aspm.c
@@ -508,9 +508,6 @@ static int pcie_aspm_sanity_check(struct pci_dev *pdev)
int pos;
u32 reg32;
- if (aspm_disabled)
- return 0;
-
/*
* Some functions in a slot might not all be PCIe functions,
* very strange. Disable ASPM for the whole slot
@@ -519,6 +516,16 @@ static int pcie_aspm_sanity_check(struct pci_dev *pdev)
pos = pci_pcie_cap(child);
if (!pos)
return -EINVAL;
+
+ /*
+ * If ASPM is disabled then we're not going to change
+ * the BIOS state. It's safe to continue even if it's a
+ * pre-1.1 device
+ */
+
+ if (aspm_disabled)
+ continue;
+
/*
* Disable ASPM for pre-1.1 PCIe device, we follow MS to use
* RBER bit to determine if a function is 1.1 version device
--
1.7.9.5

View File

@ -84,3 +84,4 @@
+ bugfix/all/Don-t-limit-non-nested-epoll-paths.patch
+ bugfix/all/CIFS-Fix-a-spurious-error-in-cifs_push_posix_locks.patch
+ bugfix/all/kbuild-do-not-check-for-ancient-modutils-tools.patch
+ bugfix/all/ASPM-Fix-pcie-devices-with-non-pcie-children.patch