[armel] dts: kirkwood: Fix SATA pinmux-ing for TS419 (Closes: #855017)

This commit is contained in:
Ben Hutchings 2017-02-18 00:38:36 +00:00
parent ad25780220
commit 5d590456c4
3 changed files with 44 additions and 0 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (4.9.10-2) UNRELEASED; urgency=medium
* [armel] dts: kirkwood: Fix SATA pinmux-ing for TS419 (Closes: #855017)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 18 Feb 2017 00:38:10 +0000
linux (4.9.10-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,37 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 17 Feb 2017 01:30:30 +0000
Subject: ARM: dts: kirkwood: Fix SATA pinmux-ing for TS419
Forwarded: https://www.spinics.net/lists/arm-kernel/msg563610.html
Bug-Debian: https://bugs.debian.org/855017
The old board code for the TS419 assigns MPP pins 15 and 16 as SATA
activity signals (and none as SATA presence signals). Currently the
device tree assigns the SoC's default pinmux groups for SATA, which
conflict with the second Ethernet port.
Reported-by: gmbh@gazeta.pl
Tested-by: gmbh@gazeta.pl
References: https://bugs.debian.org/855017
Cc: stable@vger.kernel.org # 3.15+
Fixes: 934b524b3f49 ("ARM: Kirkwood: Add DT description of QNAP 419")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/boot/dts/kirkwood-ts419.dtsi | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/arch/arm/boot/dts/kirkwood-ts419.dtsi b/arch/arm/boot/dts/kirkwood-ts419.dtsi
index 02bd53762705..532506cb0f4a 100644
--- a/arch/arm/boot/dts/kirkwood-ts419.dtsi
+++ b/arch/arm/boot/dts/kirkwood-ts419.dtsi
@@ -73,3 +73,11 @@
phy-handle = <&ethphy1>;
};
};
+
+&pmx_sata0 {
+ marvell,pins = "mpp15";
+};
+
+&pmx_sata1 {
+ marvell,pins = "mpp16";
+};

View File

@ -50,6 +50,7 @@ debian/fanotify-taint-on-use-of-fanotify_access_permissions.patch
bugfix/x86/asoc-intel-select-dw_dmac_core-since-it-s-mandatory.patch
bugfix/x86/platform-x86-acer-wmi-setup-accelerometer-when-machi.patch
bugfix/x86/x86-xen-fix-apic-id-mismatch-warning-on-intel.patch
bugfix/arm/arm-dts-kirkwood-fix-sata-pinmux-ing-for-ts419.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch