remove mips patches that are in rc9

svn path=/dists/trunk/linux-2.6/; revision=11801
This commit is contained in:
Martin Michlmayr 2008-07-06 11:00:09 +00:00
parent 24738f8d51
commit 5d03b9e7d5
5 changed files with 0 additions and 107 deletions

2
debian/changelog vendored
View File

@ -87,8 +87,6 @@ linux-2.6 (2.6.26~rc9-1~experimental.1) UNRELEASED; urgency=low
* [arm/orion5x] Add support for QNAP TS-409 and HP mv2120; thanks
Sylver Bruneau.
* [mips] Add fixes from Thomas Bogendoerfer:
- IP22: Set MIPS_L1_CACHE_SHIFT to 7
- IP32: fix unexpected irq 71
- gbefb: fix cmap FIFO timeout (closes: #487257)
- IP32: Enable FAST-20 for onboard scsi
* [arm/ixp4xx] Add support for Freecom FSG-3 (Rod Whitby).

View File

@ -1,35 +0,0 @@
From: Morten Larsen <mlarsen@broadcom.com>
As far as I can tell the branch optimization fixes in 2.6.21 introduced
a bug in atomic_sub_if_positive that causes it to return even when the
sc instruction fails. The result is that e.g. down_trylock becomes
unreliable as the semaphore counter is not always decremented.
--- a/include/asm-mips/atomic.h 2008-06-25 22:38:43.159739000 -0700
+++ b/include/asm-mips/atomic.h 2008-06-25 22:39:07.552065000 -0700
@@ -292,10 +292,10 @@ static __inline__ int atomic_sub_if_posi
" beqz %0, 2f \n"
" subu %0, %1, %3 \n"
" .set reorder \n"
- "1: \n"
" .subsection 2 \n"
"2: b 1b \n"
" .previous \n"
+ "1: \n"
" .set mips0 \n"
: "=&r" (result), "=&r" (temp), "=m" (v->counter)
: "Ir" (i), "m" (v->counter)
@@ -682,10 +682,10 @@ static __inline__ long atomic64_sub_if_p
" beqz %0, 2f \n"
" dsubu %0, %1, %3 \n"
" .set reorder \n"
- "1: \n"
" .subsection 2 \n"
"2: b 1b \n"
" .previous \n"
+ "1: \n"
" .set mips0 \n"
: "=&r" (result), "=&r" (temp), "=m" (v->counter)
: "Ir" (i), "m" (v->counter)

View File

@ -1,40 +0,0 @@
On Mon, Jun 23, 2008 at 04:20:16PM +0000, The Fungi wrote:
> On Sun, Jun 22, 2008 at 02:24:42PM +0200, Martin Michlmayr wrote:
> > I've built some kernel snapshots for mips and mipsel based on
> > 2.6.26-rc7. Please test them on your favourite MIPS machine
> > and report success or failures to this list.
>
> My Indy (CMN B006Y87, R4400 175MHz CPU) panics on the r4k-ip22
> package shortly after boot:
this might be due to the change in using a cache invalidate instead
of writeback/invalidate and the 128 byte linesize of the second level
cache on that R4k CPU modules. The patch below should fix that.
I have no R4400 IP22 handy, so I'd appriciate if someone could test
the patch. If it works, I'll sent the patch to Ralf with proper S-O-B.
Thomas.
diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index e5a7c5d..24c5dee 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -1006,7 +1006,7 @@ config BOOT_ELF32
config MIPS_L1_CACHE_SHIFT
int
default "4" if MACH_DECSTATION
- default "7" if SGI_IP27 || SGI_IP28 || SNI_RM
+ default "7" if SGI_IP22 || SGI_IP27 || SGI_IP28 || SNI_RM
default "4" if PMC_MSP4200_EVAL
default "5"
--
Crap can work. Given enough thrust pigs will fly, but it's not necessary a
good idea. [ RFC1925, 2.3 ]
--
To UNSUBSCRIBE, email to debian-mips-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

View File

@ -1,27 +0,0 @@
It's possible that the crime interrupt handler is called without
pending interrupts (probably a hardware issue). To avoid irritating
"unexpected irq 71" messages, we now just ignore the spurious crime
interrupts.
Signed-off-by: Thomas Bogendoerfer <tsbogend@alpha.franken.de>
---
arch/mips/sgi-ip32/ip32-irq.c | 5 +++++
1 files changed, 5 insertions(+), 0 deletions(-)
diff --git a/arch/mips/sgi-ip32/ip32-irq.c b/arch/mips/sgi-ip32/ip32-irq.c
index b0ea0e4..0d6b666 100644
--- a/arch/mips/sgi-ip32/ip32-irq.c
+++ b/arch/mips/sgi-ip32/ip32-irq.c
@@ -425,6 +425,11 @@ static void ip32_irq0(void)
BUILD_BUG_ON(MACEISA_SERIAL2_RDMAOR_IRQ - MACEISA_AUDIO_SW_IRQ != 31);
crime_int = crime->istat & crime_mask;
+
+ /* crime sometime delivers spurious interrupts, ignore them */
+ if (unlikely(crime_int == 0))
+ return;
+
irq = MACE_VID_IN1_IRQ + __ffs(crime_int);
if (crime_int & CRIME_MACEISA_INT_MASK) {

View File

@ -22,11 +22,8 @@
+ bugfix/sparc/drivers_net-broken.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch
#+ bugfix/mips/ip32_fix_unexpected_irq_71.patch
#+ bugfix/mips/ip22_cache_shift.patch
+ bugfix/mips/gbefb_fix_cmap_fifo_timeout.patch
+ bugfix/mips/ip32_enable_fast_20.patch
#+ bugfix/mips/atomic_sub_if_positive.patch
+ bugfix/arm/disable-dvb_b2c2_flexcop.patch
+ bugfix/arm/disable-dvb_budget.patch
+ bugfix/arm/disable-netxen_nic.patch