iwlwifi: Fix repeated warnings about tfds_in_queue (Closes: #574526)

svn path=/dists/sid/linux-2.6/; revision=15427
This commit is contained in:
Ben Hutchings 2010-03-20 15:29:20 +00:00
parent b4dd2c3a03
commit 5bed08af1c
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux-2.6 (2.6.32-11) UNRELEASED; urgency=low
(previously applied only to x86)
* linux-base: Handle duplicates in /etc/udev/rules.d/70-persistent-cd.rules
(Closes: #574630)
* iwlwifi: Fix repeated warnings about tfds_in_queue (Closes: #574526)
[ maximilian attems]
* [alpha, hppa] Disable oprofile as tracing code is unsupported here.

View File

@ -0,0 +1,29 @@
From: Stanislaw Gruszka <sgruszka@redhat.com>
Subject: [PATCH 2.6.32] iwlwifi: fix nfreed--
Date: Thu, 18 Mar 2010 15:29:33 +0100
During backporting of a120e912eb51e347f36c71b60a1d13af74d30e83
("iwlwifi: sanity check before counting number of tfds can be free")
we forget one hunk, what make lot of messages "free more than
tfds_in_queue" show up in dmesg.
Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
---
drivers/net/wireless/iwlwifi/iwl-tx.c | 1 -
1 files changed, 0 insertions(+), 1 deletions(-)
diff --git a/drivers/net/wireless/iwlwifi/iwl-tx.c b/drivers/net/wireless/iwlwifi/iwl-tx.c
index f449f06..cf5ac00 100644
--- a/drivers/net/wireless/iwlwifi/iwl-tx.c
+++ b/drivers/net/wireless/iwlwifi/iwl-tx.c
@@ -1096,7 +1096,6 @@ int iwl_tx_queue_reclaim(struct iwl_priv *priv, int txq_id, int index)
priv->cfg->ops->lib->txq_inval_byte_cnt_tbl(priv, txq);
priv->cfg->ops->lib->txq_free_tfd(priv, txq);
- nfreed++;
}
return nfreed;
}
--
1.6.2.5

View File

@ -1,2 +1,3 @@
+ bugfix/all/tracing-do-not-disable-interrupts-for-trace_clock_lo.patch
+ bugfix/sparc/sparc-Provide-io-read-write-16-32-be.patch
+ bugfix/all/iwlwifi-fix-nfreed.patch