Input: wacom - fix touch support for Bamboo Fun CTH-461

svn path=/dists/sid/linux/; revision=19661
This commit is contained in:
Ben Hutchings 2012-12-29 13:02:12 +00:00
parent 0ab5830f6c
commit 5b9872070b
3 changed files with 43 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.2.35-3) UNRELEASED; urgency=low
[ Ben Hutchings ]
* Input: wacom - fix touch support for Bamboo Fun CTH-461
-- Ben Hutchings <ben@decadent.org.uk> Thu, 27 Dec 2012 02:17:44 +0100
linux (3.2.35-2) unstable; urgency=low
* [ia64] Make IPV6 built-in (fixes FTBFS)

View File

@ -0,0 +1,35 @@
From: Diego Calleja <diegocg@gmail.com>
Date: Mon, 3 Dec 2012 21:16:11 -0800
Subject: Input: wacom - fix touch support for Bamboo Fun CTH-461
commit e12b3cecf221644ccab64d7c30a6df58b7630cb0 upstream.
Commit f393ee2b814e3291c12565000210b3cf10aa5c1d forgot to add the
touch_max property for Wacom Bamboo Fun CTH-461/S, ID 056a:00d2.
This broke the touch functionality for that device. This patch,
(done with help of Ping Cheng), adds the correct value and makes
touch work again.
Signed-off-by: Diego Calleja <diegocg@gmail.com>
Reviewed-by: Ping Cheng <pinglinux@gmail.com>
Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/input/tablet/wacom_wac.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/input/tablet/wacom_wac.c b/drivers/input/tablet/wacom_wac.c
index 0a67031..c2bfe92 100644
--- a/drivers/input/tablet/wacom_wac.c
+++ b/drivers/input/tablet/wacom_wac.c
@@ -2034,7 +2034,8 @@ static const struct wacom_features wacom_features_0xD1 =
.touch_max = 2 };
static const struct wacom_features wacom_features_0xD2 =
{ "Wacom Bamboo Craft", WACOM_PKGLEN_BBFUN, 14720, 9200, 1023,
- 31, BAMBOO_PT, WACOM_INTUOS_RES, WACOM_INTUOS_RES };
+ 31, BAMBOO_PT, WACOM_INTUOS_RES, WACOM_INTUOS_RES,
+ .touch_max = 2 };
static const struct wacom_features wacom_features_0xD3 =
{ "Wacom Bamboo 2FG 6x8", WACOM_PKGLEN_BBFUN, 21648, 13700, 1023,
31, BAMBOO_PT, WACOM_INTUOS_RES, WACOM_INTUOS_RES,

View File

@ -197,6 +197,7 @@ features/all/wacom/0027-wacom-do-not-crash-when-retrieving-touch_max.patch
features/all/wacom/0028-wacom-leave-touch_max-as-is-if-predefined.patch
features/all/wacom/0029-wacom-do-not-request-tablet-data-on-MT-Tablet-PC-pen.patch
features/all/wacom/0030-wacom-ignore-new-style-Wacom-multi-touch-packets-on-.patch
features/all/wacom/0031-input-wacom-fix-touch-support-for-bamboo-fun-cth-461.patch
# Add support for Ralink RT5392/RF5372 chipset
features/all/rt2x00-add-debug-message-for-new-chipset.patch