[i386/686] Enable MGEODE_LX instead of M686 (regression in 4.16)

- x86-32: Disable 3D-Now in generic config
This commit is contained in:
Ben Hutchings 2018-09-25 20:00:50 +01:00
parent 89193121c5
commit 5a77952e41
4 changed files with 35 additions and 1 deletions

2
debian/changelog vendored
View File

@ -156,6 +156,8 @@ linux (4.18.9-1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* drivers/net/ethernet: Ignore ABI changes (fixes FTBFS on arm64, armhf)
* [arm64] ACPI: Change ACPI_NFIT from built-in to module
* [i386/686] Enable MGEODE_LX instead of M686 (regression in 4.16)
- x86-32: Disable 3D-Now in generic config
[ Yves-Alexis Perez ]
* [x86] enable PINCTRL_AMD for touchpad support on Lenovo IdeaPad.

View File

@ -18,7 +18,9 @@ CONFIG_GEOS=y
##
## choice: Processor family
# CONFIG_M486 is not set
CONFIG_M686=y
#. We want to support Geode LX and similar AMD family 5 CPUs as well as
#. family 6+ CPUs
CONFIG_MGEODE_LX=y
## end choice
##

View File

@ -0,0 +1,29 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 25 Sep 2018 19:44:13 +0100
Subject: x86-32: Disable 3D-Now in generic config
We want the 686 flavour to run on Geode LX and similar AMD family 5
CPUs as well as family 6 and higher CPUs. This used to work with
CONFIG_M686=y. However commit 25d76ac88821 "x86/Kconfig: Explicitly
enumerate i686-class CPUs in Kconfig" in Linux 4.16 has made the
kernel require family 6 or higher.
It looks like a sensible choice would be to enable CONFIG_MGEODE_LX
and CONFIG_X86_GENERIC (for more generic optimisations), but this
currently enables CONFIG_X86_USE_3D_NOW which will cause the kernel to
crash on CPUs without the AMD-specific 3D-Now instructions.
Make CONFIG_X86_USE_3DNOW depend on CONFIG_X86_GENERIC being disabled.
---
--- a/arch/x86/Kconfig.cpu
+++ b/arch/x86/Kconfig.cpu
@@ -337,7 +337,7 @@ config X86_USE_PPRO_CHECKSUM
config X86_USE_3DNOW
def_bool y
- depends on (MCYRIXIII || MK7 || MGEODE_LX) && !UML
+ depends on (MCYRIXIII || MK7 || MGEODE_LX) && !X86_GENERIC && !UML
#
# P6_NOPs are a relatively minor optimization that require a family >=

View File

@ -76,6 +76,7 @@ bugfix/powerpc/powerpc-lib-sstep-fix-building-for-powerpcspe.patch
bugfix/powerpc/powerpc-lib-makefile-don-t-pull-in-quad.o-for-32-bit.patch
bugfix/arm/arm-mm-export-__sync_icache_dcache-for-xen-privcmd.patch
bugfix/arm64/arm64-acpi-Add-fixup-for-HPE-m400-quirks.patch
bugfix/x86/x86-32-disable-3dnow-in-generic-config.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch