aufs: Update to aufs4.x-rcN 20180702 and re-enable

This commit is contained in:
Ben Hutchings 2018-07-01 19:44:18 +01:00
parent 6143dfd1bd
commit 5866ae2a5f
5 changed files with 85 additions and 85 deletions

2
debian/changelog vendored
View File

@ -3,7 +3,7 @@ linux (4.18~rc2-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Ben Hutchings ]
* aufs: Disable support patchset until it is updated for Linux 4.18
* aufs: Update to aufs4.x-rcN 20180702
-- Ben Hutchings <ben@decadent.org.uk> Tue, 26 Jun 2018 01:43:53 +0100

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jun 6 14:11:07 2018 +0900
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -10,10 +10,10 @@ SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 9c125f7..4616bbf 100644
index 6cfd167..f60bb6e 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2519,6 +2519,19 @@ F: include/linux/audit.h
@@ -2541,6 +2541,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -32,13 +32,13 @@ index 9c125f7..4616bbf 100644
+
AUXILIARY DISPLAY DRIVERS
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
S: Maintained
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index 55cf554..bc965e5 100644
index d6b6f43..c0898a4 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -713,6 +713,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
@@ -741,6 +741,24 @@ static int loop_change_fd(struct loop_device *lo, struct block_device *bdev,
return error;
}
+/*
@ -63,20 +63,20 @@ index 55cf554..bc965e5 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index 2acfc69..ff338e2 100644
index 0e8e5de..88de3b6 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1234,7 +1234,7 @@ enum d_walk_ret {
@@ -1240,7 +1240,7 @@ enum d_walk_ret {
*
* The @enter() and @finish() callbacks are called with d_lock held.
* The @enter() callbacks are called with d_lock held.
*/
-static void d_walk(struct dentry *parent, void *data,
+void d_walk(struct dentry *parent, void *data,
enum d_walk_ret (*enter)(void *, struct dentry *),
void (*finish)(void *))
enum d_walk_ret (*enter)(void *, struct dentry *))
{
struct dentry *this_parent;
diff --git a/fs/fcntl.c b/fs/fcntl.c
index d737ff0..7550799 100644
index 12273b6..545e686 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -32,7 +32,7 @@
@ -98,20 +98,20 @@ index d737ff0..7550799 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 3b55391..e0c5255 100644
index 2c300e9..1b04ac4 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1663,7 +1663,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1649,7 +1649,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
-static int update_time(struct inode *inode, struct timespec *time, int flags)
+int update_time(struct inode *inode, struct timespec *time, int flags)
-static int update_time(struct inode *inode, struct timespec64 *time, int flags)
+int update_time(struct inode *inode, struct timespec64 *time, int flags)
{
int (*update_time)(struct inode *, struct timespec *, int);
int (*update_time)(struct inode *, struct timespec64 *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index 5f75969..61129ff 100644
index 8ddd148..ee649e0 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
@ -128,7 +128,7 @@ index 5f75969..61129ff 100644
* vfsmount lock must be held for write
*/
diff --git a/fs/read_write.c b/fs/read_write.c
index c4eabbf..ddd6e67 100644
index 153f8f6..ccc5bc8 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -489,6 +489,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@ -161,10 +161,10 @@ index c4eabbf..ddd6e67 100644
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index 005d09c..f617ab0 100644
index b3daa97..1dd7f96 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -837,8 +837,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@@ -838,8 +838,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -175,7 +175,7 @@ index 005d09c..f617ab0 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -854,9 +854,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -855,9 +855,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -214,10 +214,10 @@ index 279720d..76e38ea 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 760d8da..09a2542 100644
index 5c91108..4addb46 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1270,6 +1270,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1273,6 +1273,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -225,7 +225,7 @@ index 760d8da..09a2542 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1724,6 +1725,7 @@ struct file_operations {
@@ -1735,6 +1736,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -233,7 +233,7 @@ index 760d8da..09a2542 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1794,6 +1796,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1805,6 +1807,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -246,15 +246,15 @@ index 760d8da..09a2542 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2199,6 +2207,7 @@ extern int current_umask(void);
@@ -2220,6 +2228,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
+extern int update_time(struct inode *, struct timespec *, int);
extern int generic_update_time(struct inode *, struct timespec64 *, int);
+extern int update_time(struct inode *, struct timespec64 *, int);
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2485,6 +2494,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2506,6 +2515,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -318,7 +318,7 @@ index 74b4911..19789fb 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 0233863..06e0d7a 100644
index 5fa4d31..720f070 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -140,7 +140,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jun 6 14:11:07 2018 +0900
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -10,10 +10,10 @@ SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 1a76d75..77f698e 100644
index aaffc0c..ab72941 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2024,7 +2024,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -2004,7 +2004,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -23,7 +23,7 @@ index 1a76d75..77f698e 100644
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index 7563437..7c0dc0f 100644
index 3b63be6..fb9913b 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
@ -39,10 +39,10 @@ index 7563437..7c0dc0f 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index c486ad4..76b71f8 100644
index e967901..f6b7286 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -305,7 +305,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@@ -306,7 +306,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -54,7 +54,7 @@ index c486ad4..76b71f8 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1726,7 +1729,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1733,7 +1736,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -80,10 +80,10 @@ index 5b62f57..dfb4a3b 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 02a616e..01b3bb9 100644
index a0fbb9f..4d615af 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1380,6 +1380,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
@@ -1429,6 +1429,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
@ -113,10 +113,10 @@ index 02a616e..01b3bb9 100644
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 2161234..78aa367 100644
index 99ce070..8babe35 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -251,6 +251,7 @@ struct vm_region {
@@ -236,6 +236,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -124,7 +124,7 @@ index 2161234..78aa367 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -325,6 +326,7 @@ struct vm_area_struct {
@@ -310,6 +311,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -133,10 +133,10 @@ index 2161234..78aa367 100644
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index a5d21c4..e965e09 100644
index 9440d61..b966ed6 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -473,7 +473,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@@ -481,7 +481,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -146,7 +146,7 @@ index a5d21c4..e965e09 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index b4e54a9a..77892ae 100644
index 8716bda..68afd6d 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@ -159,11 +159,11 @@ index b4e54a9a..77892ae 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 0604cb0..45d2369 100644
index 52517f2..250f675 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2700,7 +2700,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
@@ -2700,7 +2700,7 @@ vm_fault_t filemap_page_mkwrite(struct vm_fault *vmf)
vm_fault_t ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
- file_update_time(vmf->vma->vm_file);
@ -172,7 +172,7 @@ index 0604cb0..45d2369 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index fc41c05..e376869 100644
index d1eb87e..72bd98d 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -180,7 +180,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@ -228,7 +228,7 @@ index fc41c05..e376869 100644
- struct file *file;
+ struct file *file, *prfile;
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.rst.\n",
current->comm, current->pid);
@@ -2901,10 +2901,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
@ -269,7 +269,7 @@ index fc41c05..e376869 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 1372373..6362dde 100644
index 4452d8b..d621193 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm_region *region)

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Jun 6 14:11:07 2018 +0900
Date: Sun Jul 1 12:48:09 2018 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Origin: https://github.com/sfjro/aufs4-standalone/tree/439651f04f6a359ccfe63c399162a000c4684ca9
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -10,10 +10,10 @@ SPDX-License-Identifier: GPL-2.0
aufs4.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index ff338e2..3e2bae8 100644
index 88de3b6..de0091a 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1342,6 +1342,7 @@ void d_walk(struct dentry *parent, void *data,
@@ -1345,6 +1345,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -21,7 +21,7 @@ index ff338e2..3e2bae8 100644
struct check_mount {
struct vfsmount *mnt;
@@ -2942,6 +2943,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
@@ -2891,6 +2892,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -30,7 +30,7 @@ index ff338e2..3e2bae8 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 183059c..35adee4 100644
index 2d4e007..7adbf282 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -42,7 +42,7 @@ index 183059c..35adee4 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 7550799..d403576 100644
index 545e686..0237ad7 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
@ -90,10 +90,10 @@ index 7ec0b3e..819ee07 100644
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index e0c5255..ff36056 100644
index 1b04ac4..d65a5e9 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1672,6 +1672,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
@@ -1658,6 +1658,7 @@ int update_time(struct inode *inode, struct timespec64 *time, int flags)
return update_time(inode, time, flags);
}
@ -102,7 +102,7 @@ index e0c5255..ff36056 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 61129ff..5d3e0382 100644
index ee649e0..10923cb 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@ -130,7 +130,7 @@ index 61129ff..5d3e0382 100644
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index b7a4b6a..5a69d60 100644
index aa5468f2..b38d224 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -166,7 +166,7 @@ index b7a4b6a..5a69d60 100644
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index e9191b4..1f8ccfa 100644
index 61f4c5f..b20a16c 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -108,6 +108,7 @@ void fsnotify_get_mark(struct fsnotify_mark *mark)
@ -177,7 +177,7 @@ index e9191b4..1f8ccfa 100644
static void __fsnotify_recalc_mask(struct fsnotify_mark_connector *conn)
{
@@ -392,6 +393,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
@@ -399,6 +400,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -185,7 +185,7 @@ index e9191b4..1f8ccfa 100644
/*
* Sorting function for lists of fsnotify marks.
@@ -606,6 +608,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark, struct inode *inode,
@@ -612,6 +614,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark, struct inode *inode,
fsnotify_put_mark(mark);
return ret;
}
@ -193,7 +193,7 @@ index e9191b4..1f8ccfa 100644
int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
struct vfsmount *mnt, int allow_dups)
@@ -741,6 +744,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
@@ -747,6 +750,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
fsnotify_get_group(group);
mark->group = group;
}
@ -222,7 +222,7 @@ index d0e955b..527bc1a 100644
int open_check_o_direct(struct file *f)
{
diff --git a/fs/read_write.c b/fs/read_write.c
index ddd6e67..aabf92d 100644
index ccc5bc8..36f52f4 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -459,6 +459,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
@ -258,10 +258,10 @@ index ddd6e67..aabf92d 100644
static inline loff_t file_pos_read(struct file *file)
{
diff --git a/fs/splice.c b/fs/splice.c
index f617ab0..ec0ad02 100644
index 1dd7f96..a5e3bcb 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -850,6 +850,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -851,6 +851,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -269,7 +269,7 @@ index f617ab0..ec0ad02 100644
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -879,6 +880,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
@@ -880,6 +881,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -290,10 +290,10 @@ index 2860782..ffd7ea4 100644
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 61cd28b..35570cd 100644
index f9cb1db..000b62b 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -297,6 +297,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -302,7 +302,7 @@ index 61cd28b..35570cd 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 06e0d7a..6af91bd 100644
index 720f070..4f58215 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
@ -323,10 +323,10 @@ index 0fef395..83fb1ec 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 1ce701f..a0d106e 100644
index f4c33ab..70563f1 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1332,12 +1332,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1336,12 +1336,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
@ -342,7 +342,7 @@ index 1ce701f..a0d106e 100644
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index c65b39b..e363d22 100644
index cd97929..424fd23 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -8,6 +8,7 @@
@ -359,7 +359,7 @@ index c65b39b..e363d22 100644
}
+EXPORT_SYMBOL_GPL(__devcgroup_check_permission);
diff --git a/security/security.c b/security/security.c
index 7bc2fde..6bd0468 100644
index 68f46d8..3bc1348 100644
--- a/security/security.c
+++ b/security/security.c
@@ -537,6 +537,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)

View File

@ -24,9 +24,9 @@ debian/firmware_class-refer-to-debian-wiki-firmware-page.patch
# Patches from aufs4 repository, imported with
# debian/patches/features/all/aufs4/gen-patch. These are only the
# changes needed to allow aufs to be built out-of-tree.
#features/all/aufs4/aufs4-base.patch
#features/all/aufs4/aufs4-mmap.patch
#features/all/aufs4/aufs4-standalone.patch
features/all/aufs4/aufs4-base.patch
features/all/aufs4/aufs4-mmap.patch
features/all/aufs4/aufs4-standalone.patch
# Change some defaults for security reasons
debian/af_802154-Disable-auto-loading-as-mitigation-against.patch