Replace 2.6.32.14-rc1 with 2.6.32.14

One of the reversions in revert-percpu-stable-changes.patch was
now included in 2.6.32.14, so replace that patch.

svn path=/dists/sid/linux-2.6/; revision=15793
This commit is contained in:
Ben Hutchings 2010-05-27 02:32:34 +00:00
parent 46d2cea71c
commit 57f3f4f490
4 changed files with 49 additions and 6 deletions

10
debian/changelog vendored
View File

@ -19,16 +19,16 @@ linux-2.6 (2.6.32-14) UNRELEASED; urgency=low
* [amd64] ext4: Fix compat EXT4_IOC_ADD_GROUP (used by online resize)
* Install debug kernel image in /usr/lib/debug/boot (Closes: #582810)
* net: sysfs: Check for null ethtool_ops before getting speed/duplex
* Add stable 2.6.32.14:
- [hppa] Revert "parisc: Set PCI CLS early in boot.", erroneously
included in 2.6.32.13 causing FTBFS
- btrfs: check for read permission on src file in the clone ioctl
(CVE-2010-1636)
[ Bastian Blank ]
* Update Xen patch.
[ maximilian attems]
* Add stable 2.6.32.14-rc1:
- [hppa] Revert "parisc: Set PCI CLS early in boot.", erroneously
included in 2.6.32.13 causing FTBFS
- btrfs: check for read permission on src file in the clone ioctl
(CVE-2010-1636)
* Add drm changes from stable 2.6.33.5:
- i915: Disable FBC on 915GM and 945GM (Closes: #582427)
* Update openvz patch to 509eb1f29c43.

View File

@ -0,0 +1,26 @@
From e8ab48d1bda68c75a7e5683df4cd70334bf89189 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 27 May 2010 03:29:52 +0100
Subject: [PATCH] Revert "modules: fix incorrect percpu usage"
This reverts commit ea0a09acd81c6d52c77d80f0d4089795df7bcb58.
---
kernel/module.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/kernel/module.c b/kernel/module.c
index a4aae35..dfa33e8 100644
--- a/kernel/module.c
+++ b/kernel/module.c
@@ -555,7 +555,7 @@ static void percpu_modcopy(void *pcpudest, const void *from, unsigned long size)
int cpu;
for_each_possible_cpu(cpu)
- memcpy(per_cpu_ptr(pcpudest, cpu), from, size);
+ memcpy(pcpudest + per_cpu_offset(cpu), from, size);
}
#else /* ... !CONFIG_SMP */
--
1.7.1

View File

@ -35,6 +35,8 @@ index 2c48f94..5c86fe9 100644
or if empty, the mapping is anonymous.
diff --git a/Makefile b/Makefile
index 801d0e1..47866f8 100644
diff --git a/arch/parisc/kernel/pci.c b/arch/parisc/kernel/pci.c
index 9e74bfe..f7064ab 100644
--- a/arch/parisc/kernel/pci.c
@ -1208,6 +1210,19 @@ index e694263..6920695 100644
}
static inline void
diff --git a/include/linux/module.h b/include/linux/module.h
index 460df15..482efc8 100644
--- a/include/linux/module.h
+++ b/include/linux/module.h
@@ -455,7 +455,7 @@ void symbol_put_addr(void *addr);
static inline local_t *__module_ref_addr(struct module *mod, int cpu)
{
#ifdef CONFIG_SMP
- return (local_t *) per_cpu_ptr(mod->refptr, cpu);
+ return (local_t *) (mod->refptr + per_cpu_offset(cpu));
#else
return &mod->ref;
#endif
diff --git a/include/linux/sched.h b/include/linux/sched.h
index 70abfd3..b253434 100644
--- a/include/linux/sched.h

View File

@ -10,7 +10,9 @@
+ bugfix/all/iwlwifi-manage-QoS-by-mac-stack.patch
- bugfix/all/megaraid_sas-fix-compat_ioctl-sense_ptr.patch
- bugfix/all/p54-disable-channels-with-incomplete-calibration-dat.patch
+ bugfix/all/stable/2.6.32.14-rc1.patch
- bugfix/all/revert-percpu-stable-changes.patch
+ bugfix/all/stable/2.6.32.14.patch
+ bugfix/all/revert-percpu-stable-changes-2.patch
+ bugfix/all/drm-i915-use-pipe_control-instruction-on-ironlake-and-sandy-bridge.patch
+ bugfix/all/drm-i915-fix-non-ironlake-965-class-crashes.patch
+ bugfix/all/drm-i915-disable-fbc-on-915gm-and-945gm.patch