aufs: Update support patchset to aufs4.x-rcN-20170828

This commit is contained in:
Ben Hutchings 2017-08-30 20:39:32 +01:00
parent 9ba3914638
commit 5775a8c918
4 changed files with 143 additions and 86 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux (4.13~rc7-1~exp1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* [sh4] Do not use hyphen in exported variable names (fixes FTBFS)
* aufs: Update support patchset to aufs4.x-rcN-20170828
[ Roger Shimizu ]
* [armel] Disable CONFIG_STRICT_KERNEL_RWX, which will save about 3MB

View File

@ -1,13 +1,15 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Date: Fri Aug 25 18:02:16 2017 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/9aa6b2e732a0ae7057e247cabc7bd6869714e8a3
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.11.7+ base patch
aufs4.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 6f7721d..b320f68 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2392,6 +2392,19 @@ F: include/linux/audit.h
@ -30,9 +32,11 @@ aufs4.11.7+ base patch
AUXILIARY DISPLAY DRIVERS
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index ef83349..4551210 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -707,6 +707,24 @@ static inline int is_loop_device(struct
@@ -707,6 +707,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
}
@ -57,6 +61,8 @@ aufs4.11.7+ base patch
/* loop sysfs attributes */
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index f901413..e3719a5 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1197,7 +1197,7 @@ enum d_walk_ret {
@ -68,6 +74,8 @@ aufs4.11.7+ base patch
enum d_walk_ret (*enter)(void *, struct dentry *),
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 3b01b64..659760e 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -31,7 +31,7 @@
@ -79,7 +87,7 @@ aufs4.11.7+ base patch
{
struct inode * inode = file_inode(filp);
int error = 0;
@@ -62,6 +62,8 @@ static int setfl(int fd, struct file * f
@@ -62,6 +62,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
if (filp->f_op->check_flags)
error = filp->f_op->check_flags(arg);
@ -88,6 +96,8 @@ aufs4.11.7+ base patch
if (error)
return error;
diff --git a/fs/inode.c b/fs/inode.c
index 5037059..73820bf 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1641,7 +1641,7 @@ EXPORT_SYMBOL(generic_update_time);
@ -99,9 +109,11 @@ aufs4.11.7+ base patch
{
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index 0cc7033..6e542f0 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -473,6 +473,28 @@ ssize_t __vfs_write(struct file *file, c
@@ -473,6 +473,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
}
EXPORT_SYMBOL(__vfs_write);
@ -130,6 +142,8 @@ aufs4.11.7+ base patch
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index ae41201..9753304 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -853,8 +853,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@ -143,7 +157,7 @@ aufs4.11.7+ base patch
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -870,9 +870,9 @@ static long do_splice_from(struct pipe_i
@@ -870,9 +870,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -156,6 +170,8 @@ aufs4.11.7+ base patch
{
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index 2a54c1f..7a5fa3f 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -27,7 +27,7 @@
@ -167,6 +183,8 @@ aufs4.11.7+ base patch
{
if (wait)
sync_inodes_sb(sb);
diff --git a/include/linux/file.h b/include/linux/file.h
index 61eb82c..e700888 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -19,6 +19,7 @@ struct dentry;
@ -177,9 +195,11 @@ aufs4.11.7+ base patch
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 6e1fd5d..9421ed0 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1262,6 +1262,7 @@ extern void fasync_free(struct fasync_st
@@ -1262,6 +1262,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -195,7 +215,7 @@ aufs4.11.7+ base patch
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1753,6 +1755,12 @@ ssize_t rw_copy_check_uvector(int type,
@@ -1753,6 +1755,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -216,7 +236,7 @@ aufs4.11.7+ base patch
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2437,6 +2446,7 @@ static inline bool sb_is_blkdev_sb(struc
@@ -2437,6 +2446,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -224,9 +244,11 @@ aufs4.11.7+ base patch
extern int sync_filesystem(struct super_block *);
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index db42746..12f3a5a 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -86,4 +86,10 @@ extern void splice_shrink_spd(struct spl
@@ -86,4 +86,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;
extern const struct pipe_buf_operations default_pipe_buf_ops;

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Date: Fri Aug 25 18:02:16 2017 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/9aa6b2e732a0ae7057e247cabc7bd6869714e8a3
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.11.7+ mmap patch
aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index c87b6b9..6b71643 100644
index 719c2e9..a1b7968 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1946,7 +1946,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -1986,7 +1986,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -38,10 +38,10 @@ index 7563437..7c0dc0f 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index f401682..79ea96a 100644
index fe8f326..b2f7f1a 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -292,7 +292,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@@ -293,7 +293,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -53,7 +53,7 @@ index f401682..79ea96a 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1632,7 +1635,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1640,7 +1643,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -79,10 +79,10 @@ index 23266694..58e59b6 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index cec423b..b6b2f901 100644
index 46b9ac5..62ba1c3 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1294,6 +1294,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1306,6 +1306,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -112,7 +112,7 @@ index cec423b..b6b2f901 100644
unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index f60f45f..38c5f76 100644
index 3cadee0..d0142c1 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -259,6 +259,7 @@ struct vm_region {
@ -132,10 +132,10 @@ index f60f45f..38c5f76 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 4f7151d..ebe8415 100644
index e075b77..af14572 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -641,7 +641,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@@ -663,7 +663,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -145,7 +145,7 @@ index 4f7151d..ebe8415 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 026f6a8..723da17 100644
index 411bd24..e7de927 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@ -158,10 +158,10 @@ index 026f6a8..723da17 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 157c047..0cf15d2 100644
index a497024..9389040 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2406,7 +2406,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
@@ -2541,7 +2541,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -171,7 +171,7 @@ index 157c047..0cf15d2 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index cde1262..72ca169 100644
index f19efcf..7fdd59e 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -170,7 +170,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@ -202,7 +202,7 @@ index cde1262..72ca169 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2571,7 +2571,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2568,7 +2568,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -211,7 +211,7 @@ index cde1262..72ca169 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2590,7 +2590,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2587,7 +2587,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -220,7 +220,7 @@ index cde1262..72ca169 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2744,7 +2744,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2741,7 +2741,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -229,7 +229,7 @@ index cde1262..72ca169 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2819,10 +2819,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2816,10 +2816,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -258,7 +258,7 @@ index cde1262..72ca169 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3113,7 +3130,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -3110,7 +3127,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -268,10 +268,10 @@ index cde1262..72ca169 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 2d131b9..5dc9a19 100644
index fc184f5..637ea81 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -637,7 +637,7 @@ static void __put_nommu_region(struct vm_region *region)
@@ -641,7 +641,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -280,7 +280,7 @@ index 2d131b9..5dc9a19 100644
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -795,7 +795,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
@@ -799,7 +799,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -289,7 +289,7 @@ index 2d131b9..5dc9a19 100644
put_nommu_region(vma->vm_region);
kmem_cache_free(vm_area_cachep, vma);
}
@@ -1322,7 +1322,7 @@ unsigned long do_mmap(struct file *file,
@@ -1326,7 +1326,7 @@ unsigned long do_mmap(struct file *file,
goto error_just_free;
}
}
@ -298,7 +298,7 @@ index 2d131b9..5dc9a19 100644
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1397,10 +1397,10 @@ unsigned long do_mmap(struct file *file,
@@ -1401,10 +1401,10 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)

View File

@ -1,16 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Date: Fri Aug 25 18:02:16 2017 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/9aa6b2e732a0ae7057e247cabc7bd6869714e8a3
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.11.7+ standalone patch
aufs4.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index e3719a5..3203470 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1272,6 +1272,7 @@ rename_retry:
@@ -1305,6 +1305,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -18,7 +20,7 @@ aufs4.11.7+ standalone patch
struct check_mount {
struct vfsmount *mnt;
@@ -2862,6 +2863,7 @@ void d_exchange(struct dentry *dentry1,
@@ -2894,6 +2895,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -26,9 +28,11 @@ aufs4.11.7+ standalone patch
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 62175cb..f0b6fdd 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
}
@ -36,9 +40,11 @@ aufs4.11.7+ standalone patch
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 659760e..5c37087 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -84,6 +84,7 @@ int setfl(int fd, struct file * filp, un
@@ -84,6 +84,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -46,9 +52,11 @@ aufs4.11.7+ standalone patch
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 72e861a..01ae52f 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -148,6 +148,7 @@ over:
@@ -148,6 +148,7 @@ struct file *get_empty_filp(void)
}
return ERR_PTR(-ENFILE);
}
@ -56,7 +64,7 @@ aufs4.11.7+ standalone patch
/**
* alloc_file - allocate and initialize a 'struct file'
@@ -259,6 +260,7 @@ void flush_delayed_fput(void)
@@ -260,6 +261,7 @@ void flush_delayed_fput(void)
{
delayed_fput(NULL);
}
@ -64,7 +72,7 @@ aufs4.11.7+ standalone patch
static DECLARE_DELAYED_WORK(delayed_fput_work, delayed_fput);
@@ -301,6 +303,7 @@ void __fput_sync(struct file *file)
@@ -302,6 +304,7 @@ void __fput_sync(struct file *file)
}
EXPORT_SYMBOL(fput);
@ -72,7 +80,7 @@ aufs4.11.7+ standalone patch
void put_filp(struct file *file)
{
@@ -309,6 +312,7 @@ void put_filp(struct file *file)
@@ -310,6 +313,7 @@ void put_filp(struct file *file)
file_free(file);
}
}
@ -80,9 +88,11 @@ aufs4.11.7+ standalone patch
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index 73820bf..7db829e 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1649,6 +1649,7 @@ int update_time(struct inode *inode, str
@@ -1650,6 +1650,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
@ -90,9 +100,11 @@ aufs4.11.7+ standalone patch
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index f8893dc..c55d949 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -462,6 +462,7 @@ void __mnt_drop_write(struct vfsmount *m
@@ -463,6 +463,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -100,7 +112,7 @@ aufs4.11.7+ standalone patch
/**
* mnt_drop_write - give up write access to a mount
@@ -1881,6 +1882,7 @@ int iterate_mounts(int (*f)(struct vfsmo
@@ -1823,6 +1824,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -108,6 +120,8 @@ aufs4.11.7+ standalone patch
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index 3235753..14a2d48 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -118,7 +132,7 @@ aufs4.11.7+ standalone patch
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -109,6 +110,7 @@ void fsnotify_get_group(struct fsnotify_
@@ -109,6 +110,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
atomic_inc(&group->refcnt);
}
@ -126,7 +140,7 @@ aufs4.11.7+ standalone patch
/*
* Drop a reference to a group. Free it if it's through.
@@ -118,6 +120,7 @@ void fsnotify_put_group(struct fsnotify_
@@ -118,6 +120,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (atomic_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -134,7 +148,7 @@ aufs4.11.7+ standalone patch
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -147,6 +150,7 @@ struct fsnotify_group *fsnotify_alloc_gr
@@ -147,6 +150,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -142,17 +156,19 @@ aufs4.11.7+ standalone patch
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index 9991f88..117042c 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -255,6 +255,7 @@ void fsnotify_put_mark(struct fsnotify_m
queue_delayed_work(system_unbound_wq, &reaper_work,
FSNOTIFY_REAPER_DELAY);
@@ -118,6 +118,7 @@ static bool fsnotify_get_mark_safe(struct fsnotify_mark *mark)
{
return atomic_inc_not_zero(&mark->refcnt);
}
+EXPORT_SYMBOL_GPL(fsnotify_put_mark);
bool fsnotify_prepare_user_wait(struct fsnotify_iter_info *iter_info)
static void __fsnotify_recalc_mask(struct fsnotify_mark_connector *conn)
{
@@ -395,6 +396,7 @@ void fsnotify_destroy_mark(struct fsnoti
@@ -395,6 +396,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -160,15 +176,15 @@ aufs4.11.7+ standalone patch
/*
* Sorting function for lists of fsnotify marks.
@@ -619,6 +621,7 @@ int fsnotify_add_mark(struct fsnotify_ma
mutex_unlock(&group->mark_mutex);
@@ -607,6 +609,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark, struct inode *inode,
fsnotify_put_mark(mark);
return ret;
}
+EXPORT_SYMBOL_GPL(fsnotify_add_mark);
/*
* Given a list of marks, find the mark associated with given group. If found
@@ -742,6 +745,7 @@ void fsnotify_init_mark(struct fsnotify_
int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
struct vfsmount *mnt, int allow_dups)
@@ -742,6 +745,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
fsnotify_get_group(group);
mark->group = group;
}
@ -176,9 +192,11 @@ aufs4.11.7+ standalone patch
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index 35bb784..92e08c5 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, l
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
inode_unlock(dentry->d_inode);
return ret;
}
@ -194,9 +212,11 @@ aufs4.11.7+ standalone patch
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index 6e542f0..c6fa090 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -523,6 +523,7 @@ vfs_readf_t vfs_readf(struct file *file)
@@ -483,6 +483,7 @@ vfs_readf_t vfs_readf(struct file *file)
return new_sync_read;
return ERR_PTR(-ENOSYS);
}
@ -204,7 +224,7 @@ aufs4.11.7+ standalone patch
vfs_writef_t vfs_writef(struct file *file)
{
@@ -534,6 +535,7 @@ vfs_writef_t vfs_writef(struct file *fil
@@ -494,6 +495,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -212,9 +232,11 @@ aufs4.11.7+ standalone patch
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
diff --git a/fs/splice.c b/fs/splice.c
index 9753304..b38e036 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -866,6 +866,7 @@ long do_splice_from(struct pipe_inode_in
@@ -866,6 +866,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -222,7 +244,7 @@ aufs4.11.7+ standalone patch
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -895,6 +896,7 @@ long do_splice_to(struct file *in, loff_
@@ -895,6 +896,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -230,9 +252,11 @@ aufs4.11.7+ standalone patch
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index 7a5fa3f..c9b9d46 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -38,6 +38,7 @@ int __sync_filesystem(struct super_block
@@ -38,6 +38,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
sb->s_op->sync_fs(sb, wait);
return __sync_blockdev(sb->s_bdev, wait);
}
@ -240,9 +264,11 @@ aufs4.11.7+ standalone patch
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 464c94b..0234d49 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -250,6 +276,8 @@ aufs4.11.7+ standalone patch
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/task_work.c b/kernel/task_work.c
index d513051..e056d54 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -119,3 +119,4 @@ void task_work_run(void)
@ -257,6 +285,8 @@ aufs4.11.7+ standalone patch
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 7abebd7..c079ce4 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1062,12 +1062,14 @@ int cap_mmap_addr(unsigned long addr)
@ -274,6 +304,8 @@ aufs4.11.7+ standalone patch
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 03c1652..f88c84b 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@ -284,7 +316,7 @@ aufs4.11.7+ standalone patch
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask)
return __devcgroup_check_permission(type, imajor(inode), iminor(inode),
access);
}
@ -292,9 +324,11 @@ aufs4.11.7+ standalone patch
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 3013237..342ce8b 100644
--- a/security/security.c
+++ b/security/security.c
@@ -492,6 +492,7 @@ int security_path_rmdir(const struct pat
@@ -535,6 +535,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -302,7 +336,7 @@ aufs4.11.7+ standalone patch
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -508,6 +509,7 @@ int security_path_symlink(const struct p
@@ -551,6 +552,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -310,7 +344,7 @@ aufs4.11.7+ standalone patch
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -516,6 +518,7 @@ int security_path_link(struct dentry *ol
@@ -559,6 +561,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -318,7 +352,7 @@ aufs4.11.7+ standalone patch
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -543,6 +546,7 @@ int security_path_truncate(const struct
@@ -586,6 +589,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -326,7 +360,7 @@ aufs4.11.7+ standalone patch
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -550,6 +554,7 @@ int security_path_chmod(const struct pat
@@ -593,6 +597,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -334,7 +368,7 @@ aufs4.11.7+ standalone patch
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -557,6 +562,7 @@ int security_path_chown(const struct pat
@@ -600,6 +605,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -342,7 +376,7 @@ aufs4.11.7+ standalone patch
int security_path_chroot(const struct path *path)
{
@@ -642,6 +648,7 @@ int security_inode_readlink(struct dentr
@@ -685,6 +691,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -350,7 +384,7 @@ aufs4.11.7+ standalone patch
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -657,6 +664,7 @@ int security_inode_permission(struct ino
@@ -700,6 +707,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -358,7 +392,7 @@ aufs4.11.7+ standalone patch
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -828,6 +836,7 @@ int security_file_permission(struct file
@@ -871,6 +879,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -366,7 +400,7 @@ aufs4.11.7+ standalone patch
int security_file_alloc(struct file *file)
{
@@ -887,6 +896,7 @@ int security_mmap_file(struct file *file
@@ -930,6 +939,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}