iwlwifi: allow to switch to HT40 if not associated (Closes: #653423)

svn path=/dists/sid/linux-2.6/; revision=18426
This commit is contained in:
Ben Hutchings 2011-12-28 16:20:44 +00:00
parent 7cfabda7d7
commit 576fc1b72c
3 changed files with 41 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (3.1.6-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* snapshot: Implement compat_ioctl (Closes: #502816)
* iwlwifi: allow to switch to HT40 if not associated (Closes: #653423)
[ Jonathan Nieder ]
* prerm: Print an error message when aborting removal of the running

View File

@ -0,0 +1,39 @@
From: Wey-Yi Guy <wey-yi.w.guy@intel.com>
Date: Wed, 14 Dec 2011 08:22:36 -0800
Subject: iwlwifi: allow to switch to HT40 if not associated
From: Wey-Yi Guy <wey-yi.w.guy@intel.com>
commit 78feb35b8161acd95c33a703ed6ab6f554d29387 upstream.
My previous patch
34a5b4b6af104cf18eb50748509528b9bdbc4036 iwlwifi: do not re-configure
HT40 after associated
Fix the case of HT40 after association on specified AP, but it break the
association for some APs and cause not able to establish connection.
We need to address HT40 before and after addociation.
Reported-by: Andrej Gelenberg <andrej.gelenberg@udo.edu>
Signed-off-by: Wey-Yi Guy <wey-yi.w.guy@intel.com>
Tested-by: Andrej Gelenberg <andrej.gelenberg@udo.edu>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
---
drivers/net/wireless/iwlwifi/iwl-agn-rxon.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
+++ b/drivers/net/wireless/iwlwifi/iwl-agn-rxon.c
@@ -620,8 +620,8 @@ int iwlagn_mac_config(struct ieee80211_h
if (ctx->ht.enabled) {
/* if HT40 is used, it should not change
* after associated except channel switch */
- if (iwl_is_associated_ctx(ctx) &&
- !ctx->ht.is_40mhz)
+ if (!ctx->ht.is_40mhz ||
+ !iwl_is_associated_ctx(ctx))
iwlagn_config_ht40(conf, ctx);
} else
ctx->ht.is_40mhz = false;

View File

@ -87,3 +87,4 @@
+ debian/inetpeer-hide-ABI-change-in-3.1.5.patch
+ bugfix/all/cciss-Add-IRQF_SHARED-back-in-for-the-non-MSI-X-inte.patch
+ bugfix/all/snapshot-Implement-compat_ioctl.patch
+ bugfix/all/iwlwifi-allow-to-switch-to-ht40-if-not-associated.patch