Update to 3.10-rc6

svn path=/dists/trunk/linux/; revision=20259
This commit is contained in:
Ben Hutchings 2013-06-16 03:08:36 +00:00
parent 520079b44c
commit 575f8cebf3
5 changed files with 7 additions and 72 deletions

5
debian/changelog vendored
View File

@ -1,5 +1,8 @@
linux (3.10~rc5-1~exp2) UNRELEASED; urgency=low
linux (3.10~rc6-1~exp1) UNRELEASED; urgency=low
* New upstream release candidate
[ Ben Hutchings ]
* [armhf/armmp] Add EMAC ethernet driver found on Allwinner A10 SoCs,
thanks to Niall Walsh (Closes: #711998)
- Add MDIO bus driver for the Allwinner EMAC

View File

@ -1,32 +0,0 @@
From: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date: Sat, 1 Jun 2013 07:08:09 +0530
Subject: ath9k: Disable PowerSave by default
commit 73c79617596b89a3693ff0d89d42bcd5ddedcf15 upstream.
Almost all the DMA issues which have plagued ath9k (in station mode)
for years are related to PS. Disabling PS usually "fixes" the user's
connection stablility. Reports of DMA problems are still trickling in
and are sitting in the kernel bugzilla. Until the PS code in ath9k is
given a thorough review, disbale it by default. The slight increase
in chip power consumption is a small price to pay for improved link
stability.
Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/ath/ath9k/init.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -787,8 +787,7 @@ void ath9k_set_hw_capab(struct ath_softc
hw->wiphy->iface_combinations = if_comb;
hw->wiphy->n_iface_combinations = ARRAY_SIZE(if_comb);
- if (AR_SREV_5416(sc->sc_ah))
- hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
+ hw->wiphy->flags &= ~WIPHY_FLAG_PS_ON_BY_DEFAULT;
hw->wiphy->flags |= WIPHY_FLAG_IBSS_RSN;
hw->wiphy->flags |= WIPHY_FLAG_SUPPORTS_TDLS;

View File

@ -1,34 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: iwlegacy: Use consistent condition for il_pm_ops
Date: Tue, 11 Jun 2013 04:37:26 +0100
Commit e82add550d9b 'net: wireless: iwlegacy: add CONFIG_PM_SLEEP to
suspend/resume functions' correctly changed the condition for defining
il_pm_ops and the functions it points to. But it didn't change the
condition for use of il_pm_ops, so iwl3945 and iwl4965 fail to link if
only CONFIG_PM is enabled.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/drivers/net/wireless/iwlegacy/common.h
+++ b/drivers/net/wireless/iwlegacy/common.h
@@ -1832,16 +1832,16 @@ u32 il_usecs_to_beacons(struct il_priv *
__le32 il_add_beacon_time(struct il_priv *il, u32 base, u32 addon,
u32 beacon_interval);
-#ifdef CONFIG_PM
+#ifdef CONFIG_PM_SLEEP
extern const struct dev_pm_ops il_pm_ops;
#define IL_LEGACY_PM_OPS (&il_pm_ops)
-#else /* !CONFIG_PM */
+#else /* !CONFIG_PM_SLEEP */
#define IL_LEGACY_PM_OPS NULL
-#endif /* !CONFIG_PM */
+#endif /* !CONFIG_PM_SLEEP */
/*****************************************************
* Error Handling Debugging

View File

@ -15,15 +15,15 @@ are available. This should trigger udev to load it.
---
--- a/arch/x86/platform/efi/efi.c
+++ b/arch/x86/platform/efi/efi.c
@@ -43,6 +43,7 @@
@@ -42,6 +42,7 @@
#include <linux/io.h>
#include <linux/reboot.h>
#include <linux/bcd.h>
#include <linux/ucs2_string.h>
+#include <linux/platform_device.h>
#include <asm/setup.h>
#include <asm/efi.h>
@@ -880,6 +881,20 @@ void __init efi_late_init(void)
@@ -783,6 +784,20 @@ void __init efi_late_init(void)
efi_bgrt_init();
}

View File

@ -85,9 +85,7 @@ features/arm/ARM-dts-imx-imx53-qsb.dts-enable-usbotg-and-usbh1.patch
features/arm/usbmisc-imx-add-module_device_table.patch
features/arm/imx53-qsb-usb-power.patch
bugfix/all/ath9k-Disable-PowerSave-by-default.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
bugfix/all/iwlegacy-use-consistent-condition-for-il_pm_ops.patch
features/arm/sunxi-emac/0001-net-Add-EMAC-ethernet-driver-found-on-Allwinner-A10-.patch
features/arm/sunxi-emac/0002-net-Add-MDIO-bus-driver-for-the-Allwinner-EMAC.patch
features/arm/sunxi-emac/0003-ARM-sun4i-Add-muxing-options-for-the-ethernet-contro.patch