* Switch sparc to gcc-4.1, no ABI bump as sparc

binaries for 2.6.17-1 never made it to the archive.
* Add sparc32-iotlb.patch.
* Add myself to uploaders.

svn path=/dists/trunk/linux-2.6/; revision=6884
This commit is contained in:
Jurij Smakov 2006-06-24 18:01:20 +00:00
parent 053f4238c0
commit 566e22af7b
5 changed files with 51 additions and 1 deletions

View File

@ -1,4 +1,5 @@
[base]
compiler: gcc-4.1
flavours:
sparc32
sparc64

11
debian/changelog vendored
View File

@ -1,3 +1,14 @@
linux-2.6 (2.6.17-2) unstable; urgency=low
[ Jurij Smakov ]
* [sparc] Switch to gcc-4.1 as it produces a working kernel,
while gcc-4.0 does not. No ABI bump neccessary, because
2.6.17-1 sparc binaries never made it to the archive.
* [sparc32] Add sparc32-iotlb.patch to fix DMA errors on sparc32.
* Add myself to uploaders.
-- Jurij Smakov <jurij@debian.org> Sat, 24 Jun 2006 10:54:59 -0700
linux-2.6 (2.6.17-1) unstable; urgency=low
[ Frederik Schüler ]

View File

@ -22,3 +22,4 @@
+ s390-drivers-ccw-uevent-cleanup.patch
+ mips-sb1-duart-tts.patch
+ 2.6.17.1
+ sparc32-iotlb.patch

37
debian/patches/sparc32-iotlb.patch vendored Normal file
View File

@ -0,0 +1,37 @@
From breuerr@mc.net Mon Jun 19 21:10:41 2006
Date: Mon, 19 Jun 2006 23:08:59 -0500
From: Bob Breuer <breuerr@mc.net>
To: sparclinux@vger.kernel.org
Subject: [PATCH] sparc32: fix iommu_flush_iotlb end address
Fix the calculation of the end address when flushing iotlb entries to
ram. This bug has been a cause of esp dma errors, and it affects
HyperSPARC systems much worse than SuperSPARC systems.
Signed-off-by: Bob Breuer <breuerr@mc.net>
---
Just in case it's not obvious from the patch as to how the dma was
broken: Each dma mapping sets up iopte entries for the iommu, and the
iommu only looks in main memory for the iopte entries. If there is a
group of iopte entries that are smaller than a page in size, but
straddle a page boundary, the broken code would fail to flush the last
page to ram.
Bob
diff --git a/arch/sparc/mm/iommu.c b/arch/sparc/mm/iommu.c
index 77840c8..7215849 100644
--- a/arch/sparc/mm/iommu.c
+++ b/arch/sparc/mm/iommu.c
@@ -144,8 +144,9 @@ static void iommu_flush_iotlb(iopte_t *i
unsigned long start;
unsigned long end;
- start = (unsigned long)iopte & PAGE_MASK;
+ start = (unsigned long)iopte;
end = PAGE_ALIGN(start + niopte*sizeof(iopte_t));
+ start &= PAGE_MASK;
if (viking_mxcc_present) {
while(start < end) {
viking_mxcc_flush_page(start);

View File

@ -2,7 +2,7 @@ Source: linux-@major@
Section: devel
Priority: optional
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Uploaders: Andres Salomon <dilinger@debian.org>, Bastian Blank <waldi@debian.org>, Simon Horman <horms@debian.org>, Sven Luther <luther@debian.org>, Jonas Smedegaard <dr@jones.dk>, Norbert Tretkowski <nobse@debian.org>, Frederik Schüler <fs@debian.org>
Uploaders: Andres Salomon <dilinger@debian.org>, Bastian Blank <waldi@debian.org>, Simon Horman <horms@debian.org>, Sven Luther <luther@debian.org>, Jonas Smedegaard <dr@jones.dk>, Norbert Tretkowski <nobse@debian.org>, Frederik Schüler <fs@debian.org>, Jurij Smakov <jurij@debian.org>
Standards-Version: 3.6.1.0
Build-Depends: debhelper (>= 4.1.0), module-init-tools, dpkg-dev (>= 1.10.23), debianutils (>= 1.6), bzip2, sparc-utils [sparc], kernel-package (>= 10.049), ocaml-interp, python, python2.4-minimal
Build-Depends-Indep: docbook-utils, gs, transfig, xmlto