[powerpc] KGDB: don't needlessly skip PAGE_USER test for Fsl booke

Note: KGDB is not currently enabled in debian builds (CVE-2010-1446)

svn path=/dists/sid/linux-2.6/; revision=15591
This commit is contained in:
dann frazier 2010-04-30 06:58:07 +00:00
parent f1cefb0bfa
commit 55dffb71b3
3 changed files with 45 additions and 0 deletions

2
debian/changelog vendored
View File

@ -66,6 +66,8 @@ linux-2.6 (2.6.32-12) UNRELEASED; urgency=low
errors (CVE-2010-1173)
* [CIFS] Allow null nd (as nfs server uses) on create (CVE-2010-1148)
* tipc: Fix oops on send prior to entering networked mode (CVE-2010-1187)
* [powerpc] KGDB: don't needlessly skip PAGE_USER test for Fsl booke
Note: KGDB is not currently enabled in debian builds (CVE-2010-1446)
[ Aurelien Jarno ]
* [sh4] Add a sh7751r flavour.

View File

@ -0,0 +1,42 @@
commit 56151e753468e34aeb322af4b0309ab727c97d2e
Author: Wufei <fei.wu@windriver.com>
Date: Wed Apr 28 17:42:32 2010 -0400
kgdb: don't needlessly skip PAGE_USER test for Fsl booke
The bypassing of this test is a leftover from 2.4 vintage
kernels, and is no longer appropriate, or even used by KGDB.
Currently KGDB uses probe_kernel_write() for all access to
memory via the KGDB core, so it can simply be deleted.
This fixes CVE-2010-1446.
CC: Benjamin Herrenschmidt <benh@kernel.crashing.org>
CC: Paul Mackerras <paulus@samba.org>
CC: Kumar Gala <galak@kernel.crashing.org>
Signed-off-by: Wufei <fei.wu@windriver.com>
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Adjusted to apply to Debian's 2.6.32 by dann frazier <dannf@debian.org>
diff -urpN a/arch/powerpc/mm/fsl_booke_mmu.c b/arch/powerpc/mm/fsl_booke_mmu.c
--- a/arch/powerpc/mm/fsl_booke_mmu.c 2009-12-02 20:51:21.000000000 -0700
+++ b/arch/powerpc/mm/fsl_booke_mmu.c 2010-04-30 00:49:04.000000000 -0600
@@ -131,15 +131,10 @@ void settlbcam(int index, unsigned long
TLBCAM[index].MAS3 = (phys & PAGE_MASK) | MAS3_SX | MAS3_SR;
TLBCAM[index].MAS3 |= ((flags & _PAGE_RW) ? MAS3_SW : 0);
-#ifndef CONFIG_KGDB /* want user access for breakpoints */
if (flags & _PAGE_USER) {
TLBCAM[index].MAS3 |= MAS3_UX | MAS3_UR;
TLBCAM[index].MAS3 |= ((flags & _PAGE_RW) ? MAS3_UW : 0);
}
-#else
- TLBCAM[index].MAS3 |= MAS3_UX | MAS3_UR;
- TLBCAM[index].MAS3 |= ((flags & _PAGE_RW) ? MAS3_UW : 0);
-#endif
tlbcam_addrs[index].start = virt;
tlbcam_addrs[index].limit = virt + size - 1;

View File

@ -62,3 +62,4 @@
+ bugfix/all/sctp-fix-skb_over_panic-resulting-from-multiple-invalid-parameter-errors.patch
+ bugfix/all/cifs-allow-null-nd-on-create.patch
+ bugfix/all/tipc-fix-oops-on-send-prior-to-entering-networked-mode.patch
+ bugfix/powerpc/kgdb-dont-needlessly-skip-PAGE_USER-test-for-Fsl-booke.patch