m25p80: Add support for Macronix 25L8005.

svn path=/dists/sid/linux-2.6/; revision=15891
This commit is contained in:
Martin Michlmayr 2010-06-19 10:49:23 +00:00
parent 8203cf8518
commit 55bb1e0e05
3 changed files with 21 additions and 0 deletions

1
debian/changelog vendored
View File

@ -47,6 +47,7 @@ linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
* Add support for OpenRD-Ultimate.
* QNAP TS-11x/TS-21x: Add MPP36 (RAM) and MPP44 (board ID).
* Add support for the HP t5325 Thin Client.
* m25p80: Add support for Macronix 25L8005.
[ Bastian Blank ]
* Disable mISDN support for NETJet cards. The driver binds a generic PCI

View File

@ -0,0 +1,19 @@
mtd: m25p80: Add support for Macronix 25L8005
Add support for Macronix 25L8005. Tested on a HP t5325 Thin Client.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
[backported to 2.6.32 -- tbm]
--- a/drivers/mtd/devices/m25p80.c 2010-06-19 10:37:08.000000000 +0000
+++ b/drivers/mtd/devices/m25p80.c 2010-06-19 10:37:54.000000000 +0000
@@ -621,6 +621,7 @@
{ "at26df321", 0x1f4701, 0, 64 * 1024, 64, SECT_4K, },
/* Macronix */
+ { "mx25l8005", 0xc22014, 0, 64 * 1024, 16, },
{ "mx25l3205d", 0xc22016, 0, 64 * 1024, 64, },
{ "mx25l6405d", 0xc22017, 0, 64 * 1024, 128, },
{ "mx25l12805d", 0xc22018, 0, 64 * 1024, 256, },

View File

@ -135,6 +135,7 @@
+ features/arm/ts219-mpp36.patch
+ features/arm/ts219-mpp44.patch
+ features/arm/hp-t5325.patch
+ features/all/m25p80-add-support-mx25l8005.patch
+ bugfix/mips/mips-Set-io_map_base-for-several-PCI-bridges-lacking.patch
- bugfix/all/vlan-macvlan-propagate-transmission-state-to-upper-layer.patch
+ features/sh4/sh-optimize-runtime-disabling-of-trapped-IO.patch