Update to 3.16.7-ckt7

Fix/ignore ABI changes as appropriate.

svn path=/dists/sid/linux/; revision=22422
This commit is contained in:
Ben Hutchings 2015-02-25 01:21:31 +00:00
parent 4cb54efeb9
commit 559d534a38
4 changed files with 120 additions and 1 deletions

34
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.16.7-ckt6-1) UNRELEASED; urgency=medium
linux (3.16.7-ckt7-1) UNRELEASED; urgency=medium
* New upstream stable update:
http://kernel.ubuntu.com/stable/ChangeLog-3.16.7-ckt5
@ -127,6 +127,37 @@ linux (3.16.7-ckt6-1) UNRELEASED; urgency=medium
- memcg: remove extra newlines from memcg oom kill log (regression in 3.15)
- ipv4: try to cache dst_entries which would cause a redirect
(regression in 3.16) (CVE-2015-1465)
http://kernel.ubuntu.com/stable/ChangeLog-3.16.7-ckt7
- [ppc64el] powerpc: add little endian flag to syscall_get_arch()
- [arm64] Fix up /proc/cpuinfo
- cifs: Complete oplock break jobs before closing file handle
(regression in 3.15)
- [arm64,or1k] lib/checksum.c: fix carry in csum_tcpudp_nofold
- [mips*] Fix kernel lockup or crash after CPU offline/online
- md/raid5: fix another livelock caused by non-aligned writes.
(regression in 3.16)
- drm/radeon: fix PLLs on RS880 and older v2 (regression in 3.15)
- [armhf/armmp-lpae] 8299/1: mm: ensure local active ASID is marked as
allocated on rollover
- PCI: Handle read-only BARs on AMD CS553x devices
(regression in 3.16.7-ckt4)
- mm: pagewalk: call pte_hole() for VM_PFNMAP during walk_page_range
- nilfs2: fix deadlock of segment constructor over I_SYNC flag
- ip: zero sockaddr returned on error queue
- net: rps: fix cpu unplug
- ipv6: stop sending PTB packets for MTU < 1280
- udp_diag: Fix socket skipping within chain
- ping: Fix race in free in receive path
- net: don't OOPS on socket aio
- ipv4: tcp: get rid of ugly unicast_sock
- ppp: deflate: never return len larger than output buffer
- [x86] hyperv: Fix the error processing in netvsc_send()
- Bluetooth: ath3k: workaround the compatibility issue with xHCI controller
- ceph: introduce global empty snap context
- drm/vmwgfx: Don't use memory accounting for kernel-side fence objects
- net:socket: set msg_namelen to 0 if msg_name is passed as NULL in msghdr
struct from userland.
- virtio_pci: defer kfree until release callback
[ Ian Campbell ]
* [armhf] Add DTB for Olimex A20-OLinuXino-LIME2. (Closes: #777455)
@ -142,6 +173,7 @@ linux (3.16.7-ckt6-1) UNRELEASED; urgency=medium
* rmap: Fix ABI change in 3.16.7-ckt5
* perf: Fix ABI change in 3.16.7-ckt6
* mm: Fix pagecache_get_page() ABI change in 3.16.7-ckt6
* tcp: Fix ABI change in 3.16.7-ckt7
[ Helge Deller ]
* [alpha] build debian-installer udeb packages

View File

@ -5,6 +5,8 @@ ignore-changes:
module:arch/x86/kvm/kvm
module:drivers/mtd/spi-nor/spi-nor
module:drivers/net/wireless/iwlwifi/iwlwifi
module:sound/i2c/other/snd-ak4113
module:sound/i2c/other/snd-ak4114
# Apparently not used OOT
__add_pages
__remove_pages

View File

@ -0,0 +1,84 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 25 Feb 2015 00:29:03 +0000
Subject: tcp: Fix ABI change in 3.16.7-ckt7
Forwarded: not-needed
Commit bdbbb8527b6f ('ipv4: tcp: get rid of ugly unicast_sock')
added netns_ipv4::tcp_sk. As struct netns_ipv4 is embedded in
struct net, we can't add any members there. Instead, move it
to the end of the containing structure and adjust its users
accordingly.
---
--- a/include/net/net_namespace.h
+++ b/include/net/net_namespace.h
@@ -130,6 +130,9 @@ struct net {
#endif
struct sock *diag_nlsk;
atomic_t fnhe_genid;
+#ifndef __GENKSYMS__
+ struct sock * __percpu *tcp_sk;
+#endif
};
#include <linux/seq_file_net.h>
--- a/include/net/netns/ipv4.h
+++ b/include/net/netns/ipv4.h
@@ -52,7 +52,6 @@ struct netns_ipv4 {
struct inet_peer_base *peers;
struct tcpm_hash_bucket *tcp_metrics_hash;
unsigned int tcp_metrics_hash_log;
- struct sock * __percpu *tcp_sk;
struct netns_frags frags;
#ifdef CONFIG_NETFILTER
struct xt_table *iptable_filter;
--- a/net/ipv4/tcp_ipv4.c
+++ b/net/ipv4/tcp_ipv4.c
@@ -684,7 +684,7 @@ static void tcp_v4_send_reset(struct soc
net = dev_net(skb_dst(skb)->dev);
arg.tos = ip_hdr(skb)->tos;
- ip_send_unicast_reply(*this_cpu_ptr(net->ipv4.tcp_sk),
+ ip_send_unicast_reply(*this_cpu_ptr(net->tcp_sk),
skb, ip_hdr(skb)->saddr,
ip_hdr(skb)->daddr, &arg, arg.iov[0].iov_len);
@@ -768,7 +768,7 @@ static void tcp_v4_send_ack(struct sk_bu
if (oif)
arg.bound_dev_if = oif;
arg.tos = tos;
- ip_send_unicast_reply(*this_cpu_ptr(net->ipv4.tcp_sk),
+ ip_send_unicast_reply(*this_cpu_ptr(net->tcp_sk),
skb, ip_hdr(skb)->saddr,
ip_hdr(skb)->daddr, &arg, arg.iov[0].iov_len);
@@ -2539,16 +2539,16 @@ static void __net_exit tcp_sk_exit(struc
int cpu;
for_each_possible_cpu(cpu)
- inet_ctl_sock_destroy(*per_cpu_ptr(net->ipv4.tcp_sk, cpu));
- free_percpu(net->ipv4.tcp_sk);
+ inet_ctl_sock_destroy(*per_cpu_ptr(net->tcp_sk, cpu));
+ free_percpu(net->tcp_sk);
}
static int __net_init tcp_sk_init(struct net *net)
{
int res, cpu;
- net->ipv4.tcp_sk = alloc_percpu(struct sock *);
- if (!net->ipv4.tcp_sk)
+ net->tcp_sk = alloc_percpu(struct sock *);
+ if (!net->tcp_sk)
return -ENOMEM;
for_each_possible_cpu(cpu) {
@@ -2558,7 +2558,7 @@ static int __net_init tcp_sk_init(struct
IPPROTO_TCP, net);
if (res)
goto fail;
- *per_cpu_ptr(net->ipv4.tcp_sk, cpu) = sk;
+ *per_cpu_ptr(net->tcp_sk, cpu) = sk;
}
net->ipv4.sysctl_tcp_ecn = 2;
return 0;

View File

@ -497,3 +497,4 @@ debian/revert-quota-switch-get_dqblk-and-set_dqblk-to-use-b.patch
debian/rmap-fix-abi-change-in-3.16.7-ckt5.patch
debian/perf-fix-abi-change-in-3.16.7-ckt6.patch
debian/mm-fix-pagecache_get_page-abi-change-in-3.16.7-ckt6.patch
debian/tcp-fix-abi-change-in-3.16.7-ckt7.patch