3c59x: Fix call to mdio_sync() with the wrong argument (Closes: #589989)

svn path=/dists/sid/linux-2.6/; revision=16005
This commit is contained in:
Ben Hutchings 2010-07-23 00:03:57 +00:00
parent 525c652f0e
commit 55022fb173
3 changed files with 34 additions and 0 deletions

1
debian/changelog vendored
View File

@ -15,6 +15,7 @@ linux-2.6 (2.6.32-18) UNRELEASED; urgency=low
(really closes: #534422, we hope)
* Revert "x86, paravirt: Add a global synchronization point for pvclock",
included in stable 2.6.32.16 (Closes: #588426)
* 3c59x: Fix call to mdio_sync() with the wrong argument (Closes: #589989)
[ Martin Michlmayr ]
* Add some patches from the Orion tree, including support for Marvell's

View File

@ -0,0 +1,32 @@
From d3928b11844fededd058aaa4ebcbbfedfc42e22b Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 23 Jul 2010 00:56:59 +0100
Subject: [PATCH] 3c59x: Fix call to mdio_sync() with the wrong argument
commit a095cfc40ec7ebe63e9532383c5b5c2a27b14075
"3c59x: Specify window explicitly for access to windowed registers"
changed the first parameter to mdio_sync(), from a pointer to the
register mapping, to a pointer to the vortex_private structure,
and changed all but one of the call sites. Fix that last one.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/3c59x.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/net/3c59x.c b/drivers/net/3c59x.c
index 3c85600..53a8ca5 100644
--- a/drivers/net/3c59x.c
+++ b/drivers/net/3c59x.c
@@ -1387,7 +1387,7 @@ static int __devinit vortex_probe1(struct device *gendev,
mii_preamble_required++;
if (vp->drv_flags & EXTRA_PREAMBLE)
mii_preamble_required++;
- mdio_sync(ioaddr, 32);
+ mdio_sync(vp, 32);
mdio_read(dev, 24, MII_BMSR);
for (phy = 0; phy < 32 && phy_idx < 1; phy++) {
int mii_status, phyx;
--
1.7.1

View File

@ -67,3 +67,4 @@ X features/all/rt28x0/remove-rt3090-driver.commands
+ bugfix/all/inotify-send-IN_UNMOUNT-events.patch
+ bugfix/all/sched-fix-over-scheduling-bug.patch
+ debian/revert-x86-paravirt-Add-a-global-synchronization-point.patch
+ bugfix/all/3c59x-Fix-call-to-mdio_sync-with-the-wrong-argument.patch