Update to 2.6.37

svn path=/dists/trunk/linux-2.6/; revision=16775
This commit is contained in:
Ben Hutchings 2011-01-05 02:42:33 +00:00
parent e782daae45
commit 546c3eebcb
4 changed files with 2 additions and 88 deletions

4
debian/changelog vendored
View File

@ -1,6 +1,6 @@
linux-2.6 (2.6.37~rc8-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (2.6.37-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
* New upstream release: http://kernelnewbies.org/Linux_2_6_37
[ Ben Hutchings ]
* i2c-i801: Include <linux/slab.h> (fixes FTBFS on alpha)

View File

@ -1,36 +0,0 @@
From b618f255525fcaa396f470aefeb144d049a3f7b6 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 28 Dec 2010 04:01:32 +0000
Subject: [PATCH] starfire: Fix dma_addr_t size test for MIPS
Commit 56543af "starfire: use BUILD_BUG_ON for netdrv_addr_t" revealed
that the preprocessor condition used to find the size of dma_addr_t
yielded the wrong result for some architectures and configurations.
This was kluged for 64-bit PowerPC in commit 3e502e6 by adding yet
another case to the condition. However, some MIPS configurations are
still handled incorrectly.
This should be fixed by using CONFIG_ARCH_DMA_ADDR_T_64BIT, but that
isn't yet defined everywhere it should be.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/starfire.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/net/starfire.c b/drivers/net/starfire.c
index 4adf124..a4f2bd5 100644
--- a/drivers/net/starfire.c
+++ b/drivers/net/starfire.c
@@ -148,7 +148,7 @@ static int full_duplex[MAX_UNITS] = {0, };
* This SUCKS.
* We need a much better method to determine if dma_addr_t is 64-bit.
*/
-#if (defined(__i386__) && defined(CONFIG_HIGHMEM64G)) || defined(__x86_64__) || defined (__ia64__) || defined(__alpha__) || defined(__mips64__) || (defined(__mips__) && defined(CONFIG_HIGHMEM) && defined(CONFIG_64BIT_PHYS_ADDR)) || (defined(__powerpc64__) || defined(CONFIG_PHYS_64BIT))
+#if (defined(__i386__) && defined(CONFIG_HIGHMEM64G)) || defined(__x86_64__) || defined (__ia64__) || defined(__alpha__) || (defined(CONFIG_MIPS) && ((defined(CONFIG_HIGHMEM) && defined(CONFIG_64BIT_PHYS_ADDR)) || defined(CONFIG_64BIT))) || (defined(__powerpc64__) || defined(CONFIG_PHYS_64BIT))
/* 64-bit dma_addr_t */
#define ADDR_64BITS /* This chip uses 64 bit addresses. */
#define netdrv_addr_t __le64
--
1.7.2.3

View File

@ -1,48 +0,0 @@
From 2e6e90d7a3336c6e04426190bac6067c6e4f241d Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 2 Jan 2011 21:36:13 +0000
Subject: [PATCH] watchdog: Improve failure message and documentation
The error message 'NMI watchdog failed to create perf event...'
currently prints the error value as a pointer, rather than extracting
the error code with PTR_ERR(). Fix that.
Add a note about the 'nowatchdog' kernel parameter to associate it
with this message.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
Documentation/kernel-parameters.txt | 2 +-
kernel/watchdog.c | 3 ++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/Documentation/kernel-parameters.txt b/Documentation/kernel-parameters.txt
index 7d0cead..6fc0cf4 100644
--- a/Documentation/kernel-parameters.txt
+++ b/Documentation/kernel-parameters.txt
@@ -1764,7 +1764,7 @@ and is between 256 and 4096 characters. It is defined in the file
nousb [USB] Disable the USB subsystem
- nowatchdog [KNL] Disable the lockup detector.
+ nowatchdog [KNL] Disable the lockup detector (NMI watchdog).
nowb [ARM]
diff --git a/kernel/watchdog.c b/kernel/watchdog.c
index d74e866..5b44d2c 100644
--- a/kernel/watchdog.c
+++ b/kernel/watchdog.c
@@ -366,7 +366,8 @@ static int watchdog_nmi_enable(int cpu)
goto out_save;
}
- printk(KERN_ERR "NMI watchdog failed to create perf event on cpu%i: %p\n", cpu, event);
+ printk(KERN_ERR "NMI watchdog failed to create perf event on cpu%i: %ld\n",
+ cpu, PTR_ERR(event));
return PTR_ERR(event);
/* success path */
--
1.7.2.3

View File

@ -44,8 +44,6 @@
+ debian/alpha-Do-not-use-Werror-for-arch-alpha.patch
+ bugfix/all/drm-nouveau-Only-select-ACPI_VIDEO-if-its-dependenci.patch
+ bugfix/all/i2c-i801-Include-linux-slab.h.patch
+ bugfix/mips/starfire-Fix-dma_addr_t-size-test-for-MIPS.patch
+ features/all/watchdog-Improve-failure-message-and-documentation.patch
+ features/all/r8712u-Switch-driver-to-use-external-firmware.patch
+ features/all/r8712u-Fix-external-firmware-loading.patch
+ bugfix/all/btrfs-Require-CAP_SYS_ADMIN-for-filesystem-rebalance.patch