aufs: Update support patchset to aufs4.x-rcN-20180611

This commit is contained in:
Ben Hutchings 2018-06-26 02:04:01 +01:00
parent c9c765a055
commit 544f15ac72
4 changed files with 159 additions and 89 deletions

1
debian/changelog vendored
View File

@ -21,6 +21,7 @@ linux (4.17.2-1) UNRELEASED; urgency=medium
* [x86] virt: vbox: Only copy_from_user the request-header once
(CVE-2018-12633)
* [x86] vboxguest: Enable VBOXGUEST and DRM_VBOXVIDEO as modules
* aufs: Update support patchset to aufs4.x-rcN-20180611
[ Romain Perier ]
* [x86] Enable DCN 1.0 Raven family (Closes #901349)

View File

@ -1,19 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Date: Wed Jun 6 14:11:07 2018 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.16 base patch
aufs4.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 6e950b8..7324ece 100644
index 9c125f7..4616bbf 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2485,6 +2485,19 @@ F: include/linux/audit.h
@@ -2519,6 +2519,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -34,10 +34,10 @@ index 6e950b8..7324ece 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index ee62d2d..4ca6361 100644
index 55cf554..bc965e5 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -691,6 +691,24 @@ static inline int is_loop_device(struct file *file)
@@ -713,6 +713,24 @@ static inline int is_loop_device(struct file *file)
return i && S_ISBLK(i->i_mode) && MAJOR(i->i_rdev) == LOOP_MAJOR;
}
@ -63,10 +63,10 @@ index ee62d2d..4ca6361 100644
static ssize_t loop_attr_show(struct device *dev, char *page,
diff --git a/fs/dcache.c b/fs/dcache.c
index 8945e6c..87c19c0 100644
index 2acfc69..ff338e2 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1205,7 +1205,7 @@ enum d_walk_ret {
@@ -1234,7 +1234,7 @@ enum d_walk_ret {
*
* The @enter() and @finish() callbacks are called with d_lock held.
*/
@ -76,7 +76,7 @@ index 8945e6c..87c19c0 100644
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 1e97f1f..8cd01f7 100644
index d737ff0..7550799 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -32,7 +32,7 @@
@ -98,10 +98,10 @@ index 1e97f1f..8cd01f7 100644
return error;
diff --git a/fs/inode.c b/fs/inode.c
index ef36236..929a5a3 100644
index 3b55391..e0c5255 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1659,7 +1659,7 @@ EXPORT_SYMBOL(generic_update_time);
@@ -1663,7 +1663,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -111,7 +111,7 @@ index ef36236..929a5a3 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index 9d1374a..26ef600 100644
index 5f75969..61129ff 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
@ -128,10 +128,10 @@ index 9d1374a..26ef600 100644
* vfsmount lock must be held for write
*/
diff --git a/fs/read_write.c b/fs/read_write.c
index f8547b8..0a5c47b 100644
index c4eabbf..ddd6e67 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -484,6 +484,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@@ -489,6 +489,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
return -EINVAL;
}
@ -161,7 +161,7 @@ index f8547b8..0a5c47b 100644
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index 39e2dc0..c5fb195 100644
index 005d09c..f617ab0 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -837,8 +837,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@ -189,7 +189,7 @@ index 39e2dc0..c5fb195 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index 6e0a2cb..a6891ee 100644
index b54e054..2860782 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -28,7 +28,7 @@
@ -214,7 +214,7 @@ index 279720d..76e38ea 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index c6baf76..71dc695 100644
index 760d8da..09a2542 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1270,6 +1270,7 @@ extern void fasync_free(struct fasync_struct *);
@ -225,7 +225,7 @@ index c6baf76..71dc695 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1722,6 +1723,7 @@ struct file_operations {
@@ -1724,6 +1725,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -233,7 +233,7 @@ index c6baf76..71dc695 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1792,6 +1794,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1794,6 +1796,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -246,7 +246,7 @@ index c6baf76..71dc695 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2196,6 +2204,7 @@ extern int current_umask(void);
@@ -2199,6 +2207,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -254,7 +254,7 @@ index c6baf76..71dc695 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2476,6 +2485,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2485,6 +2494,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -318,7 +318,7 @@ index 74b4911..19789fb 100644
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 89b5f83..0dca42f 100644
index 0233863..06e0d7a 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -140,7 +140,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];

View File

@ -1,17 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Date: Wed Jun 6 14:11:07 2018 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.16 mmap patch
aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 1a76d75..77f698e 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -2018,7 +2018,7 @@ static int map_files_get_link(struct den
@@ -2024,7 +2024,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -20,9 +22,11 @@ aufs4.16 mmap patch
path_get(path);
rc = 0;
}
diff --git a/fs/proc/nommu.c b/fs/proc/nommu.c
index 7563437..7c0dc0f 100644
--- a/fs/proc/nommu.c
+++ b/fs/proc/nommu.c
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_
@@ -45,7 +45,10 @@ static int nommu_region_show(struct seq_file *m, struct vm_region *region)
file = region->vm_file;
if (file) {
@ -34,9 +38,11 @@ aufs4.16 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index c486ad4..76b71f8 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -305,7 +305,10 @@ show_map_vma(struct seq_file *m, struct
@@ -305,7 +305,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -48,7 +54,7 @@ aufs4.16 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1722,7 +1725,7 @@ static int show_numa_map(struct seq_file
@@ -1726,7 +1729,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -57,9 +63,11 @@ aufs4.16 mmap patch
struct mm_struct *mm = vma->vm_mm;
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 5b62f57..dfb4a3b 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_fil
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -71,9 +79,11 @@ aufs4.16 mmap patch
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 02a616e..01b3bb9 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1380,6 +1380,28 @@ static inline void unmap_shared_mapping_
@@ -1380,6 +1380,28 @@ static inline void unmap_shared_mapping_range(struct address_space *mapping,
unmap_mapping_range(mapping, holebegin, holelen, 0);
}
@ -102,6 +112,8 @@ aufs4.16 mmap patch
extern int access_process_vm(struct task_struct *tsk, unsigned long addr,
void *buf, int len, unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 2161234..78aa367 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -251,6 +251,7 @@ struct vm_region {
@ -120,9 +132,11 @@ aufs4.16 mmap patch
void * vm_private_data; /* was vm_pte (shared mem) */
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index a5d21c4..e965e09 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -474,7 +474,7 @@ static __latent_entropy int dup_mmap(str
@@ -473,7 +473,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -131,9 +145,11 @@ aufs4.16 mmap patch
if (tmp->vm_flags & VM_DENYWRITE)
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index b4e54a9a..77892ae 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o \
interval_tree.o list_lru.o workingset.o \
@ -142,9 +158,11 @@ aufs4.16 mmap patch
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 0604cb0..45d2369 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2701,7 +2701,7 @@ int filemap_page_mkwrite(struct vm_fault
@@ -2700,7 +2700,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -153,9 +171,11 @@ aufs4.16 mmap patch
lock_page(page);
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index fc41c05..e376869 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -171,7 +171,7 @@ static struct vm_area_struct *remove_vma
@@ -180,7 +180,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -164,7 +184,7 @@ aufs4.16 mmap patch
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -896,7 +896,7 @@ again:
@@ -905,7 +905,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -173,7 +193,7 @@ aufs4.16 mmap patch
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1779,8 +1779,8 @@ out:
@@ -1820,8 +1820,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -183,7 +203,7 @@ aufs4.16 mmap patch
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2604,7 +2604,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2645,7 +2645,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -192,7 +212,7 @@ aufs4.16 mmap patch
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2623,7 +2623,7 @@ int __split_vma(struct mm_struct *mm, st
@@ -2664,7 +2664,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -201,7 +221,7 @@ aufs4.16 mmap patch
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2785,7 +2785,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2826,7 +2826,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -210,7 +230,7 @@ aufs4.16 mmap patch
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2860,10 +2860,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsign
@@ -2901,10 +2901,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -239,7 +259,7 @@ aufs4.16 mmap patch
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3171,7 +3188,7 @@ struct vm_area_struct *copy_vma(struct v
@@ -3220,7 +3237,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -248,9 +268,11 @@ aufs4.16 mmap patch
if (new_vma->vm_ops && new_vma->vm_ops->open)
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 1372373..6362dde 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm
@@ -629,7 +629,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -259,7 +281,7 @@ aufs4.16 mmap patch
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -767,7 +767,7 @@ static void delete_vma(struct mm_struct
@@ -767,7 +767,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -277,7 +299,7 @@ aufs4.16 mmap patch
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1364,10 +1364,10 @@ error_just_free:
@@ -1364,10 +1364,10 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)
@ -290,6 +312,9 @@ aufs4.16 mmap patch
kmem_cache_free(vm_area_cachep, vma);
return ret;
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..14efc4f
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@

View File

@ -1,17 +1,19 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 3 14:43:11 2018 +0900
Subject: aufs4.16 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8ed212d3987b8aed42d89dd0137bd44bad4a0a6c
Date: Wed Jun 6 14:11:07 2018 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/ed41e3660da6cb1b70e5adfa294f6dbc03bf6fb7
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
SPDX-License-Identifier: GPL-2.0
aufs4.16 standalone patch
aufs4.x-rcN standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index ff338e2..3e2bae8 100644
--- a/fs/dcache.c
+++ b/fs/dcache.c
@@ -1342,6 +1342,7 @@ rename_retry:
@@ -1342,6 +1342,7 @@ void d_walk(struct dentry *parent, void *data,
seq = 1;
goto again;
}
@ -19,7 +21,7 @@ aufs4.16 standalone patch
struct check_mount {
struct vfsmount *mnt;
@@ -2920,6 +2921,7 @@ void d_exchange(struct dentry *dentry1,
@@ -2942,6 +2943,7 @@ void d_exchange(struct dentry *dentry1, struct dentry *dentry2)
write_sequnlock(&rename_lock);
}
@ -27,9 +29,11 @@ aufs4.16 standalone patch
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index 183059c..35adee4 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
}
@ -37,9 +41,11 @@ aufs4.16 standalone patch
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 7550799..d403576 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, un
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -47,9 +53,11 @@ aufs4.16 standalone patch
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 7ec0b3e..819ee07 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -147,6 +147,7 @@ over:
@@ -147,6 +147,7 @@ struct file *get_empty_filp(void)
}
return ERR_PTR(-ENFILE);
}
@ -81,9 +89,11 @@ aufs4.16 standalone patch
void __init files_init(void)
{
diff --git a/fs/inode.c b/fs/inode.c
index e0c5255..ff36056 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1671,6 +1671,7 @@ int update_time(struct inode *inode, str
@@ -1672,6 +1672,7 @@ int update_time(struct inode *inode, struct timespec *time, int flags)
return update_time(inode, time, flags);
}
@ -91,9 +101,11 @@ aufs4.16 standalone patch
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 61129ff..5d3e0382 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *m
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -101,7 +113,7 @@ aufs4.16 standalone patch
/**
* mnt_drop_write - give up write access to a mount
@@ -851,6 +852,7 @@ int is_current_mnt_ns(struct vfsmount *m
@@ -851,6 +852,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
{
return check_mnt(real_mount(mnt));
}
@ -109,7 +121,7 @@ aufs4.16 standalone patch
/*
* vfsmount lock must be held for write
@@ -1892,6 +1894,7 @@ int iterate_mounts(int (*f)(struct vfsmo
@@ -1893,6 +1895,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -117,6 +129,8 @@ aufs4.16 standalone patch
static void cleanup_group_ids(struct mount *mnt, struct mount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index b7a4b6a..5a69d60 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -127,7 +141,7 @@ aufs4.16 standalone patch
#include <linux/fsnotify_backend.h>
#include "fsnotify.h"
@@ -109,6 +110,7 @@ void fsnotify_get_group(struct fsnotify_
@@ -109,6 +110,7 @@ void fsnotify_get_group(struct fsnotify_group *group)
{
refcount_inc(&group->refcnt);
}
@ -135,7 +149,7 @@ aufs4.16 standalone patch
/*
* Drop a reference to a group. Free it if it's through.
@@ -118,6 +120,7 @@ void fsnotify_put_group(struct fsnotify_
@@ -118,6 +120,7 @@ void fsnotify_put_group(struct fsnotify_group *group)
if (refcount_dec_and_test(&group->refcnt))
fsnotify_final_destroy_group(group);
}
@ -143,7 +157,7 @@ aufs4.16 standalone patch
/*
* Create a new fsnotify_group and hold a reference for the group returned.
@@ -147,6 +150,7 @@ struct fsnotify_group *fsnotify_alloc_gr
@@ -147,6 +150,7 @@ struct fsnotify_group *fsnotify_alloc_group(const struct fsnotify_ops *ops)
return group;
}
@ -151,9 +165,11 @@ aufs4.16 standalone patch
int fsnotify_fasync(int fd, struct file *file, int on)
{
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index e9191b4..1f8ccfa 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -108,6 +108,7 @@ void fsnotify_get_mark(struct fsnotify_m
@@ -108,6 +108,7 @@ void fsnotify_get_mark(struct fsnotify_mark *mark)
WARN_ON_ONCE(!refcount_read(&mark->refcnt));
refcount_inc(&mark->refcnt);
}
@ -161,7 +177,7 @@ aufs4.16 standalone patch
static void __fsnotify_recalc_mask(struct fsnotify_mark_connector *conn)
{
@@ -392,6 +393,7 @@ void fsnotify_destroy_mark(struct fsnoti
@@ -392,6 +393,7 @@ void fsnotify_destroy_mark(struct fsnotify_mark *mark,
mutex_unlock(&group->mark_mutex);
fsnotify_free_mark(mark);
}
@ -169,7 +185,7 @@ aufs4.16 standalone patch
/*
* Sorting function for lists of fsnotify marks.
@@ -606,6 +608,7 @@ err:
@@ -606,6 +608,7 @@ int fsnotify_add_mark_locked(struct fsnotify_mark *mark, struct inode *inode,
fsnotify_put_mark(mark);
return ret;
}
@ -177,7 +193,7 @@ aufs4.16 standalone patch
int fsnotify_add_mark(struct fsnotify_mark *mark, struct inode *inode,
struct vfsmount *mnt, int allow_dups)
@@ -741,6 +744,7 @@ void fsnotify_init_mark(struct fsnotify_
@@ -741,6 +744,7 @@ void fsnotify_init_mark(struct fsnotify_mark *mark,
fsnotify_get_group(group);
mark->group = group;
}
@ -185,9 +201,11 @@ aufs4.16 standalone patch
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index d0e955b..527bc1a 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, l
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
inode_unlock(dentry->d_inode);
return ret;
}
@ -195,9 +213,19 @@ aufs4.16 standalone patch
long vfs_truncate(const struct path *path, loff_t length)
{
@@ -723,6 +724,7 @@ SYSCALL_DEFINE3(fchown, unsigned int, fd, uid_t, user, gid_t, group)
{
return ksys_fchown(fd, user, group);
}
+EXPORT_SYMBOL_GPL(open_check_o_direct);
int open_check_o_direct(struct file *f)
{
diff --git a/fs/read_write.c b/fs/read_write.c
index ddd6e67..aabf92d 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -459,6 +459,7 @@ ssize_t vfs_read(struct file *file, char
@@ -459,6 +459,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
return ret;
}
@ -213,7 +241,7 @@ aufs4.16 standalone patch
vfs_writef_t vfs_writef(struct file *file)
{
@@ -510,6 +512,7 @@ vfs_writef_t vfs_writef(struct file *fil
@@ -510,6 +512,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -221,7 +249,7 @@ aufs4.16 standalone patch
ssize_t __kernel_write(struct file *file, const void *buf, size_t count, loff_t *pos)
{
@@ -579,6 +582,7 @@ ssize_t vfs_write(struct file *file, con
@@ -579,6 +582,7 @@ ssize_t vfs_write(struct file *file, const char __user *buf, size_t count, loff_
return ret;
}
@ -229,9 +257,11 @@ aufs4.16 standalone patch
static inline loff_t file_pos_read(struct file *file)
{
diff --git a/fs/splice.c b/fs/splice.c
index f617ab0..ec0ad02 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -850,6 +850,7 @@ long do_splice_from(struct pipe_inode_in
@@ -850,6 +850,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -239,7 +269,7 @@ aufs4.16 standalone patch
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -879,6 +880,7 @@ long do_splice_to(struct file *in, loff_
@@ -879,6 +880,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -247,9 +277,11 @@ aufs4.16 standalone patch
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index 2860782..ffd7ea4 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -39,6 +39,7 @@ int __sync_filesystem(struct super_block
@@ -39,6 +39,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
sb->s_op->sync_fs(sb, wait);
return __sync_blockdev(sb->s_bdev, wait);
}
@ -257,9 +289,11 @@ aufs4.16 standalone patch
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 61cd28b..35570cd 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -297,6 +297,7 @@ vfs_getxattr_alloc(struct dentry *dentry
@@ -297,6 +297,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}
@ -267,9 +301,11 @@ aufs4.16 standalone patch
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index 06e0d7a..6af91bd 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_
@@ -151,6 +151,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
@ -277,6 +313,8 @@ aufs4.16 standalone patch
#define hlock_class(hlock) lockdep_hlock_class(hlock)
#ifdef CONFIG_LOCK_STAT
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 0fef395..83fb1ec 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -116,3 +116,4 @@ void task_work_run(void)
@ -284,9 +322,11 @@ aufs4.16 standalone patch
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 1ce701f..a0d106e 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1330,12 +1330,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1332,12 +1332,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
@ -301,6 +341,8 @@ aufs4.16 standalone patch
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index c65b39b..e363d22 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -8,6 +8,7 @@
@ -311,14 +353,16 @@ aufs4.16 standalone patch
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -824,3 +825,4 @@ int __devcgroup_check_permission(short t
@@ -824,3 +825,4 @@ int __devcgroup_check_permission(short type, u32 major, u32 minor,
return 0;
}
+EXPORT_SYMBOL_GPL(__devcgroup_check_permission);
diff --git a/security/security.c b/security/security.c
index 7bc2fde..6bd0468 100644
--- a/security/security.c
+++ b/security/security.c
@@ -537,6 +537,7 @@ int security_path_rmdir(const struct pat
@@ -537,6 +537,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -326,7 +370,7 @@ aufs4.16 standalone patch
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -553,6 +554,7 @@ int security_path_symlink(const struct p
@@ -553,6 +554,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -334,7 +378,7 @@ aufs4.16 standalone patch
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -561,6 +563,7 @@ int security_path_link(struct dentry *ol
@@ -561,6 +563,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -342,7 +386,7 @@ aufs4.16 standalone patch
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -588,6 +591,7 @@ int security_path_truncate(const struct
@@ -588,6 +591,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -350,7 +394,7 @@ aufs4.16 standalone patch
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -595,6 +599,7 @@ int security_path_chmod(const struct pat
@@ -595,6 +599,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -358,7 +402,7 @@ aufs4.16 standalone patch
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -602,6 +607,7 @@ int security_path_chown(const struct pat
@@ -602,6 +607,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -366,7 +410,7 @@ aufs4.16 standalone patch
int security_path_chroot(const struct path *path)
{
@@ -687,6 +693,7 @@ int security_inode_readlink(struct dentr
@@ -687,6 +693,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -374,7 +418,7 @@ aufs4.16 standalone patch
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -702,6 +709,7 @@ int security_inode_permission(struct ino
@@ -702,6 +709,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -382,7 +426,7 @@ aufs4.16 standalone patch
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -873,6 +881,7 @@ int security_file_permission(struct file
@@ -873,6 +881,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -390,7 +434,7 @@ aufs4.16 standalone patch
int security_file_alloc(struct file *file)
{
@@ -932,6 +941,7 @@ int security_mmap_file(struct file *file
@@ -932,6 +941,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}