aufs: Update support patchset to aufs4.14-20171120

This commit is contained in:
Ben Hutchings 2017-11-21 16:20:07 +00:00
parent bf3c5027e0
commit 5436f201dd
4 changed files with 129 additions and 74 deletions

1
debian/changelog vendored
View File

@ -5,6 +5,7 @@ linux (4.14-1~exp2) UNRELEASED; urgency=medium
- i40e/i40evf: organize and re-number feature flags
- i40e: fix flags declaration
- Revert "i40e: Build for 64-bit targets only"
* aufs: Update support patchset to aufs4.14-20171120
-- Ben Hutchings <ben@decadent.org.uk> Mon, 20 Nov 2017 14:16:28 +0000

View File

@ -1,15 +1,15 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Thu Sep 28 22:42:44 2017 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/2fd397407f9d85de19dd837bc1a48b3872582366
Date: Thu Nov 16 10:20:27 2017 +0900
Subject: aufs4.14 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/bf518fb574cee10c6112f0e9ca5c67b277426630
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN base patch
aufs4.14 base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 6671f37..2cadb88 100644
index 2811a21..02b6deb 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2465,6 +2465,19 @@ F: include/linux/audit.h
@ -75,10 +75,10 @@ index f901413..e3719a5 100644
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 448a111..f51c2cf 100644
index 8d78ffd..cffefab 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -31,7 +31,7 @@
@@ -32,7 +32,7 @@
#define SETFL_MASK (O_APPEND | O_NONBLOCK | O_NDELAY | O_DIRECT | O_NOATIME)
@ -87,7 +87,7 @@ index 448a111..f51c2cf 100644
{
struct inode * inode = file_inode(filp);
int error = 0;
@@ -62,6 +62,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
@@ -63,6 +63,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
if (filp->f_op->check_flags)
error = filp->f_op->check_flags(arg);
@ -110,10 +110,10 @@ index d1e35b5..f7800d6 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/namespace.c b/fs/namespace.c
index 54059b1..4f508a1 100644
index d18deb4..e5a4a7f 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -844,6 +844,12 @@ static inline int check_mnt(struct mount *mnt)
@@ -846,6 +846,12 @@ static inline int check_mnt(struct mount *mnt)
return mnt->mnt_ns == current->nsproxy->mnt_ns;
}
@ -127,10 +127,10 @@ index 54059b1..4f508a1 100644
* vfsmount lock must be held for write
*/
diff --git a/fs/read_write.c b/fs/read_write.c
index a2b9a47..cfd7de4 100644
index 0046d72..2388284 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -483,6 +483,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@@ -484,6 +484,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
return -EINVAL;
}
@ -188,10 +188,10 @@ index f3084cc..eb888c6 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index a576aa2..eb61780 100644
index 83ac79a..fe15900 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -27,7 +27,7 @@
@@ -28,7 +28,7 @@
* wait == 1 case since in that case write_inode() functions do
* sync_dirty_buffer() and thus effectively write one block at a time.
*/
@ -201,10 +201,10 @@ index a576aa2..eb61780 100644
if (wait)
sync_inodes_sb(sb);
diff --git a/include/linux/file.h b/include/linux/file.h
index 61eb82c..e700888 100644
index 279720d..76e38ea 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -19,6 +19,7 @@ struct dentry;
@@ -20,6 +20,7 @@ struct dentry;
struct path;
extern struct file *alloc_file(const struct path *, fmode_t mode,
const struct file_operations *fop);
@ -213,10 +213,10 @@ index 61eb82c..e700888 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 339e737..b024533 100644
index 885266a..e489e42 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1264,6 +1264,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1265,6 +1265,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -224,7 +224,7 @@ index 339e737..b024533 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern int f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1710,6 +1711,7 @@ struct file_operations {
@@ -1711,6 +1712,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -232,7 +232,7 @@ index 339e737..b024533 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1780,6 +1782,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1781,6 +1783,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -245,7 +245,7 @@ index 339e737..b024533 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *);
@@ -2182,6 +2190,7 @@ extern int current_umask(void);
@@ -2183,6 +2191,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -253,7 +253,7 @@ index 339e737..b024533 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2462,6 +2471,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2463,6 +2472,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
@ -261,11 +261,32 @@ index 339e737..b024533 100644
extern int sync_filesystem(struct super_block *);
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h
index f301d31..c26f5b4 100644
--- a/include/linux/lockdep.h
+++ b/include/linux/lockdep.h
@@ -406,6 +406,8 @@ static inline int lockdep_match_key(struct lockdep_map *lock,
return lock->key == key;
}
+struct lock_class *lockdep_hlock_class(struct held_lock *hlock);
+
/*
* Acquire a lock.
*
@@ -530,6 +532,7 @@ struct lock_class_key { };
#define lockdep_depth(tsk) (0)
+#define lockdep_is_held(lock) (1)
#define lockdep_is_held_type(l, r) (1)
#define lockdep_assert_held(l) do { (void)(l); } while (0)
diff --git a/include/linux/mnt_namespace.h b/include/linux/mnt_namespace.h
index 12b2ab5..8b810d1 100644
index 3594208..24f5fd1 100644
--- a/include/linux/mnt_namespace.h
+++ b/include/linux/mnt_namespace.h
@@ -5,11 +5,14 @@
@@ -6,11 +6,14 @@
struct mnt_namespace;
struct fs_struct;
struct user_namespace;
@ -281,10 +302,10 @@ index 12b2ab5..8b810d1 100644
extern const struct file_operations proc_mountinfo_operations;
extern const struct file_operations proc_mountstats_operations;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index db42746..12f3a5a 100644
index 74b4911..19789fb 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -86,4 +86,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
@@ -87,4 +87,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;
extern const struct pipe_buf_operations default_pipe_buf_ops;
@ -295,3 +316,24 @@ index db42746..12f3a5a 100644
+ struct pipe_inode_info *pipe, size_t len,
+ unsigned int flags);
#endif
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index e36e652..bc97a97 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -144,7 +144,7 @@ static struct lock_list list_entries[MAX_LOCKDEP_ENTRIES];
unsigned long nr_lock_classes;
static struct lock_class lock_classes[MAX_LOCKDEP_KEYS];
-static inline struct lock_class *hlock_class(struct held_lock *hlock)
+inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
{
if (!hlock->class_idx) {
/*
@@ -155,6 +155,7 @@ static inline struct lock_class *hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
+#define hlock_class(hlock) lockdep_hlock_class(hlock)
#ifdef CONFIG_LOCK_STAT
static DEFINE_PER_CPU(struct lock_class_stats[MAX_LOCKDEP_KEYS], cpu_lock_stats);

View File

@ -1,18 +1,18 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Sep 22 11:57:33 2017 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/2fd397407f9d85de19dd837bc1a48b3872582366
Date: Thu Nov 16 10:20:27 2017 +0900
Subject: aufs4.14 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/bf518fb574cee10c6112f0e9ca5c67b277426630
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN mmap patch
aufs4.14 mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index ad3b076..ad4a50d 100644
index 9d357b2..11f4f23 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1987,7 +1987,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -1988,7 +1988,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -38,10 +38,10 @@ index 7563437..7c0dc0f 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 5589b4b..f60aea2 100644
index 6744bd7..6d4dea3 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -309,7 +309,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@@ -310,7 +310,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -53,7 +53,7 @@ index 5589b4b..f60aea2 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1734,7 +1737,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1739,7 +1742,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -63,10 +63,10 @@ index 5589b4b..f60aea2 100644
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index b00b7660..93e8a86 100644
index 5b62f57..dfb4a3b 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
@@ -156,7 +156,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -79,10 +79,10 @@ index b00b7660..93e8a86 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index f8c10d3..7241686 100644
index 43edf65..3f9acd9 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1348,6 +1348,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1349,6 +1349,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -112,10 +112,10 @@ index f8c10d3..7241686 100644
unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 46f4ecf5..1340df3 100644
index c85f11d..a63875a 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -260,6 +260,7 @@ struct vm_region {
@@ -261,6 +261,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -123,7 +123,7 @@ index 46f4ecf5..1340df3 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -334,6 +335,7 @@ struct vm_area_struct {
@@ -335,6 +336,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -132,10 +132,10 @@ index 46f4ecf5..1340df3 100644
atomic_long_t swap_readahead_info;
diff --git a/kernel/fork.c b/kernel/fork.c
index 1064618..8937405 100644
index 07cc743..b1d2b43 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -672,7 +672,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@@ -676,7 +676,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -145,10 +145,10 @@ index 1064618..8937405 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index e3ac3ae..745b26c 100644
index 4659b93..84488841 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@@ -40,7 +40,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o swap_slots.o \
interval_tree.o list_lru.o workingset.o \
@ -158,10 +158,10 @@ index e3ac3ae..745b26c 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 870971e..045dd0e 100644
index 594d73f..7183aef 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2582,7 +2582,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
@@ -2590,7 +2590,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Thu Sep 28 22:42:44 2017 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/2fd397407f9d85de19dd837bc1a48b3872582366
Date: Thu Nov 16 10:20:27 2017 +0900
Subject: aufs4.14 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/bf518fb574cee10c6112f0e9ca5c67b277426630
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN standalone patch
aufs4.14 standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index e3719a5..3203470 100644
@ -29,7 +29,7 @@ index e3719a5..3203470 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index ac34d97..f42757e 100644
index 3e14ba2..6818b01 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
@ -41,10 +41,10 @@ index ac34d97..f42757e 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index f51c2cf..58bf222 100644
index cffefab..725d190 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -84,6 +84,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
@@ -85,6 +85,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -101,10 +101,10 @@ index f7800d6..f31a6c7 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 4f508a1..c872ba2 100644
index e5a4a7f..6d0c376 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -515,6 +515,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@@ -517,6 +517,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -112,7 +112,7 @@ index 4f508a1..c872ba2 100644
/**
* mnt_drop_write - give up write access to a mount
@@ -849,6 +850,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
@@ -851,6 +852,7 @@ int is_current_mnt_ns(struct vfsmount *mnt)
{
return check_mnt(real_mount(mnt));
}
@ -120,7 +120,7 @@ index 4f508a1..c872ba2 100644
/*
* vfsmount lock must be held for write
@@ -1885,6 +1887,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1887,6 +1889,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -221,10 +221,10 @@ index 7ea1184..6e2e241 100644
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index cfd7de4..8623bd3 100644
index 2388284..b2a68e5 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -453,6 +453,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
@@ -454,6 +454,7 @@ ssize_t vfs_read(struct file *file, char __user *buf, size_t count, loff_t *pos)
return ret;
}
@ -232,7 +232,7 @@ index cfd7de4..8623bd3 100644
static ssize_t new_sync_write(struct file *filp, const char __user *buf, size_t len, loff_t *ppos)
{
@@ -493,6 +494,7 @@ vfs_readf_t vfs_readf(struct file *file)
@@ -494,6 +495,7 @@ vfs_readf_t vfs_readf(struct file *file)
return new_sync_read;
return ERR_PTR(-ENOSYS);
}
@ -240,7 +240,7 @@ index cfd7de4..8623bd3 100644
vfs_writef_t vfs_writef(struct file *file)
{
@@ -504,6 +506,7 @@ vfs_writef_t vfs_writef(struct file *file)
@@ -505,6 +507,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -248,7 +248,7 @@ index cfd7de4..8623bd3 100644
ssize_t __kernel_write(struct file *file, const void *buf, size_t count, loff_t *pos)
{
@@ -573,6 +576,7 @@ ssize_t vfs_write(struct file *file, const char __user *buf, size_t count, loff_
@@ -574,6 +577,7 @@ ssize_t vfs_write(struct file *file, const char __user *buf, size_t count, loff_
return ret;
}
@ -277,10 +277,10 @@ index eb888c6..7ab89d2 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index eb61780..32c5a05 100644
index fe15900..e3386ea 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -38,6 +38,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
@@ -39,6 +39,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
sb->s_op->sync_fs(sb, wait);
return __sync_blockdev(sb->s_bdev, wait);
}
@ -289,7 +289,7 @@ index eb61780..32c5a05 100644
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 4424f7f..15431ff 100644
index 61cd28b..35570cd 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -297,6 +297,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
@ -300,20 +300,32 @@ index 4424f7f..15431ff 100644
ssize_t
__vfs_getxattr(struct dentry *dentry, struct inode *inode, const char *name,
diff --git a/kernel/locking/lockdep.c b/kernel/locking/lockdep.c
index bc97a97..895a1ba 100644
--- a/kernel/locking/lockdep.c
+++ b/kernel/locking/lockdep.c
@@ -155,6 +155,7 @@ inline struct lock_class *lockdep_hlock_class(struct held_lock *hlock)
}
return lock_classes + hlock->class_idx - 1;
}
+EXPORT_SYMBOL_GPL(lockdep_hlock_class);
#define hlock_class(hlock) lockdep_hlock_class(hlock)
#ifdef CONFIG_LOCK_STAT
diff --git a/kernel/task_work.c b/kernel/task_work.c
index 836a72a..aa00d49 100644
index 5718b3e..e6c64d9 100644
--- a/kernel/task_work.c
+++ b/kernel/task_work.c
@@ -115,3 +115,4 @@ void task_work_run(void)
@@ -116,3 +116,4 @@ void task_work_run(void)
} while (work);
}
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index c25e0d2..9551659 100644
index fc46f5b..90543ef 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1269,12 +1269,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1270,12 +1270,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
@ -329,10 +341,10 @@ index c25e0d2..9551659 100644
#ifdef CONFIG_SECURITY
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 03c1652..f88c84b 100644
index 5ef7e52..e2e959d 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -7,6 +7,7 @@
@@ -8,6 +8,7 @@
#include <linux/device_cgroup.h>
#include <linux/cgroup.h>
#include <linux/ctype.h>
@ -340,7 +352,7 @@ index 03c1652..f88c84b 100644
#include <linux/list.h>
#include <linux/uaccess.h>
#include <linux/seq_file.h>
@@ -849,6 +850,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask)
@@ -850,6 +851,7 @@ int __devcgroup_inode_permission(struct inode *inode, int mask)
return __devcgroup_check_permission(type, imajor(inode), iminor(inode),
access);
}