* Add stable release 2.6.17.5.

* Add stable release 2.6.17.6.

* debian/changelog: Update.
* debian/patches/series/4
  - Add 2.6.17.5.
  - Add 2.6.17.6.
* debian/patches/2.6.17.5, debian/patches/2.6.17.6: Add.

svn path=/dists/trunk/linux-2.6/; revision=7029
This commit is contained in:
Bastian Blank 2006-07-15 19:49:32 +00:00
parent 2af11163d0
commit 533d12fe9d
4 changed files with 45 additions and 2 deletions

11
debian/changelog vendored
View File

@ -1,3 +1,12 @@
linux-2.6 (2.6.17-4) UNRELEASED; urgency=low
* Add stable release 2.6.17.5:
- Fix nasty /proc vulnerability (CVE-2006-3626)
* Add stable release 2.6.17.6:
- Relax /proc fix a bit
-- Bastian Blank <waldi@debian.org> Sat, 15 Jul 2006 21:46:05 +0200
linux-2.6 (2.6.17-3) unstable; urgency=low
[ maximilian attems ]
@ -33,8 +42,6 @@ linux-2.6 (2.6.17-3) unstable; urgency=low
* Fix README.Debian: Correct svn location, remove old boot param bswap
reference, the asfs patch is in the Debian kernel. Remove reference to
AMD 768 erratum 10, it was solved in 2.6.12. Add wording corrections.
* Add 686-bigmem flavour with CONFIG_HIGHMEM64G=y and CONFIG_X86_PAE=y.
Set deadline as default iosched and CONFIG_NR_CPUS=32. (closes: 295680)
* Set CONFIG_SERIAL_8250_RN_UARTS=16 for all archs beside mips/m68k unless
explicitly set on a specific value. (closes: 377151)
* Add stable release 2.6.17.4:

12
debian/patches/2.6.17.5 vendored Normal file
View File

@ -0,0 +1,12 @@
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 6cc77dc..5a8b89a 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1404,6 +1404,7 @@ static int pid_revalidate(struct dentry
} else {
inode->i_uid = 0;
inode->i_gid = 0;
+ inode->i_mode = 0;
}
security_task_to_inode(task, inode);
return 1;

22
debian/patches/2.6.17.6 vendored Normal file
View File

@ -0,0 +1,22 @@
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 5a8b89a..f801693 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1404,8 +1404,8 @@ static int pid_revalidate(struct dentry
} else {
inode->i_uid = 0;
inode->i_gid = 0;
- inode->i_mode = 0;
}
+ inode->i_mode &= ~(S_ISUID | S_ISGID);
security_task_to_inode(task, inode);
return 1;
}
@@ -1433,6 +1433,7 @@ static int tid_fd_revalidate(struct dent
inode->i_uid = 0;
inode->i_gid = 0;
}
+ inode->i_mode &= ~(S_ISUID | S_ISGID);
security_task_to_inode(task, inode);
return 1;
}

2
debian/patches/series/4 vendored Normal file
View File

@ -0,0 +1,2 @@
+ 2.6.17.5
+ 2.6.17.6