xhci-hcd: Include <linux/slab.h> in xhci-pci.c (fixes FTBFS on armel)

svn path=/dists/trunk/linux-2.6/; revision=17283
This commit is contained in:
Ben Hutchings 2011-05-02 19:04:13 +00:00
parent abf43d4e1b
commit 52d00b4c29
3 changed files with 34 additions and 0 deletions

4
debian/changelog vendored
View File

@ -1,8 +1,12 @@
linux-2.6 (2.6.39~rc5-1~experimental.2) experimental; urgency=low
[ maximilian attems ]
* Enable SQUASHFS_{LZO,XZ}. (closes: #613658)
* [x86] Enable EASYCAP. (closes: #624505)
[ Ben Hutchings
* xhci-hcd: Include <linux/slab.h> in xhci-pci.c (fixes FTBFS on armel)
-- maximilian attems <maks@debian.org> Tue, 01 May 2011 14:36:33 +0100
linux-2.6 (2.6.39~rc5-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,29 @@
Subject: [PATCH] xhci-hcd: Include <linux/slab.h> in xhci-pci.c
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 25 Apr 2011 16:54:28 +0100
Commit b02d0ed677acb3465e7600366f2353413bf24074 ('xhci: Change
hcd_priv into a pointer') added calls to kzalloc() and kfree() in
xhci-pci.c. On most architectures <linux/slab.h> is indirectly
included, but on some it is not.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/usb/host/xhci-pci.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/drivers/usb/host/xhci-pci.c b/drivers/usb/host/xhci-pci.c
index a10494c..cbc4d49 100644
--- a/drivers/usb/host/xhci-pci.c
+++ b/drivers/usb/host/xhci-pci.c
@@ -21,6 +21,7 @@
*/
#include <linux/pci.h>
+#include <linux/slab.h>
#include "xhci.h"
--
1.7.4.4

View File

@ -0,0 +1 @@
+ bugfix/all/xhci-hcd-Include-linux-slab.h-in-xhci-pci.c.patch