USB: serial: option: add two Longcheer device ids (Closes: #864604)

This commit is contained in:
Ben Hutchings 2017-06-18 21:05:59 +01:00
parent 0119f2ad46
commit 52978aae0c
3 changed files with 39 additions and 0 deletions

1
debian/changelog vendored
View File

@ -22,6 +22,7 @@ linux (4.11.6-1) UNRELEASED; urgency=medium
(Closes: #862842)
* [rt] Update to 4.11.5-rt1 and reenable
* fs: Reenable HPFS_FS as module (Closes: #864878)
* USB: serial: option: add two Longcheer device ids (Closes: #864604)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 06 Jun 2017 20:43:11 +0100

View File

@ -0,0 +1,37 @@
From: Johan Hovold <johan@kernel.org>
Date: Mon, 12 Jun 2017 16:30:16 +0200
Subject: USB: serial: option: add two Longcheer device ids
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Origin: https://git.kernel.org/pub/scm/linux/kernel/git/johan/usb-serial.git/commit?id=8fb060da715ad10fe956d7c0077b2fb0c12bb9d7
Bug-Debian: https://bugs.debian.org/864604
Add two Longcheer device-id entries which specifically enables a
Telewell TW-3G HSPA+ branded modem (0x9801).
Reported-by: Teemu Likonen <tlikonen@iki.fi>
Reported-by: Bjørn Mork <bjorn@mork.no>
Reported-by: Lars Melin <larsm17@gmail.com>
Tested-by: Teemu Likonen <tlikonen@iki.fi>
Cc: stable <stable@vger.kernel.org>
Signed-off-by: Johan Hovold <johan@kernel.org>
---
drivers/usb/serial/option.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/usb/serial/option.c b/drivers/usb/serial/option.c
index 3bf61acfc26b..ebe51f11105d 100644
--- a/drivers/usb/serial/option.c
+++ b/drivers/usb/serial/option.c
@@ -1877,6 +1877,10 @@ static const struct usb_device_id option_ids[] = {
.driver_info = (kernel_ulong_t)&four_g_w100_blacklist
},
{ USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, SPEEDUP_PRODUCT_SU9800, 0xff) },
+ { USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, 0x9801, 0xff),
+ .driver_info = (kernel_ulong_t)&net_intf3_blacklist },
+ { USB_DEVICE_INTERFACE_CLASS(LONGCHEER_VENDOR_ID, 0x9803, 0xff),
+ .driver_info = (kernel_ulong_t)&net_intf4_blacklist },
{ USB_DEVICE(LONGCHEER_VENDOR_ID, ZOOM_PRODUCT_4597) },
{ USB_DEVICE(LONGCHEER_VENDOR_ID, IBALL_3_5G_CONNECT) },
{ USB_DEVICE(HAIER_VENDOR_ID, HAIER_PRODUCT_CE100) },

View File

@ -69,6 +69,7 @@ bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
# Miscellaneous features
features/all/usb-serial-option-add-two-longcheer-device-ids.patch
# Lockdown (formerly 'securelevel') patchset
features/all/lockdown/0001-Annotate-module-params-that-specify-hardware-paramet.patch