debian/patches: Create manpages and binaries including the version.

svn path=/dists/trunk/linux-tools/; revision=18128
This commit is contained in:
Bastian Blank 2011-09-26 12:53:12 +00:00
parent badbaf4943
commit 51d0620a11
2 changed files with 45 additions and 0 deletions

View File

@ -1 +1,2 @@
modpost-symbol-prefix.patch
tools-perf-version.patch

44
debian/patches/tools-perf-version.patch vendored Normal file
View File

@ -0,0 +1,44 @@
--- a/tools/perf/Makefile
+++ b/tools/perf/Makefile
@@ -859,7 +859,7 @@
install: all
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'
- $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)'
+ $(INSTALL) $(OUTPUT)perf '$(DESTDIR_SQ)$(bindir_SQ)/perf_$(VERSION)'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
@@ -879,7 +879,7 @@
$(MAKE) -C Documentation install
install-man:
- $(MAKE) -C Documentation install-man
+ $(MAKE) -C Documentation install-man VERSION=$(VERSION)
install-html:
$(MAKE) -C Documentation install-html
--- a/tools/perf/Documentation/Makefile
+++ b/tools/perf/Documentation/Makefile
@@ -156,13 +156,15 @@
install: install-man
-install-man: man
+install-man: $(addprefix install-man-,$(DOC_MAN1))
+
+install-man-perf.1: perf.1
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
+ sed -e 's/"perf"/"perf_$(VERSION)"/' -e 's/fBperf-/fBperf_$(VERSION-)/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION).1
+
+install-man-perf%.1: perf%.1
$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)
-# $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
-# $(INSTALL) -d -m 755 $(DESTDIR)$(man7dir)
- $(INSTALL) -m 644 $(DOC_MAN1) $(DESTDIR)$(man1dir)
-# $(INSTALL) -m 644 $(DOC_MAN5) $(DESTDIR)$(man5dir)
-# $(INSTALL) -m 644 $(DOC_MAN7) $(DESTDIR)$(man7dir)
+ sed -e 's/"perf-/"perf_$(VERSION)-/' -e 's/fBperf-/fBperf_$(VERSION-)/g' $^ > $(DESTDIR)$(man1dir)/perf_$(VERSION)$*.1
install-info: info
$(INSTALL) -d -m 755 $(DESTDIR)$(infodir)