usb-audio: Define another USB ID for a buggy USB MIDI cable (Closes: #617743)

svn path=/dists/sid/linux-2.6/; revision=17212
This commit is contained in:
Ben Hutchings 2011-04-08 00:02:43 +00:00
parent 6228cfeac5
commit 50c2cf2d2b
3 changed files with 42 additions and 0 deletions

8
debian/changelog vendored
View File

@ -1,3 +1,11 @@
linux-2.6 (2.6.38-4) UNRELEASED; urgency=low
[ Ben Hutchings ]
* usb-audio: Define another USB ID for a buggy USB MIDI cable
(Closes: #617743)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 08 Apr 2011 00:59:57 +0100
linux-2.6 (2.6.38-3) unstable; urgency=low
[ Ben Hutchings ]

View File

@ -0,0 +1,33 @@
From: Tarek Soliman <tarek@bashasoliman.com>
Date: Mon, 4 Apr 2011 09:23:53 -0500
Subject: [PATCH] ALSA: usb-audio: define another USB ID for a buggy USB MIDI cable
commit 49c039f071d36586ba32da75996ef339e4ab8405 upstream.
There are many USB MIDI cables out there that have buggy
firmware that reports it can do more than 4 bytes in a
packet when they can only properly handle 4
This patch adds the ID of yet another one of those cables
Signed-off-by: Tarek Soliman <tarek@bashasoliman.com>
Signed-off-by: Takashi Iwai <tiwai@suse.de>
---
sound/usb/midi.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/sound/usb/midi.c b/sound/usb/midi.c
index b4b39c0..f928910 100644
--- a/sound/usb/midi.c
+++ b/sound/usb/midi.c
@@ -1301,6 +1301,7 @@ static int snd_usbmidi_out_endpoint_create(struct snd_usb_midi* umidi,
case USB_ID(0x15ca, 0x0101): /* Textech USB Midi Cable */
case USB_ID(0x15ca, 0x1806): /* Textech USB Midi Cable */
case USB_ID(0x1a86, 0x752d): /* QinHeng CH345 "USB2.0-MIDI" */
+ case USB_ID(0xfc08, 0x0101): /* Unknown vendor Cable */
ep->max_transfer = 4;
break;
/*
--
1.7.4.1

1
debian/patches/series/4 vendored Normal file
View File

@ -0,0 +1 @@
+ features/all/ALSA-usb-audio-define-another-USB-ID-for-a-buggy-USB.patch