* debian/changelog: Set version to 2.6.31~rc7-1~experimental.1.

* debian/patches/bugfix/all/perf_counter-default-idx-offset.patch: Remove.
* debian/patches/series/base: Remove merged patch.

svn path=/dists/trunk/linux-2.6/; revision=14164
This commit is contained in:
Bastian Blank 2009-08-22 11:53:11 +00:00
parent 2e8f15256e
commit 5065eaa86f
3 changed files with 2 additions and 53 deletions

6
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.31~rc6-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (2.6.31~rc7-1~experimental.1) UNRELEASED; urgency=low
* New upstream release.
- Support for W83627DHG-P (closes: #535646).
@ -78,13 +78,11 @@ linux-2.6 (2.6.31~rc6-1~experimental.1) UNRELEASED; urgency=low
used for experimental (trunk), oldstable and stable, but Vcs-*
doesn't yet provide the ability to distinguish branches in a
more fine-grained manner. (Closes: #471495)
[ dann frazier ]
* n_tty: Fix echo race
* [ia64] Stop disabling CONFIG_HOTPLUG_CPU, which was blocking
CONFIG_KEXEC from being enabled
* Specify a fallback PERF_COUNTER_INDEX_OFFSET for archs that
don't define it
* [hppa] Disable CONFIG_AB3100_CORE, it fails to build
-- maximilian attems <maks@debian.org> Thu, 18 Jun 2009 23:50:56 +0200

View File

@ -1,48 +0,0 @@
commit f738eb1b63edf664da1b4ac76895d988749b2f07
Author: Ingo Molnar <mingo@elte.hu>
Date: Tue Aug 18 11:32:24 2009 +0200
perf_counter: Fix the PARISC build
PARISC does not build:
/home/mingo/tip/kernel/perf_counter.c: In function 'perf_counter_index':
/home/mingo/tip/kernel/perf_counter.c:2016: error: 'PERF_COUNTER_INDEX_OFFSET' undeclared (first use in this function)
/home/mingo/tip/kernel/perf_counter.c:2016: error: (Each undeclared identifier is reported only once
/home/mingo/tip/kernel/perf_counter.c:2016: error: for each function it appears in.)
As PERF_COUNTER_INDEX_OFFSET is not defined.
Now, we could define it in the architecture - but lets also provide
a core default of 0 (which happens to be what all but one
architecture uses at the moment).
Architectures that need a different index offset should set this
value in their asm/perf_counter.h files.
Cc: Kyle McMartin <kyle@mcmartin.ca>
Cc: Helge Deller <deller@gmx.de>
Cc: linux-parisc@vger.kernel.org
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
Cc: Mike Galbraith <efault@gmx.de>
Cc: Paul Mackerras <paulus@samba.org>
Cc: Arnaldo Carvalho de Melo <acme@redhat.com>
Cc: Frederic Weisbecker <fweisbec@gmail.com>
LKML-Reference: <new-submission>
Signed-off-by: Ingo Molnar <mingo@elte.hu>
diff --git a/kernel/perf_counter.c b/kernel/perf_counter.c
index b8fe739..36f65e2 100644
--- a/kernel/perf_counter.c
+++ b/kernel/perf_counter.c
@@ -2019,6 +2019,10 @@ int perf_counter_task_disable(void)
return 0;
}
+#ifndef PERF_COUNTER_INDEX_OFFSET
+# define PERF_COUNTER_INDEX_OFFSET 0
+#endif
+
static int perf_counter_index(struct perf_counter *counter)
{
if (counter->state != PERF_COUNTER_STATE_ACTIVE)

View File

@ -29,4 +29,3 @@
#+ bugfix/all/wireless-regulatory-default-EU.patch
#+ features/sparc/video-sunxvr500-intergraph.patch
#+ bugfix/sparc/arch-zimage-target.patch
+ bugfix/all/perf_counter-default-idx-offset.patch