[armel/orion5x] Fix GPIO enable bits for MPP9 (Closes: #667446)

svn path=/dists/sid/linux-2.6/; revision=18913
This commit is contained in:
Ben Hutchings 2012-04-07 04:18:14 +00:00
parent dc1f49f9f6
commit 4ffe012c6f
3 changed files with 38 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (3.2.14-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* net: fix /proc/net/dev regression (Closes: #659499)
* [armel/orion5x] Fix GPIO enable bits for MPP9 (Closes: #667446)
[ Jonathan Nieder ]
* [x86] ioat: fix size of 'completion' for Xen (Closes: #660554)

View File

@ -0,0 +1,36 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 7 Apr 2012 04:57:36 +0100
Subject: [PATCH] ARM: orion5x: Fix GPIO enable bits for MPP9
Commit 554cdaefd1cf7bb54b209c4e68c7cec87ce442a9 seems to have
accidentally inverted the GPIO valid bits for MPP9 (only). For the
mv2120 platform which uses MPP9 as a GPIO LED device, this results in
the error:
[ 12.711476] leds-gpio: probe of leds-gpio failed with error -22
Reported-by: Henry von Tresckow <hvontres@gmail.com>
References: http://bugs.debian.org/667446
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
arch/arm/mach-orion5x/mpp.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/arm/mach-orion5x/mpp.h b/arch/arm/mach-orion5x/mpp.h
index eac6897..db70e79 100644
--- a/arch/arm/mach-orion5x/mpp.h
+++ b/arch/arm/mach-orion5x/mpp.h
@@ -65,8 +65,8 @@
#define MPP8_GIGE MPP(8, 0x1, 0, 0, 1, 1, 1)
#define MPP9_UNUSED MPP(9, 0x0, 0, 0, 1, 1, 1)
-#define MPP9_GPIO MPP(9, 0x0, 0, 0, 1, 1, 1)
-#define MPP9_GIGE MPP(9, 0x1, 1, 1, 1, 1, 1)
+#define MPP9_GPIO MPP(9, 0x0, 1, 1, 1, 1, 1)
+#define MPP9_GIGE MPP(9, 0x1, 0, 0, 1, 1, 1)
#define MPP10_UNUSED MPP(10, 0x0, 0, 0, 1, 1, 1)
#define MPP10_GPIO MPP(10, 0x0, 1, 1, 1, 1, 1)
--
1.7.9.5

View File

@ -92,3 +92,4 @@
# Temporary, until the next ABI bump
+ debian/revert-rtc-Provide-flag-for-rtc-devices-that-don-t-s.patch
+ bugfix/all/net-fix-proc-net-dev-regression.patch
+ bugfix/arm/-ARM-orion5x-Fix-GPIO-enable-bits-for-MPP9.patch