xfs: Fix possible memory corruption in xfs_readlink (CVE-2011-4077)

svn path=/dists/sid/linux-2.6/; revision=18209
This commit is contained in:
Ben Hutchings 2011-11-01 14:25:01 +00:00
parent 39c430be9f
commit 4f95622964
4 changed files with 65 additions and 0 deletions

1
debian/changelog vendored
View File

@ -30,6 +30,7 @@ linux-2.6 (3.0.0-6) UNRELEASED; urgency=low
* ark3116: Fix initialisation order (Closes: #640391)
* Add empty files to trigger generation of kernel-image udebs
* aufs: Update to aufs3.0-20111031 (Closes: #644687)
* xfs: Fix possible memory corruption in xfs_readlink (CVE-2011-4077)
-- Uwe Kleine-König <u.kleine-koenig@pengutronix.de> Fri, 07 Oct 2011 15:48:22 +0200

View File

@ -0,0 +1,18 @@
Subject: [PATCH] xfs: Fix possible memory corruption in xfs_readlink (2)
From: Ben Hutchings <ben@decadent.org.uk>
Previous fix doesn't check for integer overflow.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/fs/xfs/xfs_vnodeops.c
+++ b/fs/xfs/xfs_vnodeops.c
@@ -127,7 +127,7 @@ xfs_readlink(
if (!pathlen)
goto out;
- if (pathlen > MAXPATHLEN) {
+ if (pathlen < 0 || pathlen > MAXPATHLEN) {
xfs_alert(mp, "%s: inode (%llu) symlink length (%d) too long",
__func__, (unsigned long long)ip->i_ino, pathlen);
ASSERT(0);

View File

@ -0,0 +1,44 @@
Subject: [PATCH] Fix possible memory corruption in xfs_readlink
From: Carlos Maiolino <cmaiolino@redhat.com>
Date: Tue, 18 Oct 2011 02:18:58 -0200
Fixes a possible memory corruption when the link is larger than
MAXPATHLEN and XFS_DEBUG is not enabled. This also remove the
S_ISLNK assert, since the inode mode is checked previously in
xfs_readlink_by_handle() and via VFS.
Signed-off-by: Carlos Maiolino <cmaiolino@redhat.com>
[bwh: Adjust deleted S_ISLNK check for 3.0]
---
fs/xfs/xfs_vnodeops.c | 11 ++++++++---
1 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/fs/xfs/xfs_vnodeops.c b/fs/xfs/xfs_vnodeops.c
index 51fc429..c3288be 100644
--- a/fs/xfs/xfs_vnodeops.c
+++ b/fs/xfs/xfs_vnodeops.c
@@ -123,13 +123,18 @@ xfs_readlink(
xfs_ilock(ip, XFS_ILOCK_SHARED);
- ASSERT((ip->i_d.di_mode & S_IFMT) == S_IFLNK);
- ASSERT(ip->i_d.di_size <= MAXPATHLEN);
-
pathlen = ip->i_d.di_size;
if (!pathlen)
goto out;
+ if (pathlen > MAXPATHLEN) {
+ xfs_alert(mp, "%s: inode (%llu) symlink length (%d) too long",
+ __func__, (unsigned long long)ip->i_ino, pathlen);
+ ASSERT(0);
+ return XFS_ERROR(EFSCORRUPTED);
+ }
+
+
if (ip->i_df.if_flags & XFS_IFINLINE) {
memcpy(link, ip->i_df.if_u1.if_data, pathlen);
link[pathlen] = '\0';
--
1.7.6.2

View File

@ -12,3 +12,5 @@
+ features/all/aufs3/aufs3-kbuild.patch
+ features/all/aufs3/aufs3-add.patch
+ features/all/aufs2/mark-as-staging.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink.patch
+ bugfix/all/xfs-fix-memory-corruption-in-xfs_readlink-2.patch