[x86] Revert "KVM: Fix of previously incomplete fix for CVE-2014-8480" as that issue does not affect 3.16

svn path=/dists/sid/linux/; revision=22303
This commit is contained in:
Ben Hutchings 2015-01-29 04:51:00 +00:00
parent 4931fc74b2
commit 4f4c93c29b
3 changed files with 2 additions and 29 deletions

2
debian/changelog vendored
View File

@ -1,6 +1,8 @@
linux (3.16.7-ckt4-3) UNRELEASED; urgency=medium
* [sh4] ftrace: Remove -m32 option from recordmcount.pl (Closes: #775611)
* [x86] Revert "KVM: Fix of previously incomplete fix for CVE-2014-8480"
as that issue does not affect 3.16
-- Ben Hutchings <ben@decadent.org.uk> Wed, 28 Jan 2015 17:52:39 +0000

View File

@ -1,28 +0,0 @@
From: Nadav Amit <nadav.amit@gmail.com>
Date: Thu, 8 Jan 2015 11:59:03 +0100
Subject: KVM: x86: Fix of previously incomplete fix for CVE-2014-8480
Origin: https://git.kernel.org/linus/63ea0a49ae0b145b91ff2b070c01b66fc75854b9
STR and SLDT with rip-relative operand can cause a host kernel oops.
Mark them as DstMem as well.
Cc: stable@vger.linux.org
Signed-off-by: Nadav Amit <namit@cs.technion.ac.il>
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
---
arch/x86/kvm/emulate.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/arch/x86/kvm/emulate.c
+++ b/arch/x86/kvm/emulate.c
@@ -3737,8 +3737,8 @@ static const struct opcode group5[] = {
};
static const struct opcode group6[] = {
- DI(Prot, sldt),
- DI(Prot, str),
+ DI(Prot | DstMem, sldt),
+ DI(Prot | DstMem, str),
II(Prot | Priv | SrcMem16, em_lldt, lldt),
II(Prot | Priv | SrcMem16, em_ltr, ltr),
N, N, N, N,

View File

@ -492,6 +492,5 @@ bugfix/x86/x86_64-vdso-fix-the-vdso-address-randomization-algor.patch
bugfix/all/crypto-prefix-module-autoloading-with-crypto.patch
bugfix/all/crypto-include-crypto-module-prefix-in-template.patch
bugfix/all/crypto-add-missing-crypto-module-aliases.patch
bugfix/x86/kvm-x86-fix-of-previously-incomplete-fix-for-cve-201.patch
bugfix/x86/kvm-x86-sysenter-emulation-is-broken.patch
bugfix/sh4/scripts-recordmcount.pl-there-is-no-m32-option-on-super-h.patch