[powerpc*] Fix sstep compile on powerpcspe

Closes: #823526; thanks to Lennart Sorensen
This commit is contained in:
Ben Hutchings 2016-05-08 12:07:36 +01:00
parent d0b84ae1e7
commit 4ebee8024b
3 changed files with 51 additions and 0 deletions

2
debian/changelog vendored
View File

@ -2,6 +2,8 @@ linux (4.5.3-2) UNRELEASED; urgency=medium
* [s390x] PCI: Ignore zpci ABI changes; these functions are not used by
modules
* [powerpc*] Fix sstep compile on powerpcspe (Closes: #823526; thanks to
Lennart Sorensen)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 08 May 2016 11:56:07 +0100

View File

@ -0,0 +1,48 @@
From: "Lennart Sorensen" <lsorense@csclub.uwaterloo.ca>
Subject: powerpc: Fix sstep compile on powerpcspe
Date: Thu, 5 May 2016 16:44:44 -0400
Forwarded: http://news.gmane.org/gmane.linux.ports.ppc.embedded/95502
Bug-Debian: https://bugs.debian.org/823526
Commit be96f63375a14ee8e690856ac77e579c75bd0bae introduced ldarx and stdcx
into the instructions in sstep.c, which are not accepted by the assembler
on powerpcspe, but does seem to be accepted by the normal powerpc assembler
even in 32 bit mode.
Wrap these two instructions in a __powerpc64__ check like it is everywhere
else in the file.
Fixes: be96f63375a1 ("powerpc: Split out instruction analysis part of emulate_step()")
Signed-off-by: Len Sorensen <lsorense@csclub.uwaterloo.ca>
---
arch/powerpc/lib/sstep.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/arch/powerpc/lib/sstep.c b/arch/powerpc/lib/sstep.c
index dc885b3..6d34310 100644
--- a/arch/powerpc/lib/sstep.c
+++ b/arch/powerpc/lib/sstep.c
@@ -1818,9 +1818,11 @@ int __kprobes emulate_step(struct pt_regs *regs, unsigned int instr)
case 4:
__get_user_asmx(val, op.ea, err, "lwarx");
break;
+#ifdef __powerpc64__
case 8:
__get_user_asmx(val, op.ea, err, "ldarx");
break;
+#endif
default:
return 0;
}
@@ -1841,9 +1843,11 @@ int __kprobes emulate_step(struct pt_regs *regs, unsigned int instr)
case 4:
__put_user_asmx(op.val, op.ea, err, "stwcx.", cr);
break;
+#ifdef __powerpc64__
case 8:
__put_user_asmx(op.val, op.ea, err, "stdcx.", cr);
break;
+#endif
default:
return 0;
}

View File

@ -52,6 +52,7 @@ bugfix/arm/arm-dts-kirkwood-fix-sd-slot-default-configuration-f.patch
bugfix/sparc/sparc-implement-and-wire-up-modalias_show-for-vio.patch
bugfix/sparc/sparc-implement-and-wire-up-vio_hotplug-for-vio.patch
bugfix/x86/revert-sp5100_tco-fix-the-device-check-for-SB800-and.patch
bugfix/powerpc/powerpc-fix-sstep-compile-on-powerpcspe.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch