QNAP TS-11x/TS-21x: Add MPP36 (RAM) and MPP44 (board ID).

svn path=/dists/sid/linux-2.6/; revision=15864
This commit is contained in:
Martin Michlmayr 2010-06-13 18:36:01 +00:00
parent d434d32751
commit 4cb498cd81
4 changed files with 53 additions and 0 deletions

1
debian/changelog vendored
View File

@ -31,6 +31,7 @@ linux-2.6 (2.6.32-16) UNRELEASED; urgency=low
never made it upstream.
* ARM: update mach types.
* Add support for OpenRD-Ultimate.
* QNAP TS-11x/TS-21x: Add MPP36 (RAM) and MPP44 (board ID).
-- dann frazier <dannf@debian.org> Tue, 01 Jun 2010 09:23:57 -0600

View File

@ -0,0 +1,29 @@
From: Martin Michlmayr <tbm@cyrius.com>
Date: Thu, 5 Nov 2009 18:09:01 +0000 (+0000)
Subject: [ARM] Kirkwood: Add MPP36 for QNAP TS-11x/TS-21x
X-Git-Tag: v2.6.33-rc1~12^2~4^2~7
X-Git-Url: http://git.kernel.org/?p=linux%2Fkernel%2Fgit%2Fnico%2Forion.git;a=commitdiff_plain;h=b421950cdc7d0ac900414aa582c5e35aeab921c0
[ARM] Kirkwood: Add MPP36 for QNAP TS-11x/TS-21x
MPP36 is used on the QNAP TS-11x/TS-21x devices to indicate how
much RAM there is: it's high for 512 MB RAM (TS-x19) and low for
256 MB (TS-x10). While this may not be very useful, let's add
it for completeness.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
Signed-off-by: Nicolas Pitre <nico@marvell.com>
---
diff --git a/arch/arm/mach-kirkwood/ts219-setup.c b/arch/arm/mach-kirkwood/ts219-setup.c
index ec1a64f..cb0f56d 100644
--- a/arch/arm/mach-kirkwood/ts219-setup.c
+++ b/arch/arm/mach-kirkwood/ts219-setup.c
@@ -152,6 +152,7 @@ static unsigned int qnap_ts219_mpp_config[] __initdata = {
MPP14_UART1_RXD, /* PIC controller */
MPP15_GPIO, /* USB Copy button */
MPP16_GPIO, /* Reset button */
+ MPP36_GPIO, /* RAM: 0: 256 MB, 1: 512 MB */
0
};

View File

@ -0,0 +1,21 @@
Subject: [PATCH] Kirkwood: Add MPP44 (board ID) for QNAP TS-11x/TS-21x
MPP44 can be used to differentiate between one-bay (TS-11x) and
two-bay (TS-21x) devices.
According to an engineer from QNAP, the setting of MPP44 depends
on the firmware rather than hardware. Presumably, this means
that you could fake the MPP44 value by changing the boot loader.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
--- a/arch/arm/mach-kirkwood/ts219-setup.c 2010-06-13 18:31:20.000000000 +0000
+++ b/arch/arm/mach-kirkwood/ts219-setup.c 2010-06-13 18:31:54.000000000 +0000
@@ -153,6 +153,7 @@
MPP15_GPIO, /* USB Copy button */
MPP16_GPIO, /* Reset button */
MPP36_GPIO, /* RAM: 0: 256 MB, 1: 512 MB */
+ MPP44_GPIO, /* Board ID: 0: TS-11x, 1: TS-21x */
0
};

View File

@ -132,3 +132,5 @@
+ features/arm/mach-types-update-2010-06-13.patch
+ features/arm/openrd-combine.patch
+ features/arm/openrd-ultimate.patch
+ features/arm/ts219-mpp36.patch
+ features/arm/ts219-mpp44.patch