fix arm* builds

add relevant patch.
Thanks-to: Arnaud Patard <arnaud.patard@rtp-net.org>

svn path=/dists/trunk/linux/; revision=19573
This commit is contained in:
Maximilian Attems 2012-12-04 18:04:10 +00:00
parent f4cb9f38fc
commit 4c633edefe
3 changed files with 36 additions and 0 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux (3.6.9-1~experimental.1) UNRELEASED; urgency=low
* Enable NETFILTER_XT_TARGET_HMARK, NET_EMATCH_IPSET, USB_NET_QMI_WWAN.
* Enable more HID drivers.
* [x86] Enable INTEL_MEI.
* [ARM]: 7492/1: add strstr declaration for decompressors.
[ Ben Hutchings ]
* HID: Add Apple wireless keyboard 2011 ANSI to special driver list

View File

@ -0,0 +1,34 @@
From ef1c2096fcf390f2f6a6a835d9d26105e82abda5 Mon Sep 17 00:00:00 2001
From: Rob Herring <rob.herring@calxeda.com>
Date: Wed, 15 Aug 2012 16:28:36 +0100
Subject: [PATCH] ARM: 7492/1: add strstr declaration for decompressors
With the generic unaligned.h, more kernel headers get pulled in including
dynamic_debug.h which needs strstr. As it is not really used, we only need
a declaration here.
Signed-off-by: Rob Herring <rob.herring@calxeda.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnd Bergmann <arnd@arndb.de>
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
---
arch/arm/boot/compressed/decompress.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/arch/arm/boot/compressed/decompress.c b/arch/arm/boot/compressed/decompress.c
index f41b38c..9deb56a 100644
--- a/arch/arm/boot/compressed/decompress.c
+++ b/arch/arm/boot/compressed/decompress.c
@@ -32,6 +32,9 @@ extern void error(char *);
# define Tracecv(c,x)
#endif
+/* Not needed, but used in some headers pulled in by decompressors */
+extern char * strstr(const char * s1, const char *s2);
+
#ifdef CONFIG_KERNEL_GZIP
#include "../../../../lib/decompress_inflate.c"
#endif
--
1.8.0

View File

@ -49,3 +49,4 @@ debian/iwlwifi-do-not-request-unreleased-firmware.patch
debian/cirrus-disable-modeset-by-default.patch
debian/fs-enable-link-security-restrictions-by-default.patch
bugfix/all/hid-add-apple-wireless-keyboard-2011-ansi-to-special-driver-list.patch
bugfix/arm/ARM-7492-1-add-strstr-declaration-for-decompressors.patch