qla2xxx: fix kernel NULL pointer access (regression in 3.16) (Closes: #764804)

svn path=/dists/sid/linux/; revision=21942
This commit is contained in:
Ben Hutchings 2014-10-11 20:43:03 +00:00
parent 9ba2f0950c
commit 4c35143561
3 changed files with 40 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.16.5-2) UNRELEASED; urgency=medium
* qla2xxx: fix kernel NULL pointer access (regression in 3.16)
(Closes: #764804)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 11 Oct 2014 21:41:58 +0100
linux (3.16.5-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,32 @@
From: Himanshu Madhani <himanshu.madhani@qlogic.com>
Date: Thu, 25 Sep 2014 06:14:44 -0400
Subject: qla2xxx: fix kernel NULL pointer access
Origin: https://git.kernel.org/linus/78c2106a50e067f7168ee8c0944baaeb0e988272
This patch is to fix regression added by commit id
51a07f84649d2be206c4c2ad9a612956db0c2f8c.
When allocating memory for new session original patch does
not assign vha to op->vha resulting into NULL pointer
access during qlt_create_sess_from_atio().
Cc: <stable@vger.kernel.org>
Signed-off-by: Himanshu Madhani <himanshu.madhani@qlogic.com>
Signed-off-by: Saurav Kashyap <saurav.kashyap@qlogic.com>
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
drivers/scsi/qla2xxx/qla_target.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/scsi/qla2xxx/qla_target.c b/drivers/scsi/qla2xxx/qla_target.c
index aebe62c..43f9177 100644
--- a/drivers/scsi/qla2xxx/qla_target.c
+++ b/drivers/scsi/qla2xxx/qla_target.c
@@ -3277,6 +3277,7 @@ static int qlt_handle_cmd_for_atio(struct scsi_qla_host *vha,
return -ENOMEM;
memcpy(&op->atio, atio, sizeof(*atio));
+ op->vha = vha;
INIT_WORK(&op->work, qlt_create_sess_from_atio);
queue_work(qla_tgt_wq, &op->work);
return 0;

View File

@ -137,3 +137,4 @@ features/all/sfc-Add-40G-link-capability-decoding.patch
bugfix/s390/s390-3215-fix-tty-output-containing-tabs.patch
bugfix/all/fold-swapping-d_name.hash-into-switch_names.patch
bugfix/all/vfs-Don-t-exchange-short-filenames-unconditionally.patch
bugfix/all/qla2xxx-fix-kernel-NULL-pointer-access.patch