drivers/mfd/rtsx_usb.c: export device table (Closes: #761428)

svn path=/dists/sid/linux/; revision=21842
This commit is contained in:
Ben Hutchings 2014-09-13 21:28:30 +00:00
parent d624ad0698
commit 4bafad72b0
3 changed files with 41 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.16.2-4) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* drivers/mfd/rtsx_usb.c: export device table (Closes: #761428)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 13 Sep 2014 22:28:05 +0100
linux (3.16.2-3) unstable; urgency=medium
[ Ben Hutchings ]

View File

@ -0,0 +1,33 @@
From: Jeff Mahoney <jeffm@suse.com>
Date: Tue, 12 Aug 2014 13:46:09 -0700
Subject: drivers/mfd/rtsx_usb.c: export device table
Origin: https://git.kernel.org/linus/1813908986e36119228c158aae1c6a0267c99e77
The rtsx_usb driver contains the table for the devices it supports but
doesn't export it. As a result, no alias is generated and it doesn't
get loaded automatically.
Via https://bugzilla.novell.com/show_bug.cgi?id=890096
Signed-off-by: Jeff Mahoney <jeffm@suse.com>
Reported-by: Marcel Witte <wittemar@googlemail.com>
Cc: Roger Tseng <rogerable@realtek.com>
Cc: <stable@vger.kernel.org>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
drivers/mfd/rtsx_usb.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/mfd/rtsx_usb.c b/drivers/mfd/rtsx_usb.c
index 6352bec..71f387c 100644
--- a/drivers/mfd/rtsx_usb.c
+++ b/drivers/mfd/rtsx_usb.c
@@ -744,6 +744,7 @@ static struct usb_device_id rtsx_usb_usb_ids[] = {
{ USB_DEVICE(0x0BDA, 0x0140) },
{ }
};
+MODULE_DEVICE_TABLE(usb, rtsx_usb_usb_ids);
static struct usb_driver rtsx_usb_driver = {
.name = "rtsx_usb",

View File

@ -124,3 +124,4 @@ bugfix/all/libceph-do-not-hard-code-max-auth-ticket-len.patch
features/all/efi-autoload-efivars.patch
features/all/virtio-scsi-Implement-change_queue_depth-for-virtscs.patch
debian/revert-staging-sm7xxfb-remove-driver.patch
bugfix/all/drivers-mfd-rtsx_usb.c-export-device-table.patch