[x86] ACPI / video: ignore BIOS initial backlight value for HP Folio 13-2000 (Closes: #692361)

svn path=/dists/sid/linux/; revision=19590
This commit is contained in:
Ben Hutchings 2012-12-09 18:54:48 +00:00
parent 69c5409867
commit 4b4bd6faaa
3 changed files with 53 additions and 0 deletions

2
debian/changelog vendored
View File

@ -91,6 +91,8 @@ linux (3.2.35-1) UNRELEASED; urgency=low
* udeb: Add pata_piccolo to pata-modules (Closes: #695437)
* firmware_class: Log every success and failure against given device
* firmware: Remove redundant log messages from drivers
* [x86] ACPI / video: ignore BIOS initial backlight value for
HP Folio 13-2000 (Closes: #692361)
[ Ian Campbell ]
* [xen] add support for microcode updating. (Closes: #693053)

View File

@ -0,0 +1,49 @@
From: Zhang Rui <rui.zhang@intel.com>
Date: Tue, 4 Dec 2012 23:30:19 +0100
Subject: ACPI / video: ignore BIOS initial backlight value for HP Folio
13-2000
commit 129ff8f8d58297b04f47b5d6fad81aa2d08404e1 upstream.
Or else the laptop will boot with a dimmed screen.
References: https://bugzilla.kernel.org/show_bug.cgi?id=51141
Tested-by: Stefan Nagy <public@stefan-nagy.at>
Signed-off-by: Zhang Rui <rui.zhang@intel.com>
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
drivers/acpi/video.c | 14 ++++++++++++++
1 file changed, 14 insertions(+)
diff --git a/drivers/acpi/video.c b/drivers/acpi/video.c
index 0230cb6..ac9a69c 100644
--- a/drivers/acpi/video.c
+++ b/drivers/acpi/video.c
@@ -389,6 +389,12 @@ static int __init video_set_bqc_offset(const struct dmi_system_id *d)
return 0;
}
+static int video_ignore_initial_backlight(const struct dmi_system_id *d)
+{
+ use_bios_initial_backlight = 0;
+ return 0;
+}
+
static struct dmi_system_id video_dmi_table[] __initdata = {
/*
* Broken _BQC workaround http://bugzilla.kernel.org/show_bug.cgi?id=13121
@@ -433,6 +439,14 @@ static struct dmi_system_id video_dmi_table[] __initdata = {
DMI_MATCH(DMI_PRODUCT_NAME, "Aspire 7720"),
},
},
+ {
+ .callback = video_ignore_initial_backlight,
+ .ident = "HP Folio 13-2000",
+ .matches = {
+ DMI_MATCH(DMI_BOARD_VENDOR, "Hewlett-Packard"),
+ DMI_MATCH(DMI_PRODUCT_NAME, "HP Folio 13 - 2000 Notebook PC"),
+ },
+ },
{}
};

View File

@ -420,3 +420,5 @@ features/all/xen/microcode-typo.patch
bugfix/all/firmware_class-log-every-success-and-failure.patch
bugfix/all/firmware-remove-redundant-log-messages-from-drivers.patch
bugfix/x86/ACPI-video-ignore-BIOS-initial-backlight-value-for-H.patch