- Add patch to make Documentation/DocBook -j clean.

- Build doc and manual package ourself.

* debian/patches/series/0experimental.1: Add doc-build-parallel.patch.
* debian/patches/doc-build-parallel.patch: Add.
* debian/rules.real: Add code to build doc and manual package.

svn path=/dists/trunk/linux-2.6/; revision=6802
This commit is contained in:
Bastian Blank 2006-06-13 22:05:06 +00:00
parent 0b6d9516a6
commit 4aa4c15270
3 changed files with 34 additions and 15 deletions

13
debian/patches/doc-build-parallel.patch vendored Normal file
View File

@ -0,0 +1,13 @@
diff --git a/Documentation/DocBook/Makefile b/Documentation/DocBook/Makefile
index 5a2882d..71c7077 100644
--- a/Documentation/DocBook/Makefile
+++ b/Documentation/DocBook/Makefile
@@ -146,7 +146,7 @@ quiet_cmd_db2html = HTML $@
cp $(PNG-$(basename $(notdir $@))) $(patsubst %.html,%,$@); fi
quiet_cmd_db2man = MAN $@
- cmd_db2man = if grep -q refentry $<; then xmlto man $(XMLTOFLAGS) -o $(obj)/man $< ; gzip -f $(obj)/man/*.9; fi
+ cmd_db2man = if grep -q refentry $<; then xmlto man $(XMLTOFLAGS) -o $(obj)/man $< ; fi
%.9 : %.xml
@(which xmlto > /dev/null 2>&1) || \
(echo "*** You need to install xmlto ***"; \

View File

@ -4,6 +4,7 @@
+ modular-ide-pnp.patch
+ version.patch
+ kernelvariables.patch
+ doc-build-parallel.patch
#
+ ia64-irq-affinity-upfix.patch
+ powerpc-mkvmlinuz-support.patch

35
debian/rules.real vendored
View File

@ -183,26 +183,31 @@ install-base:
dh_md5sums
dh_builddeb
install-doc: PACKAGE_NAME_DOC = linux-doc-$(VERSION)
install-doc: PACKAGE_NAME_MANUAL = linux-manual-$(VERSION)
install-doc: SOURCE_DIR=$(BUILD_DIR)/source
install-doc: DIR=$(BUILD_DIR)/$@
install-doc: PACKAGE_DIR_DOC = $(CURDIR)/debian/$(PACKAGE_NAME_DOC)
install-doc: PACKAGE_DIR_MANUAL = $(CURDIR)/debian/$(PACKAGE_NAME_MANUAL)
install-doc: OUT_DIR_DOC = $(PACKAGE_DIR_DOC)/usr/share/doc/$(PACKAGE_NAME_DOC)
install-doc: DH_OPTIONS = -p$(PACKAGE_NAME_DOC) -p$(PACKAGE_NAME_MANUAL)
install-doc: $(STAMPS_DIR)/source
rm -rf '$(DIR)'
cp -al '$(SOURCE_DIR)' '$(DIR)'
mkdir -p '$(DIR)/debian'
cp debian/changelog '$(DIR)/debian'
cp debian/copyright '$(DIR)/debian'
cp debian/control '$(DIR)/debian/control'
touch '$(DIR)/debian/official'
rm '$(DIR)/Makefile'
sed -e 's,^EXTRAVERSION.*$$,EXTRAVERSION =,' < '$(SOURCE_DIR)/Makefile' > '$(DIR)/Makefile'
cd '$(DIR)' && $(setup_env) make-kpkg --stem linux \
--config defconfig kernel-manual
cat '$(DIR)/debian/files' >> debian/files
@for i in $$(awk '{ print $$1; }' '$(DIR)/debian/files'); do \
echo "mv \"$(BUILD_DIR)/$$i\" .."; \
mv "$(BUILD_DIR)/$$i" ..; \
done
rm -rf '$(DIR)'
dh_clean -d -k
cd '$(DIR)'; $(setup_env) make $(JOBS_ARG) htmldocs mandocs
DH_OPTIONS= dh_installman -p$(PACKAGE_NAME_MANUAL) '$(DIR)/Documentation/DocBook/'*.9 '$(DIR)/Documentation/DocBook/man/'*.9
cd $(DIR)/Documentation; \
find . \
-path './DocBook/man/*' -prune -o \
-path './DocBook/*' -a \( -name '*.tmpl' -o -name '*.xml' -o -name '*.9' \) -prune -o \
\( -name 'Makefile*' -o -name '.*.cmd' -o -name '.gitignore' \) -prune -o \
-print \
| \
cpio -pd --preserve-modification-time '$(OUT_DIR_DOC)/Documentation'
mv '$(OUT_DIR_DOC)/Documentation/DocBook' '$(OUT_DIR_DOC)/html'
-gzip -9qfr '$(OUT_DIR_DOC)/Documentation'
$(MAKE) -f debian/rules.real install-base
install-dummy:
dh_testdir